This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 1 reply, has 2 voices.

Last updated by Riffaz 1 year, 7 months ago.

Assigned support staff: Riffaz.

Author Posts
October 5, 2018 at 1:59 pm #2791006



I have a website already translated both in English and Dutch that works correctly.
English is now the Default Language. I want to switch it to Dutch.

As soon as I switch it to Dutch I got several issues:
1– The language switcher disappears.
2– The Main Menu (top) stays in English.
3– The categories of the posts also stay in English.

However, the rest of the content is in Dutch (text of the main page and of the posts)
I guess it's a problem related to the menus, because if I try delete the Language Switcher, I cannot activate it again, the bar is greyed out, they say I gave no menus.

I attached two screenshots with caption so you better understand the issue.

Any idea of what I should do?

P.S.: The Debug info is from the site when it is switched in Dutch.


October 8, 2018 at 12:05 pm #2795920


Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)


1– The language switcher disappears:
i. What are your results when using a footer language switcher ? (WPML->Languages->Add footer switcher)

ii. Does the secondary language have a full translation done ?
- go to WPML=>Languages=> enable "Link to home of language for missing translations"

2– The Main Menu (top) stays in English.
It seems you did not translate your menus to Dutch
Please translate your menu in Appearance > Menus > Translation : hidden link

Please refer :

3– The categories of the posts also stay in English.
I think you did not translate the categories as well.
Please translate them here : hidden link

Please refer :

And, please create new tickets for 1 and 3 if you have the issue even after you tried the above-mentioned steps.
So that will be easier and will not be confused/mixed. We are happy to help.

Let me know if you need further assistance regarding the 2nd one in this ticket.


The topic ‘[Closed] Switching default language keeps menus in English.’ is closed to new replies.