This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: I am trying to change languages on various different pages

Solution: - Go to WPML -> Settings -> Post Type Translation -> Set Pages to 'Translatable - only show translated items' -> Save the changes.

Relevant Documentation:

This topic contains 7 replies, has 2 voices.

Last updated by Carlos Rojas 11 months, 3 weeks ago.

Assigned support staff: Carlos Rojas.

Author Posts
October 17, 2018 at 11:08 pm

tonyD-4

I am trying to: Change languages on various different pages

Link to a page where the issue can be seen:
hidden link
hidden link

I expected to see:
The translated version of that page including the menu.

Instead, I got:
On the home page the menu changes but the body text stays in English. On other pages nothing happens at all, it says in English.

Most of the woocommerce pages work fine but sometimes they wont change back to english.

Everything is super glitchy and I just need someone to really have a look at whats going on.

October 18, 2018 at 7:46 pm #2829421

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.
I will do my best to help you solve this issue.

I would like to ask you to follow this steps:
- Back up your site first before making any change, this is for security reasons.
- Update the outdated plugins and theme to their latest version.
- Go to WPML -> Settings -> Post Type Translation -> Set 'Pages' to 'Translatable - only show translated items' -> Save the changes.
- Make sure the pages are fully translated.
- Go to WPML -> Languages -> Language filtering for AJAX operations -> Activate this option -> Save the changes.
- Go to WPML -> Support -> Troubleshooting link -> Click on 'Clear the cache in WPML' button and 'Set language information'
- Go to Settings -> Permalinks -> Common Settings -> Select 'Post name' -> Save the permalink structure.

Could you tell me if the issue persists?

Kind regards,
Carlos

October 18, 2018 at 8:41 pm #2829625

tonyD-4

I've done all of the above and its still having issues.
On this page the language switcher just refreshes the page still in English - hidden link

The shop page doesnt translate either - hidden link

Individual products translate but the images dont update (Notice the english has an updated image and the translation has the old image) - hidden link

October 19, 2018 at 3:15 am #2830445

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
Thank you very much for your feedback.

I would like to ask your authorization to make a copy of the site in order to make further test without affecting the production site.

Looking forward to your answer.
Best regards,
Carlos

October 22, 2018 at 8:28 pm #2839757

tonyD-4

Hi Carlos,

Sure go for it.

October 22, 2018 at 10:56 pm #2840020

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,
Thank you very much for your authorization.

Before I created the copy of the site I took another look at the WPML's settings in the site and it called my eye that the 'page' post type is set to 'Not Translatable'. I would like to ask you to follow this steps and let me know if the issue persists:
- Go to WPML -> Settings -> Post Type Translation -> Set Pages to 'Translatable - only show translated items' -> Save the changes.
- If the issue persists then activate the parent theme and check if the issue disappeared.

Could you tell me the result of this steps?

Regards,
Carlos

October 23, 2018 at 11:09 pm #2844199

tonyD-4

My issue is resolved now. Thank you!

October 24, 2018 at 3:53 am #2844818

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,

I'm glad to hear that the issue is solved 🙂

Please don't hesitate to contact us if you need our help in the future with WPML. We will be more than happy to help.
Best regards,
Carlos