This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 1 reply, has 2 voices.

Last updated by Diego Pereira 1 year, 7 months ago.

Assigned support staff: Diego Pereira.

Author Posts
October 11, 2018 at 8:15 am #2807138



We have had issues with a veeeeery slow backend for many years, and have discovered it depends on String Translations. With it activated it takes 5-10 minutes to update a product or go anywhere in the backend. If I translate 3 products I get Internal Servor Error.

However, deactivating String Translation solves the issue and it is pretty fast to do anything in the backend.

But, we need String translation otherwise a lot of content is not translated.

I googled and found many people with the same problem. One guy posted a solution to the problem. Which was this:

"Switching off the option (in string translation) to scan every plugin SOLVED (apparently) the problem. "

Could you tell me where I can switch of that option?

This is the link to the thread I read:

We just want a solution to this not, have been looking for 3 years with no results, until perhaps now.

Thank you

October 11, 2018 at 4:35 pm #2809139

Diego Pereira

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello @emeliec, welcome to the WPML support Forum!

These are the String Translator options that can be disabled to improve WPML performance:
- Adjust IDs for multilingual functionality (Available on WPML > Languages)
- Track where strings appear (Available on WPML > String translation)
- Auto register strings(Available on WPML > String translation)

Please also take a look at this article:

Please let me know if it worked for you.

All the best,