This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.


This topic contains 1 reply, has 2 voices.

Last updated by Vincenzo 2 years, 1 month ago.

Assigned support staff: Vincenzo.

Author Posts
May 12, 2018 at 12:30 pm


I am trying to:
Switch on "WPML Multilingual CMS"

Link to a page where the issue can be seen:
hidden link

I expected to see:
That the front page loads as it would load without the plugin

Instead, I got:
A very slow loading page

May 14, 2018 at 8:03 am #2112541


Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello, thank you for contacting WPML Support!

I understand you are having site performance issues.

I'd like to mention that's normal for WPML to have additional queries in order to get multilingual content.

The number of queries might depend on different factors like the number of elements that you are using on the page, the impact of your theme and the other plugins installed on your site.

Since performance issues can be difficult to pinpoint, let's check a few variables and settings to narrow the issue. Please answer as many of these questions as you can. Contact your hosting provider, if necessary.

Please keep WPML & all its add-on plugins enabled while we do these steps
❌ Before proceeding please make a full website backup! ❌

1. Can you add the Debug Information to the thread?

2. If you haven't already, can you review the following article? to ensure all relevant steps are followed?

3. Can you confirm that the following settings are OFF or disabled?
- Adjust IDs for multilingual functionality (WPML > Languages)
- Track where strings appear on the site (WPML > String translation)

4. Can you give me more information about the hardware of your hosting server including the CPU?

5. What type of hosting do you have? Shared, VPS, Dedicated, etc?

6. Do you know if object caching is part of your PHP setup?

7. Can you confirm that you are still experiencing performance issues with minimal set up (all plugins except WPML disabled and the theme on a WordPress default such as Twenty Fifteen)?

8. Are you using a cache plugin? If so, try disabling the cache plugin.

9. Make sure Disk caching is disabled.

10. Please use tools like pingdom (, google pagespeed insights or gtmetrix (hidden link) to find more factors that affect the speed of your site on the frontend.

I have run your site through these services and the "Time To First Byte" is quite good so I think there is room for optimization that has no direct relation to the WPML plugin.

Please make a test with and without WPML on any of these services:, and google pagespeed insights, as they may help you to evaluate the real impact of WPML on your page speed.

11. Please post here the results of these tests.

Thank you for helping us pinpoint the issue. Feel free to add any other information you may have.

The topic ‘[Closed] Switching "WPML Multilingual CMS" plugin on makes our site significant slow’ is closed to new replies.