This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 2 voices.

Last updated by Andreas W. 1 month ago.

Assigned support staff: Andreas W..

Author Posts
September 9, 2019 at 9:18 am #4535133

ahmede-28

I am having a products Sync issue between wpml english/arabic inventory of woocomerce

in english you will see that it shows instock (2)
in arabic for the same product you will see it shows (0)

link :
En : hidden link
Ar : hidden link

September 9, 2019 at 4:34 pm #4538925

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for contacting the WPML Support Forum.

Do I understand right, that those products are translated to 100%? Did you translate with the native WooCommerce Editor or are you using one of our WPML Translation Editors?

I can see that various plugins on your install are outdated. Could you please update WPML and its add-ons to the latest version and let us know if the issue persists?
Before doing it, please create a reliable backup of your site.

Also please go to WooCommerce -> WooCommerce Multingual and select the Status tab. Now click "Troubleshooting" in the right bottom corner. Run the available sync options and verify if the issue persists.

Let me know about the outcome.

Kind regards
Andreas

September 11, 2019 at 7:05 pm #4556009

ahmede-28

HI

i would like to update the plugins . yet when i tried that on m3roud.com website before , after the updates of the wpml plugins , all my arabic translation lost and went back to the default language english .

any suggustions ? i can give you access to see

September 11, 2019 at 11:10 pm #4556703

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for your message.

It seems we are having currently an issue with the automatic update process on some sites.

Can you please, try a manual update via FTP? Here is how:

1 - Download the mentioned plugin zip folders from your wpml.org account.

2 - Unzip them and upload the unzipped folder to your host wp-content/plugins folder replacing the current folders.

Note: I recommend you to delete the current plugin folders before updating the new ones. Also it is better if you put your website in a maintenance mode to avoid any issue for your users.

IMPORTANT: Please, note, a backup is required for security reasons and to avoid any data loss, you can use the https://wordpress.org/plugins/backupwordpress/ plugin for these backup needs.

Please, let me know if the workaround solved the issue.

Kind regards
Andreas

September 12, 2019 at 8:42 am #4559351

ahmede-28

HI

sure i will do that . I am just wondering , if i added these new plugins and i am already have my translations on those old plugin .

if i added the new ones , all translation will go back to default . what is the right process to update plugins while still having the translations as it is?

September 12, 2019 at 5:51 pm #4563809

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for your message.

Deleting the plugins will not harm your content or anz plugin settings, as those informations are saved inside of the database.

Let me know if it worked out.

Kind regards
Andreas

September 13, 2019 at 7:52 pm #4570561

ahmede-28

Hi

I did before deleted the plugin and installed and updated the new one . it caused all my translation work to go waste and i had to do it from zero again .

that happened on
test3.m3roud.sd

September 14, 2019 at 3:30 pm #4572867

ahmede-28

Hi

I am looking for urgent support please as some plugins stopped working now .

the string plugin disappeared from the wpml menu as well .

September 16, 2019 at 5:20 pm #4582863

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Did you try to upload the plugins manually to the server, as mentioned earlier?

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better to a testing site where the issue is replicated.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok with you.

IMPORTANT

Please make a backup of site files and database before providing us access.
If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link

Kind regards
Andreas

The topic ‘[Closed] Sync issue with woocomeerce when using arabic language’ is closed to new replies.