This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 16 replies, has 3 voices.

Last updated by Carlos Rojas 1 month ago.

Assigned support staff: Carlos Rojas.

Author Posts
May 30, 2020 at 3:31 pm #6256379

gilbertW-2

On my site, I sell beer. The bottles have a deposit. I use Woocommerce Force Sell to add the deposit on the beer cases and kegs.

Worked fine so far. Since the last update of WPML, the deposits disappear when I switch the language twice in the cart (from German to French, and from French back to German).

You can see this if you log on the following site with the following login:
***

1. Put a product in the cart (for example the "La Djéronimo" on the start page)
2. Go in the cart
3. You see the product with the deposit
4. Switch language in the top bar (ex: DE -> FR)
5. You see the product with the deposit
6. Switch language in the top bar (ex: FR -> DE)
7. You see the product alone. The deposit is gone!

I already talked to the guys of Woocommerce Force Sell, they say it is a WPML issue...

Your help would be very much appreciated!

June 1, 2020 at 12:05 pm #6265189

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Thank you for contacting WPML support!

While you are waiting for one of my colleagues to take this ticket and work on it, let me provide you with first debugging steps or if I can perhaps help with the issue quickly.

According to your debug information, you are not on the the latest versions of our plugins. Can you make sure they match these versions before we proceed debugging this?
https://wpml.org/account/downloads/

Also, would you be willing to provide us with WordPress admin credentials so we could investigate the issue directly?

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

I marked your next reply as private so that you can safely add credentials.

Regards,
Bruno Kos

June 3, 2020 at 12:21 pm #6283363

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hi Gilbert,
My name is Carlos and I will be taking this ticket from now long.

I just visited the site and I can see that there are a few important plugins outdated. I want to confirm with you that this is a staging site and I want to ask your authorization to run some tests on the site.

Regards,
Carlos

June 3, 2020 at 6:33 pm #6286641

gilbertW-2

Hi Carlos

Thanks for looking into this.

I confirm it's a staging site, you can run all the tests you like.

As the are plugin updates almost every day, there will always be a couple outdated one. I updated them all. The problem persists.

Kind Regards,
Gilbert

June 4, 2020 at 1:01 pm #6294079

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hi Gilbert,
Thank you very much for your confirmation.

I was able to reproduce the issue on the site. After deactivating all WPML plugins the issue persisted which lead me to believe that the issue is not caused by WPML, however when I deactivated all plugins in order to test in a minimal setup the site stop working and now I can't log in on the backend.

Could you re-create the staging site and let me know the results of the following steps:
- Re-create the staging site
- Deactivate all plugins except WPML plugins, Woocommerce, Woocommerce Multilingual, and the Force Sell plugin.
- Activate a default WordPress theme, like Twenty-Twenty.
- If the issue disappeared, start activating the theme and then the plugins one by one until the issue appears again.

Could you tell me the results of the steps above?

Regards,
Carlos

June 7, 2020 at 8:35 am #6313857

gilbertW-2

OK. I'll check this and come back to you.

June 7, 2020 at 6:58 pm #6315825

gilbertW-2

Hi Carlos

I did as you asked. All plugins except WPML, Woocommerce, Woocommerec Multilingual and Force Sell are deactivated. I changed the theme to Twenty-Twenty. And the problem persists...

I think it is definitely a WPML issue. This appeared when I last updated WPML.

You can test this as described in the first post.
-> Login in from here: hidden link
-> Access the shop from here (use the small bottles or the kegs to see the deposit): hidden link

Thanks for your help!

June 8, 2020 at 9:39 am #6319465

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hi,
Thank you for restoring the staging site.

Could you provide the steps to configure the 'WooCommerce Force Sells' plugin?

Regards,
Carlos

June 8, 2020 at 4:53 pm #6323685

gilbertW-2

Hi Carlos

Woocommerce Force Sells is an Add-On developed by Woocommerce itself.

There is nothing to configure. You simply get 2 more field (Normal Force Sell / Synced Force Sell) to link your product to another product. All is explained here: https://woocommerce.com/products/force-sells/

Kind Regards
Gilbert

June 9, 2020 at 12:43 pm #6331137

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hi Gilbert,

After running several tests the issue persists, which means that we might be facing a compatibility issue. For this reason, I decided to escalate this ticket to our compatibility team where our compatibility specialists will take a deeper look at the problem and will try to find a solution.

It will be very good if you could provide some contact information on the authors and let them know about this issue, this will speed up the process of finding a solution because our compatibility team might get in touch with them 🙂

Best regards,
Carlos

June 9, 2020 at 1:55 pm #6332005

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hi Gilbert,

Our 2nd tier specialists mentioned that for this kind of issues we have this option: https://wpml.org/documentation/related-projects/woocommerce-multilingual/clearing-cart-contents-when-language-or-currency-change/#prompt-for-a-confirmation-and-reset-the-cart due to the fact that switching languages at the cart is not that common, so the warning should be good enough. And on our side, complex carts are hard to switch to another language without issues.

Best regards,
Carlos

June 10, 2020 at 7:12 am #6338771

gilbertW-2

Hi Carlos

Thanks for the workaround. I agree with WPML that it's not very user friendly and a bit ugly...

The fact is that everything still works perfectly on my production system with the WPML Package versions in the screen shot below. The problem appears when I update.

Could your compatibility team please check what got broken in the process of the new developments? I don't think it's a very good practise to accept and drag such bugs along.

Cheers,
Gilbert

June 10, 2020 at 10:35 am #6340769

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hi Gilbert,

I have set your next answer private. Could you provide access to a site where I can see that the issue is not happening with an earlier version of WPML?

Also, could you authorize me to create a copy of that site?

Regards,
Carlos

June 11, 2020 at 9:41 am #6349505

gilbertW-2

Hi Carlos

I can do this. To do this, I'll have to delete the current staging environment and set up a new one.

Do you need the current staging environment showing the error? If yes, please do a copy of the current staging environment and tell me when I can replace it with the error free environment.

June 11, 2020 at 1:34 pm #6351425

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hi Gilbert,

I already made a copy of the actual staging site 🙂 You can delete it a create the new one.

I have set your next answer private again.
Regards,
Caros