This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 2 voices.

Last updated by paulC-62 1 month, 1 week ago.

Assigned support staff: Laura.

Author Posts
September 7, 2019 at 10:54 am #4529153

paulC-62

Hi, forgive me but I'm trying to achieve something that I thought might be straight forward, or I may be mis-interpreting the settings but here is what I would like to do:-

1) Create a field group in ACF.

2) Copy all fields to all my languages.

3) If I decide to add another field(s) to the English version, how would I go about synching/copying the same field(s) to all other languages?

This is just the field structure not the value.

Kind regards

September 9, 2019 at 7:34 am #4534081

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

when you do any changes to the original post/page, including adding "external" content like custom fields, you need to update and resave it.

This will push any changes to the translation and you should be able to find it.

If this is not the case, please provide me with a step-by-step process of what you have done so far and also with your debug information. You can find it in:
WPML -> Support -> click on debug information link
Then you can copy/paste the text you see in the Debug box I'll enable for the next answer.
More information here: http://wpml.org/faq/provide-debug-information-faster-support/

September 9, 2019 at 12:03 pm #4536887

paulC-62

Hi, so I've tried to document the steps I'm taking to make an ACF group appear under a different language, without having to manually re-create all the fields again on a per-language basis in under the ACF area.

I've attached some screenshots of the process I'm currently trying. Again, please advice on any mistakes I'm doing, or best practise to achieve what I need.

Step 1: Shows my ACF fields, in English, that I would like to appear under all languages.

Step 2 : I've added in a new test field.

Step 3 : I edit a page which show the ACF group and I add some value. I then click the 'Update' button.

Step 4 : I attempt to edit the German version of the page, but can't see the ACF grouping of 'Anchor Block 2019'?

Kind regards

September 9, 2019 at 2:27 pm #4537991

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

I think your problem here is that your field is a repeater field, and you need to set translation preference for it before being able to see it in the translated pages.

Please check here: https://wpml.org/documentation/related-projects/translate-sites-built-with-acf/#setting-the-translation-preference-for-repeater-fields

Let me know if this helps you or if you need further assistance.

September 9, 2019 at 3:25 pm #4538529

paulC-62

Ah I see. So I used the duplicate tutorial on that page, after creating a new ACF field group and that got my desired result, so thanks for that!

However once I managed to get the fields for all languages, I then added a new one under English, but is there then a way to update or sync the fields again across languages for that particular ACF field group?

I did notice that the field would copy to other languages but it would simply appear under the 'Custom Fields' area of the CMS and not as an expected ACF embedded field to edit.

Kind regards

September 10, 2019 at 7:42 am #4542609

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

do you have a screenshot for that? I'm not sure I got the problem correctly.

When a field is copied you can't edit it, so it's expected you don't have any embedded field to edit. If you are referring to the system field, they are not supposed to be edited in this case.

September 10, 2019 at 11:42 am #4544841

paulC-62

Hi, sure no problem, hopefully the following images and steps details what I'm trying to do:-

Step 1 : I create a new ACF Field group in English with one test field.

Step 2 : After saving I then 'duplicate' the ACF field group and field to all my required languages.

Step 3 : The German language now shows the ACF field group successfully duplicated over.

Step 4 : Next I create a new field for the same ACF field group and save.

Step 5 : The German ACF field group doesn't show the new field I just added.

Hopefully I've explained the potential issue okay? So what I want to know is, is there a way to re-sync the ACF field group across languages once I decide to add further fields to the original English group without having to manually re-create?

Kind regards

September 10, 2019 at 2:02 pm #4546227

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

what you did here is translating Field Group. This function is not used to add Fields to and ACF group, but to translate the interface.

See here: https://wpml.org/documentation/related-projects/translate-sites-built-with-acf/#translating-field-groups

As you can see in the box in the beginning, we say "If you only need to translate field values and display them on the front-end, you don’t need to perform the following steps. Proceed with the steps in this section only if you really need to have ACF interface translated."

And below, at point 6, we say "To keep your field groups consistent for all the languages of the site, you should only edit the label and descriptions of the fields and not add new fields or change their Field Name values. If you do any changes like this to the fields, you should do so for all your site’s languages."

So I think what is happening to you is expected - if you want to add the field to the other language you need to do so manually.
However, if you want to translate only the content for the new field you should have it already in the translation editor or in the WordPress edit page.

I hope my explanation is clear.

September 10, 2019 at 4:09 pm #4547197

paulC-62

Hi, yes I think that makes sense. However I just created a single field and tried to just translate the value this time but the field still doesn't show up in the translator? Please see my attachments and steps I've done:-

Step 1 : Created a simple single test field in English only

Step 2 : Create a new page and publish with content in the ACF field.

Step 3 : Attempt to translate the page into German but can't seem to see any of the ACF fields to translate their values.

What am I missing here?

Kind regards

September 11, 2019 at 10:01 am #4552375

paulC-62

My issue is resolved now. Thank you!