This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 3 voices.

Last updated by michalisV 7 months, 1 week ago.

Assigned support staff: Yvette.

Author Posts
February 19, 2019 at 6:11 pm #3218510

urdanetaZ

I am trying to:

I am trying to get our website translated. The original language is Chinese even tho most of our texts are duplicated in Chinese and English, but still the woo commerce checkout process and some areas need to have the possibility to switch languages, not just in Chinese. In the future we will make full English and full Chinese switch.

In any case my problem is:

I have started by translating one product and its attributes. What I get is that stock dose not synchronize, I have tested most of the solutions given to other costumers but I can not solve the issue. In my back end: Chinese stock (original language) shows as 4 , English stock shows as 0.
I have tested to manually change the English stock and do a test buy. With this still stock in between languages dose not get to synchronize.

Link to a page where the issue can be seen:

I expected to see:
hidden link

hidden link

February 20, 2019 at 1:37 pm #3221979

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

Please try the following steps.

1. Check for configuration errors
Please make sure there are no warnings/errors reported on these screens:
Woocommerce > Status
Woocommerce > Woocommerce Multilingual > Status

2. After correcting any errors, then please try the tool here:
Woocommerce > Woocommerce Multilingual > Status > Troubleshooting > Sync product stock quantity and status ( synchronizing min stock between translations )

After selecting it, choose "Start".

If these steps do not resolve your issues, please write back with system access details and a link to a specific product that is demonstrating the error. I am opening the private area for this information that is only visible between you and WPML SUpport.

February 20, 2019 at 4:30 pm #3222921

urdanetaZ

Hello again,
I have fixed all the issues that where shown under:

Woocommerce > Status
Woocommerce > Woocommerce Multilingual > Status

But after "Sync product stock quantity and status" I still have same issue,

chinese product (original) shows 4 in stock
english product stock shows 0 in stock

February 20, 2019 at 10:05 pm #3223954

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Thank you for having attempted the steps.

Temporary Access to your system
Please provide access to your system (wp-admin and ftp) so that I can further investigate this particular problem. The fields to provide this data are included in a private section that I will open for your next response. You can find it above the comments area. The information in this private section is only visible between WPML Support and you.

Please also send me links to test products that illustrate this problem on your site.

I´ll see what I can find.

February 21, 2019 at 9:53 am #3226165

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

The product you provided had no stock.
I tried to add the stock to the variations (100 each). But on save, I can now no longer see the variations and the product view still shows it is not purchasable.

I believe there is something else going on here.

Please do the following diagnostic:
1. Temporarily deactivate all non-WPML plugins and change your active themeto Storefront.
With this setup, are you still having the same issues with your stock synchronisation?

2. With that same setup, could you please provide a test case for me to confirm the behaviour?

Thanks

February 22, 2019 at 8:43 am #3231396

urdanetaZ

Hello,
Thanks for the quick replys,

Yes the English product dose not synchronize with the Chinese version product (original), and even if you do it manually it dose not allow you to buy it.

I have created an staging web site to try what you asked me:

I have deactivate all the plugins + download install and activate Storefront theme, after that I run the "Woocommerce > Woocommerce Multilingual > Status >Troubleshoot " and synchronize the stock.

Still same issue, English version stock still 0 even tho Chinese version (original) has 4.

This is the link to the staging web product english version
hidden link

Thanks

February 22, 2019 at 3:24 pm #3233021

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

THank you again for the staging site. It was a strange setup with your Chinese product having English language variations - I cannot imagine how that happened.

In any case, I reviewed your configuration settings and saw that you had your product post type set as "Trranslate" but your variations set as "Appear as translated". I suppose this could cause some confusion.

Here are the steps I did:
0. Deactivated all non-WPML plugins except for Woocommerce.

1. Changed the multilinugal content setup options for post type Product Variations to be "Translate"

2. Installed activated that "Duplicate Post" plugin

3. Created a clone of the test product you provided earlier.

4. I then re-translated the product to English.

5. I then rested changing the levels of stock. And this time, the translated product is correctly displaying the new stock quantities.

Here is the link to the new product : hidden link

Please use this as a test and see if the system is behaving as you expect now.

Thanks

March 18, 2019 at 3:53 pm #3371279

michalisV

Hello,
we were facing the same issue in our e-shop. We realised that in WPML settings and specifically in system fields, the field " _stock" was "not translate" instead of "Copy".

We chose the selection "copy" so we fix the problem of stock synchronisation.

However, we don't know how it happened. Is it because of an update? We have to check these settings in every update?

Thank you in advance.

The topic ‘[Closed] synchronization of stock not working’ is closed to new replies.