This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 16 replies, has 2 voices.

Last updated by Carlos Rojas 4 weeks ago.

Assigned support staff: Carlos Rojas.

Author Posts
September 4, 2019 at 9:21 am #4509657

emilieD-5

Hello,

I'm always using the same media (photos) content in both languages on my website.

I would love to be able to either only have one library for both languages (fr + eng) and be able to use the same images for my posts and galeries

Or be able to somehow synchronize the french library to the english one. If I delete one image in the english media library, it would be so easy that the french version acted like the other and update any change

Is there any way to do one or the other ?

My website link is : hidden link

Thank you
Emilie

September 4, 2019 at 2:32 pm #4512023

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello Emilie,
Thank you for contacting WPML support.

There is no option within WPML to remove an image and then the translation automatically gets deleted too. In this case, if you are going to use the same images in both language, I recommend you to not install Media Translation plugin.

In case you installed already, then follow this steps:
- Go to Media Library -> Select List view -> Switch to the secondary language using the admin menu at the top -> Select all images in the secondary language and delete them -> Deactivate Media Translation plugin.

Note: Please don't forget to create a full backup of the site before making any change in the site.

Kind regards,
Carlos

September 9, 2019 at 8:53 am #4534847

emilieD-5

Dear Carlos,
Thank your so much for your help
I did all the steps, delete the files in the french galerie
Only thing is, I don't see the Media Translation plugin

I have : WPML Multilingual CMS , WPML String Translation , WPML Translation Management installed

September 9, 2019 at 11:29 am #4536663

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

To install the Media Translation plugin you need to follow this steps:
- Go to Plugins -> Add new -> Commercial tab -> There you will be able to download an install the plugin.

Regards,
Carlos

September 9, 2019 at 2:30 pm #4538003

emilieD-5

Dear Carlos,
Thank you, but you told me to desactivate the plugin
I just don't know where to find it. it is not located in the plugin area
Thank you

September 9, 2019 at 3:39 pm #4538595

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

Could you tell me if the issue persists? Because if the Media Translation plugin is not active and if you removed the images from the secondary language then you shouldn't have any issue left 🙂

Regards,
Carlos

September 10, 2019 at 1:59 pm #4546199

emilieD-5

Hi,
I did remove the images from the secondary language.
One thing though. I created a gallerie in language #1 to see if the issue will persist. Then click on duplicate to create a language #2. Went to the media librairy in language #2 to see if it was still empty. 2 images appears... Seems to be the images used as featured images....
Why does still it duplicate the featured images ?
Thank you

September 10, 2019 at 2:37 pm #4546509

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

The images files aren't duplicated. Only new entries in the database are created pointing to the same file. This is correct and won't affect the site in any way.

Regards,
Carlos

September 17, 2019 at 7:46 am #4586129

emilieD-5

Hello Carlos,

My issue is not resolved yet !
Please find here the response of FLOTHEME. I contacted them for the same reason :

-----------

"Thank you for the provided screenshots.

We have inspected your website and found that the order of images output to users is affected by the "WPML" plugin (when using the "duplicate" function). We suggest contacting the WPML support team and kindly ask them to help with the issue inspection."

----------------------------

Thank you for helping,
Emilie

September 17, 2019 at 10:27 am #4587671

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Emilie,

As I mentioned earlier, WPML doesn't duplicate the image files, but it creates a new entry in the database for the images in the secondary language to save the metadata information. This way is possible to show different metadata for different languages when is necessary for each image.

This means that the images files aren't duplicated so no extra server space is consumed. This is the correct behavior of WPML. You can read more about this subject in the following link: https://wpml.org/documentation/getting-started-guide/media-translation/#media-translation-settings

Best regards,
Carlos

September 22, 2019 at 10:06 am #4618051

emilieD-5

Dear Carlos,

As you recommanded, I removed all media from the second language and deactivated the media translation option in the settings. I don't find any media translation plugin to uninstall.
Now all previously existing pages, posts and galleries from the second language are missing their images but I can't reassign them as they are not available in the media library.
How can I fix that ?

September 23, 2019 at 9:20 am #4621917

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,
Thank you very much for your message.

In this case I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Regards,
Carlos

September 23, 2019 at 2:58 pm #4625263

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,
Thank you very much for the information provided.

I need to ask you to add the user to the role of administrator, this way I will have access to all the functionalities of WPML in the site.

Also, please confirm you have a full backup of the site in case we need to restore it.
Regards,
Carlos

September 23, 2019 at 3:01 pm #4625295

emilieD-5

Carlos,
sure sorry I forgot
You're now an admin
And I confirmed that I did an full backup
Thank you 🙂

September 24, 2019 at 8:38 am #4629165

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

I applied some troubleshooting steps in the site. Could you tell me if the issue persists?

Also, there is a new release of WPML plugins and I would recommend you to update them.

Note: In case the issue persists I kindly ask you to provide some screenshots that shows the problem.

Regards,
Carlos