Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: Table wp_icl_string_pages is too big and site is slow is when String Translation is active

Solution: The site performance is improved after the following steps.

a) Upgrade to the latest version of WPML

b) Visit WPML>>Support>>Troubleshooting page, then click on *Recreate ST DB cache tables* button. This will clear the String Translation caches, including the *wp_icl_string_pages* table.

c) Visit WPML>>String Translation and enable *Auto-Registering* option for the all the String Domains.

Relevant Documentation:

67% of people find this useful.

Tagged: 

This topic contains 12 replies, has 3 voices.

Last updated by danielF-60 1 year ago.

Assigned support staff: Bigul.

Author Posts
November 21, 2018 at 8:21 am

danielJ-8

Hi,

we are having issues with the performance of this site when we activate the WPML Strings plugin.

We just find out that the table wp_icl_string_pages is extremely heavy and has 214 MB. See screenshot attached.

I have been investigating and I assume it has something to do with cleaning cache. Went to WPML>Support>Issues solution and I see to many option and don't what should I do.

Also I read in this thread:

https://wpml.org/forums/topic/wp_icl_string_pages-is-too-big-and-my-site-dies/

that a solution would be to truncate the table. But I don't know if this apply to my site.

We need a solution so that we do not loose any data and the site speed improves. Can you please advise on what steps to take?

I give you access to the site too.

Regards,
Daniel

November 23, 2018 at 6:21 am #2932777

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Daniel,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

We had this issue in the fast(too big wp_icl_string_pages table) and it is fixed in WPML 3.5.1. Please check the following Errata URL for more details.

https://wpml.org/errata/big-icl_string_pages-table-wpml-3-5-0-causes-performance-issues/

Have you upgraded from a very older version of WPML to 4.0.8 version?

Please try the following troubleshooting steps after a site backup and make sure the issue is existing or not.

1) Go to WPML>>Support page
2) Click on Troubleshooting link (blue link in the middle of the page)
3) In Troubleshooting page, please click on the following options of *Clean up* section. Wait for confirmation of processing after each one.

- Clear the cache in WPML
- Remove ghost entries from the translation tables
- Fix element_type collation
- Set language information
- Assign translation status to duplicated content
- Fix terms count
- Fix post type assignment
- Recreate ST DB cache tables

--
Thanks!

Bigul

November 23, 2018 at 8:33 am #2932992

danielJ-8

Hi,

I completed all those steps, but it looks like the tables get full after some time and the site gets very slowly again.

I have one question: In WPML > Support > Troubleshooting, the last option is "Reset" It says

"The 'Reset' action will deactivate the WPML plugin after it deletes the WPML tables (tables with the 'icl_' prefix) from the database. The action will NOT delete any content (posts, taxonomy terms etc.). It only affects translation and language information that WPML associates with each content type."

Is it safe to apply the Reset action and will it solve these issues? I installed the plugin "Query Monitor" and some slow queries come from plugins "sitepress-multilingual-cms" and from "wpml-string-translation"

Could you please acces the back-end and take a look? This is causing a lot of trouble and my customer is pushing us. I appreciate a solution.

Thanks!

November 23, 2018 at 2:14 pm #2934483

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Daniel,

Thank you for the updates. Once you *Reset* the WPML settings, you will lose all the WPML settings and translated data. So it is not recommended.

I would like to know which type of hosting you are using? Shared, VPS or Dedicated?

Please deactivate WPML String Translation for a moment and check is there any difference in site performance or not.

Maybe you are facing this issue because of compatibility conflicts. So to make sure if possible, please do the following steps.

a) Backup your site first
b) Switch for a moment to a WordPress default theme like 2017
c) Deactivate all the plugins that are not related to WPML
d) If the issue is gone, activate the plugin one by one to see with which one there is an interaction issue

--
Thanks!

Bigul

November 26, 2018 at 9:27 am #2939113

danielJ-8

There is no incompatibility with other plugins. I have created a copy of the site on another server and it works fine.

Can you please read my messages and give me a solution?

I am telling you that the table "wp_icl_string_pages table" increases its size too much and that makes the site very very slow.

Can you please tell me why that is and what can I do to stop that table to refill and grow that much?

Thanks!

November 26, 2018 at 2:17 pm #2940479

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Daniel,

Thank you for the updates. For your kind information, this may be happening because of multiple reasons. Most probably because of the compatibility issues with the theme or other plugins.

I have checked about this our team. We have a couple of requests to track the issue.

1) Please visit WPML>>Support>>Troubleshooting page, then click on *Recreate ST DB cache tables* button. This will clear the String Translation caches, including the *wp_icl_string_pages* table. After that please make sure the *wp_icl_string_pages* table size is decreased and the site is performing faster now or not

2) If you are still having the issues. Please give me permission for the following.

a) Install *ARI Adminer* plugin - https://wordpress.org/plugins/ari-adminer/ to cross check your *wp_icl_string_pages* table.

b) Make a duplicator copy of your site using the Duplicator plugin(https://wordpress.org/plugins/duplicator/) for debugging the issue on my local server.

--
Thanks!

Bigul

November 26, 2018 at 4:10 pm #2941194

danielJ-8

Ok.

I installed RUNAdminer and clicked on "Recreate ST DB cache tables". I attach a screenshot of the tables before the reset.

I'd like to know:

1) is the size of any table extremely heavy so that it could be decreasing the site speed?

2) the site has enough resources and memory to run faster. However it looks like the Strings plugin is making it slower. Can you please check that?

I have made a copy of the site on my server and it runs much much faster. Check out here:

hidden link

You have permision to install Duplicator plugin and make a copy.

I need a detailed explanation of why the site is so slow when we activate Strings. The customer is pushing me and I need a solution asap.

Thanks for your help!

November 27, 2018 at 9:44 am #2943355

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Daniel,

Thank you for the details. I went through your actual site and the copy hosted in Cloudways. I can see the difference. On your actual site, the WPML support page is showing a conflict in the memory. Please check the attached images.

Therefore I would like to know the following about the hosting you are using for the actual site.

a) Which type of hosting you are using? Shared, VPS or Dedicated?

b) Does it support object caching?

For your kind updates, I have shared the details with our second tier team for the expert opinion and waiting for their feedback now. We will get back to you soon.

--
Thanks!

Bigul

November 27, 2018 at 11:44 am #2943948

danielJ-8

I think it's a shared hosting.

About the caching, should I activate the option "memcached" in the Cpanel? See screenshot.

Thanks

November 27, 2018 at 4:41 pm #2945144

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Daniel,

Thank you for the updates. I have forwarded it our team(especially about the the *Memcache*). I will update you about it as soon as possible.

As per the advice of our second tier team I have enabled *Auto-Registering* option for the all the String Domains. After that, the pages are loading faster for me. Please check the attached images for more details and let me know your feedback.

--
Thanks!

Bigul

November 28, 2018 at 3:25 pm #2948909

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Daniel,

For your kind updates, the *memcached* option of your CPanel is a PHP module. PHP module by itself not effective if there is no separate service *Memcache* that runs on the hosting.

Therefore please check with your hosting that they support *Memcache* or *Object cache* as a special service.

--
Thanks!

Bigul

November 28, 2018 at 3:29 pm #2948942

danielJ-8

My issue is resolved now. Thank you!

September 5, 2019 at 6:09 am #4515617

danielF-60

Hi danielJ, what did resolve the issue finally?

Thanks a lot for oyur feedback!