This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 4 replies, has 2 voices.

Last updated by davideG-16 1 year, 9 months ago.

Assigned support staff: Noman.

Author Posts
December 28, 2017 at 10:00 pm #1467638

davideG-16

Tell us what you are trying to do?
I'm setting through search console google the sitemap and I found this: "Il tuo sito non ha tag hreflang" so the english version is not visible to google?

Is there any documentation that you are following?
I saw many post without find a solution

Is there a similar example that we can see?

What is the link to your site?
hidden link

Tks in advance for support.

December 29, 2017 at 9:42 am #1467782

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi Davide,

Thank you for contacting WPML Support. Href langs are set automatically once you add multiple languages or translations for your site.

Read here for more info: https://wpml.org/forums/topic/google-your-site-has-no-hreflang-tags/#post-707945

Doc - Adding hreflang to Multilingual WordPress Sites:
https://wpml.org/documentation/support/adding-hreflang-wordpress/

Thank you

December 29, 2017 at 2:15 pm #1467972

davideG-16

Hi, you said "Href langs are set automatically once you add multiple languages or translations for your site" but my site is multilanguages (IT and EN). You link me a post where the link is hidden, so I don't know how can I do.

Could you explain me in few step how can I do? I saw this : https://wpml.org/documentation/support/adding-hreflang-wordpress/
but without understand what I have to do...

January 1, 2018 at 3:46 pm #1468912

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi Davide,

Here is link that was hidden:
hidden link

Please send me screenshot where you facing this error:
"Il tuo sito non ha tag hreflang"

Also, please add the debug report in the Debug Information box. I have also enabled debug info box for your next reply: https://wpml.org/faq/provide-debug-information-faster-support/

Please enable WordPress Debug mode and check if there are any code related errors shown on the page - How to enable Debug mode: https://wpml.org/documentation/support/debugging-wpml/

WPML added hreflang properly, you can see in attached screenshots and it seems all fine.

Thank you

January 9, 2018 at 5:58 pm #1478481

davideG-16

Hi, now is all right, in the search console the hreflang are visible.