This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: I am trying to recreate the Tagalog menu. But menu shows only the default WP top level page menu, not the full menu.

Solution: It was a conflict with NextScripts: Social Networks Auto-Poster plugin. Deactivating the plugin solved the issue.

Tagged: 

This topic contains 2 replies, has 2 voices.

Last updated by Andrew Dunne 1 year, 5 months ago.

Assigned support staff: Noman.

Author Posts
May 10, 2018 at 12:20 am #2063896

Andrew Dunne

I am trying to: recreate the Tagalog menu

Link to a page where the issue can be seen: hidden link

I expected to see: A menu layout similar to hindi or english

Instead, I got: the default WP top level page menu.

I have tried to reset the menu using WP Menus Sync as well as doing it manually but bth option time out. This doesn't occur with english or hindi menus

May 10, 2018 at 3:08 pm #2075430

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi Andrew Dunne,

Thank you for contacting WPML Support.

- I have noticed that your website’s WP Memory Limit is 40MB. The WP memory limit needs to be increased, it's different than php memory. PHP memory is fine but WordPress uses 40MB as default in your site. Minimum requirements for WPML are 128Mb: https://wpml.org/home/minimum-requirements/

Please add this to the top of wp-config.php to increase WP memory:

/* WP Memory Limit */
define('WP_MEMORY_LIMIT', '512M');
define( 'WP_MAX_MEMORY_LIMIT', '512M');

- Please increase MaxInputVars to 10000 or more. For this, please try to set this variables in your php.ini:

max_input_vars = 10000;
suhosin.post.max_vars = 10000;
suhosin.request.max_vars = 10000;

You may need to contact your hosting provider to set them.

- Please enable error reporting at you site and let me know if any error found.
To enable it, open your ‘wp-config.php’ file and look for ‘define(‘WP_DEBUG’, false);’. Change it to:

define('WP_DEBUG', true);
define( 'WP_DEBUG_DISPLAY', true );

For more details:
https://wpml.org/documentation/support/debugging-wpml/

Thank you

May 21, 2018 at 1:34 am #2198568

Andrew Dunne

It turned out, NextScripts: Social Networks Auto-Poster plugin was causing a conflict