This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by jasonS-17 1 month, 1 week ago.

Assigned support staff: Bobby.

Author Posts
August 28, 2019 at 4:50 am #4471195

jasonS-17

I am trying to: Use ATE to add translations for a page

Link to a page where the issue can be seen:

I expected to see: the entire sentence come across in a editable field with the "alt-1" to add <a> tag in and "alt-2" to add the tag in

Instead, I got: the sentence in 2 separate fields splitting where the tag occurs.

What this causes is an joint-issue with the fact that the editable fields remove ALL trailing and leading empty spaces... This causes any space between the words in the and before or after it to be stripped.

i.e this is italic text
renders in translations as
this isitalictext

because in ATE its 3 fields with no trailing/leading spaces
1) This is
2) italic
3) text

August 28, 2019 at 7:31 am #4471591

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

i would like to try and reproduce this on my local environment as at the moment i tried with a <b></b> tag but it seems to work as expected

if possible please provide me with your exact string for me to test locally

August 28, 2019 at 11:16 pm #4477009

jasonS-17

Hi,

Yes strong bold tags and a tags work inline as expected. It just seems to be em tags (same results with i tag)
The string I'm using is:

A recent report by <a href="<em><u>hidden link</u></em>" target="_blank" rel="noopener noreferrer">McKinsey</a> said: <em>"The automobile, mechanical to its soul, will need to compete in a digital world, and that will demand new expertise and attract new competitors from outside the industry. As value chains shift and data eclipses horsepower, the industry's basic business model could be transformed. Indeed, the very concept of cars as autonomous freedom machines may shift markedly over the next 50 years."</em>

In wpml website screenshots, em appear highlighted like b and a tags, but its separate's into its own string section for me. (attached image of section in ATE).

August 29, 2019 at 5:49 am #4477915

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

i have test the tag along with the provided text above and it works as expected in my testing environment

if possible i would like to see the issue on your site as i am not able to reproduce it

is this happening with all pages, even if you create a new test page ?

If possible i would like to take a closer look at the backend to further test this issue

**Before we proceed I recommend to please take FULL BACKUP of your database and your website.**
I often use the Duplicator plugin for this purpose See: http://wordpress.org/plugins/duplicator/

I would like to request temporary access (wp-admin and FTP) to your site to fix the issue.
(preferably to a test site where the problem has been replicated if possible)

You will find the needed fields for this below the comment area when you log in to leave your next reply.
The information you will enter is private which means only you and I can see and have access to it.

Thank you,
Bobby

August 29, 2019 at 7:07 am #4478097

jasonS-17

Sorry, your screenshot shows the error just like mine... the italics tag isn't there to add... its come as separate string.

As you can see in below image from the WPML website... the green and orange elements are <b>em</b> tags just like mine... but appear inline.

Second image is a mockup of what I expected to see.

August 29, 2019 at 10:37 am #4480213

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

You are right, what is happening here is called segmentation

ATE uses segmentation to break a paragraph into multiple lines

General:

ATE it is splitting into sentences as all other CAT tools do that. It has some benefits:
- Shorter sentences are easier/faster to translate.
- Without splitting, translation memory would never work. The shorter the sentence, the higher is the chance to repeat itself and be translated from TM
- When doing small edits, only segments affected by edits needs re-translation, everything else is translated from TM
- Rules for splitting are not perfect. It is impossible with current technology to make them perfect, but are undergoing continuous improvement. Currently those rules are tested against more than one million xliff files and are working good for 90% of the use case.
- While there are certain use cases where the rules are failing, those can’t be fixed without affecting the big majority of working use cases.

There are plans to offer option to merge segments into blocks and translate in such a way, but there is no ETA for when this feature will be released

NOTE that there are more than 300 rules that the segmentation is based on (for example a line end "." )

-------------

Now with this as a base on why the lines are splitting we can go back to the main issue which is why is the line not highlighted in the Advanced Translation editor as expected.

this is happening because the tag spans through different segmentations therefore the tag is not shown in the Advanced Translation Editor with the color but it does remain and work in the front end as expected after you are done with your translation

____________

after you have finished your translation what are your results in the front end ? the end result should be as expected as i did test it and it worked well

September 1, 2019 at 11:38 pm #4493563

jasonS-17

Ok, thanks for the explanations. I did notice the segmentation was weird on a few occations...

If I had the EM inside the quotes e.g.

"<em>content</em>"

The trailing " was is a segment by itself, which gave the initial error in removed space between segments.

But by placing the EM outside the quotes e.g

<em>"content"</em>

I got nicer segments.

Yes, translation for this page is finished, and although the highlight is not appearing, with the above segment rework, the front end content is looking as expected.

Thank you for the assistance.

September 1, 2019 at 11:40 pm #4493565

jasonS-17

My issue is resolved now. Thank you!