This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by Carlos Rojas 1 year ago.

Assigned support staff: Carlos Rojas.

Author Posts
September 28, 2018 at 11:28 am

nickC-8

Hi,

I am facing an issue with the tags.When I checked the products in tags on English language,it shows 63 and when changed the language to Australian language it shows 65 products and on Canadian and Uk language it shows only one product.
Here are the link:
hidden link
hidden link
hidden link
hidden link
Also if I create a new tags and assigned the newly added tags to the products,then its working fine for all languages.But,In my case I don't want to create a new tags,so please help to resolve this issue with the already created tags.

I have taken the whole backup of the website.Could you please resolve this issue as soon as possible because my website is live and user visiting the website regularly.

Thanks

September 30, 2018 at 4:31 pm #2776666

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

1.- I would like to ask you to follow this steps:
- Make sure to have a backup that is up-to-date.
- Flush all cache memory.
- Update all outdated plugins, specially Woocommerce. Outdated functionalities can cause conflicts in the code.
- Go to Woocommerce -> Woocommerce Multilingual -> Status tab -> Fix all the issues.
- Go to Woocommerce -> Woocommerce Multilingual -> Settings tab -> Troubleshooting link -> Sync all products.

Coudl you tell me the result of this steps?

2.- Please increase the PHP Memory Limit. Minimum requirements are 128Mb: https://wpml.org/home/minimum-requirements/
You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '128M');
define( 'WP_MAX_MEMORY_LIMIT', '128M' );

- Add it above the line /* That's all, stop editing! Happy blogging. */

Kind regards,
Carlos

October 1, 2018 at 9:56 am #2777655

nickC-8

I have increased the memory limit to 512M by adding the below code above the line / That's all, stop editing! Happy blogging. /

define('WP_MEMORY_LIMIT', '512M');
define( 'WP_MAX_MEMORY_LIMIT', '512M' );

Also In the status tab,only product translations are pending and I don't want to translate it now.May be I will translate it later.
I have Sync all products in the troubleshooting page but I didn't received any errors and still my issue is not resolved.
Could you please help to resolve it as soon as possible.

October 1, 2018 at 8:12 pm #2779427

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
Thank you very much for your feedback.

I double checked the site and there is a PHP extension that needs to be loaded so String Translation plugin can work correctly. This PHP extension is called "Multibyte String extension", you can find the alert in WPML -> Support.

Please contact your hosting providers and ask them to load this extension, then flush all cache memory and check if the issue persists.

Looking forward to your answer.
Best regards,
Carlos

October 3, 2018 at 9:23 am #2784041

nickC-8

I have enabled the Multibyte String extension but still the issue is not fixed.

October 3, 2018 at 5:49 pm #2785428

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,
Thank you very much for enable the PHP extension.

Before we continue I need to ask you to update all outdated plugins and themes to their latest version.

Please double check if the issue persists after the update.

Looking forward to your answer.
Best regards,
Carlos