This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 18 replies, has 2 voices.

Last updated by Jamal 5 months, 2 weeks ago.

Assigned support staff: Jamal.

Author Posts
April 19, 2019 at 11:26 am

christophe

I would like to followup on this ticket https://wpml.org/forums/topic/taxonomy-sync-does-not-work-anymore-for-duplicate-posts/

We discussed this further with our client and we have an ok to give your team access to the staging environment in order to replicate the bug.

-----------------

I am trying to:
Update an existing post that has translations and duplicates

I expected to see:
Terms from my (custom) taxonomies should be synced to the translations and duplicates

Instead, I got:
Terms for duplicate posts are created for the duplicate posts but they already existed

Issue started occurring after upgrading from:
- WPML Multilingual CMS v4.1.1 => v4.1.4
- WPML Translation Management v2.7.0 => v2.7.3

I also tested this with the latest versions of both the Multilingual CMS plugin and the Translation management plugin.

This always worked before, but doesn't anymore.

Kr
Joren

ps. on a side note: when on version v4.1.4 (wpml) & v2.7.3 (trans. management) no update notification is shown. I had to manually download the latest versions from the website.

April 19, 2019 at 2:22 pm #3646445

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

Thank you for contacting WPML Support. I will be glad to help with this.

Please make a full backup of your site.

You are using the latest WordPress release and outdated WPML plugins. Please update all WPML plugins to latest release.

If this does not solve the issue, please conduct a compatibility check, by switching to a default theme and deactivating all non WPML plugins. If it solves the issue, you will need to reactivate the theme and plugins 1-by-1 to spot which one causes the issue.

If this does not solve the issue, please allow me temporary access, and provide steps to follow to reproduce this issue.

Best regards,
Jamal
WPML Support

April 23, 2019 at 7:31 am #3660119

christophe

Hi Jamal

Thank you for your reply. As you can read in the previous topic I already followed all the steps that you provided, wp-admin access credentials are already present in my the openings post of this forum topic.

We where also able to reproduce the issue on the latest version of WPML

The steps to reproduce can be found in the original forum topic where I linked to.

Kind regards
Joren

April 23, 2019 at 11:13 am
April 23, 2019 at 12:52 pm #3664103

christophe

Hi Jamal

Thank you for following up, can you please don't share any screenshots publicly we are under heavy NDA and had to go through a lot in order to give you access to wp-admin. Can you make your previous post private or delete the screenshot please?

Steps to reproduce could be found in the chat history of the previous post normally however I'm not able to open the private message for some reason.
Below you can find the steps:

1. Go to a post that has one or more duplicates
2. Update the post
3. Taxonomies should be synced to the duplicate posts
4. They are synced but they created a brand new term for it when the term translation was already available in the duplicate post language
5. I expect the already available translation of that taxonomy to be selected and no new term being created

Hope this helps to reproduce the issue.

Kr
Joren

EDIT: there are indeed terms with another origin language as the site was at the initial release only available in that language. Currently we have 10+ languages and the default language has been changed over time

April 23, 2019 at 1:48 pm
April 24, 2019 at 7:26 am
April 24, 2019 at 1:39 pm
April 24, 2019 at 1:51 pm #3673595

christophe

Hi Jamal

I will get back to your answer later today with a screen recording of the issue.
Can you please put your comment as private as it contains a url and screenshots, we are under NDA non of this may be publicly visible. Thanks for understanding.

Kr
Joren

April 24, 2019 at 2:41 pm #3674241

christophe

Hi Jamal

Can you also enable a private comment for me so that I can share a screen recording demonstrating the bug with you?

Kr
Joren

April 24, 2019 at 3:32 pm #3674739

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hi Joren,

I activated the private box, you can use duplicator's field to share the url.
If you have any doubts you can send me a message to my email. See my profile page https://wpml.org/forums/users/jamal-b/

Best regards,
Jamal

April 24, 2019 at 7:35 pm
April 25, 2019 at 9:11 am #3680383

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

Thank you for the video i can see now the issue. It sounds to me like a bug, and would like to confirm that on one of our clean installs.
Please use the link below to connect to our server, configure WPML with 2 or 3 languages. Add the plugin or theme that registers the custom taxonomies and try to reproduce this issue.
If reproduced, i will escalate this to our developpers, if not, we will continue debugging your site until we find what causes that.
hidden link

If you need ftp access, see Sandbox menu.

Best regards,
Jamal

April 25, 2019 at 9:37 am #3680625

christophe

Hi Jamal

First of all, can you please make your comment (https://wpml.org/forums/topic/taxonomy-sync-does-not-work-anymore-for-duplicate-posts-2/#post-3673471) private as it contains private information of our application that may not be visible to other visitors. Thanks for your understanding.

Regarding the sandbox env, the plugin that is responsible for the taxonomies contains quite a lot more and depends on quite some logic from other plugins, themes etc. But I will to my best to reproduce the issue over there.

April 25, 2019 at 9:56 am #3680781

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

I made the reply private. I'll be waiting for your test on the sandbox.

Best regards,
Jamal

The topic ‘[Closed] Taxonomy sync does not work anymore for duplicate posts’ is closed to new replies.