Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 13 replies, has 2 voices.

Last updated by Fabio Fava 10 months, 1 week ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
October 22, 2019 at 3:44 pm

Fabio Fava

My website (staging.fabiofava.com) is in Brazilian Portuguese.

If I set the slugs in Settings -> Permalinks to Brazilian Portuguese, then Taxonomy Translator still get "Category" and "Tag" names in English, instead of showing in Brazilian Portuguese.

Thus, the slugs that are "cat-br" and "tag-br" would still appear as Category/Categories and Tag/Tags, instead of appearing in Brazilian Portuguese.

hidden link

I expected to see: Text (Singular/Plural) for Categories and Tags translated as set in Settings -> Permalinks (Brazilian Portuguese) instead of appearing in English (with the correct -br slugs). Quite weird, please check the images attached.

Instead, I got: Please check the attached pictures, they show the problem. I'm preparing a User and SFTP/SSH access to the WPML Support Team to be able to get in and take a look.

I've set this user to English (US), but I strongly recommend to change it to Brazilian Portuguese, in order to exactly reproduce the issue I'm having. I'm not sure it will behave exactly the same witht he user being configured to American English.

Please reply with a protected form so I can share WP-User/SFPT/SSH Credentials.

October 23, 2019 at 4:45 pm #4813409

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. I try to access your website using the provided access details to give a detailed look in your website, but these provided access credentials don't seem to be correct. Can you review it please? A private reply is enabled for you, so, you can provide any access details safely. Thank you for your collaboration, have a nice day.

October 25, 2019 at 5:07 pm #4828979

Fabio Fava

Hello Marcos, I'm sorry for the issues. I assume is something with the @ sign on the password, I've removed please try it again without it. Before anything, I've read all problematic issues with the last update (that just appeared today on my WP Admins), because of that I didn't yet updated all my 3 sites with WPML. Is it now safe to update? Can still some site to break?

[EDITED]

I'll keep looking forward if I should update the WPML Plugins on my sites (we can start with this Staging Site to test as wanted), please let me know if I should.

Then, please check my original issue. I really want to make this on my Live Site, it will take time just to translate those Taxonomies, Menus, etcetera, before start translating the pages (most of them were made with the Cornerstone Page Builder, and until last trial I didn't have success on translating - lost all layout formatting - or duplicating the pages). I would need to learn what is the correct approach to have those pages translated and keeping the layout.

Thank you and best regards.

October 25, 2019 at 8:53 pm #4830067

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the details. I am jumping here to let you know I will continue working on your issue on the next monday (in case it is not urgent, if it is please, let me know) as I am in the end of my work shift for today. Thank you for your understanding, have a nice day.

October 25, 2019 at 9:22 pm #4830121

Fabio Fava

Hey Marcos, no worries my friend! I'll keep looking forward from you starting at Mondey. Have a great weekend! Cheers!

October 30, 2019 at 2:02 am #4852399

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for your continued patience while waiting for a detailed reply and sorry for the bit of waiting here. I tested it a clean sandbox environment and could notice the same issue, as a workaroung I noticed:

1 - If you enter keep the default language as english for these categories labels and slug you will be able to translate it properly.

2 - It doesn't seem to affect the frontend as these labels are just suitable for admin screens.

You can confirm the same behavior and workaround at: hidden link (it is a one click login url)

Still your questions make sense and I also believe if you enter a slug in another different language than english this slug should be shown for that specific language only and not english labels should be shown for the slugs and labels translations features. I will get some more details regarding this behavior and I will be back here in the next hours.

Thank you for your collaboration and patience, have a nice day.

October 31, 2019 at 8:17 am #4861113

Fabio Fava

Hello Marcos,

1 - That's what I've been doing until now. As you agree at the end of your message, yes these should be compliant with the site's language. By the way, many other slugs aren't correctly interpreted on "WooCommerce Multilingual -> Store URLs" as you can see on my Staging Site.

2 - Yes, it doesn't affect the Frontend, but makes very confusing for the Admin and the Translators on the Backend anyway. That's a point we would love to have it fixed, the proper language to be attached to every slug, taxonomy, etcetera when it's not English.

Finally, bug (or enhancement needed) reported, I assume you can close this ticket. I'll keep looking forward and will try again on my own (pt-BR) website in the future. The other WPML-enabled sites I'm working on, they start with English as main/first language, so hopefully those issues won't cause problems there. But I'll keep dreaming on converting my personal website to WPML in a not-so-far future.

Thank you very much for your patience and support, cheers!

October 31, 2019 at 6:38 pm #4866993

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. I've found a technical explanation for that, and it happens due the nature of WordPress itself:

"The original language of strings should still be English. Even if you’re not using English in your site, WordPress and all plugins from wordpress.org are still coded with English as the source language. This means that we’re still translation a lot of stuff from English."

See: https://wpml.org/faq/string-translation-default-language-not-english/#when-your-site-doesnt-at-all-include-english

Hope it brings a bit of clarifications regarding this behavior. Have a nice day.

November 1, 2019 at 11:28 am #4870287

Fabio Fava

Hello Marcos,

For some reason, WPML started working fine with those slugs defined in "Settings -> Permalinks" so I'm using Brazilian Portuguese there and it's working. On the other hand, "WooCommerce Multilingual -> Store URLs" shows this weird behaviour (please check picture attached) and I don't know how-to either make them in English or change them to Portuguese.

It's all in Brazilian Portuguese, but "WooCommerce Multilingual -> Store URLs" doesn't allow me to change its default language from English. Any solution to that? Please check the pic. I've set the WPML user language to "Default" that is pt-BR so you can reproduce the situation when you login. I'll keep looking forward from you on that, thanks!

November 1, 2019 at 6:24 pm #4872787

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello Fabio,

Thank you for the updates. The default language of the store URLs the ones defined in your WordPress Dashboard > Settings > Permalinks such as product base and so on have the correct behavior, they will be always shown in the default language of your website in the language you entered the values in actually.

As regarding the endpoint urls (Ponto de extremidade) they will be always displayed in english since this is the default language for the WooComemerce source files. (here it is basically the same techinical explanation from: https://wpml.org/faq/string-translation-default-language-not-english/#when-your-site-doesnt-at-all-include-english). In your particular case it seems you edited these endpoints url and translate them in some way without using the WooCommerce Multilingual features for that. (The same behavior doesn't happen in this test installation for example: hidden link).

These endpoints url should never be edited, instead it needs to be loaded in english as default language and then you can translate it to all the other languages using the WooCommerce Multilingual features for that.

Reference: https://wpml.org/forums/topic/woocommerce-endpoint-default-language-set-to-english-instead-to-dutch/

Hope it brings a bit more of clarifications for your questions, have a nice day.

November 5, 2019 at 1:17 pm #4889363

Fabio Fava

Hey Marcos,

I didn't edit any endpoint, WooCommerce was installed over a Brazilian Portuguese WP Install, so everything is as is, nothing was edited by me or anyone else.

So I can't understand why things are happening this way.

Please let me know if you can further discover anything, thanks!

November 5, 2019 at 7:15 pm #4893107

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello Fabio,

Thank you for the updates. I noticed the default values for your endpoits settings were entered in portuguese in your WordPress Dashboard > WooCommerce > Settings > Advanced or they were defined as portuguese during the installation as you said and this is what confused me, sorry for that.

Actually you can change the default language of your endpoits url in your WordPress Dashboard > WPML > String Translation under the 'WP Endpoits' text domain, this way you can have the default values in the proper language and then you can your translations as you would make with any other string.

Please, let me know if it helps, have a nice day.

November 12, 2019 at 8:40 pm #4934745

Fabio Fava

Hey Marcos, thank you for your infos.

Unfortunately, I couldn't find those. I went to the place you told me but everything there is in english. But on WooCommerce Multilingual -> Store URLs, the first slugs (set on Settings -> Permalinks) are already in Brazilian Portuguese, but all the others - despite being already in Brazilian Portuguese - appear as being in English, and I just can't find how to change them.

Please let me know if you can help me changing those, thanks!

November 22, 2019 at 8:38 am #4994957

Fabio Fava

Hey there,

I still have no answer/solution for the last issue. Also, starting today, WPML says my WP has REST API DISABLED, wich I've never done (just updated theme but can't imagine why the new version could have disabled it, nothing else has changed).

I've been searching on google to Re-Enable REST API but I can't find any valuable resource. And WPML keeps saying me on the Main Dashboard screen, that REST API is DISABLED.

Whan can I do to solve that? Also, how can I solve the Store URLs languages defaults?

Thank you very much and best regards.