This thread is resolved. Here is a description of the problem and solution.

Problem: After switching the language, the widgets are showing the wrong page when a search is made.

Solution: If the search widget has a field to add to the page URL, make sure that within the widget you are setting up the pages correctly.

To do this, click on the Appearance > Widgets and check if the desired widgets are configured correctly.

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 2 voices.

Last updated by davidG-36 1 year, 11 months ago.

Assigned support staff: Bruno.

Author Posts
July 16, 2018 at 5:08 pm #2528534

davidG-36

Hello,

Here is my two Language website hidden link where I use Team Showcase plugin to create dentists database. Wpml translated this plugin and it worked good before I used English as a primary language.

After I turned the primary Language to Georgian Language, I have a problem with filtered results. I mean the filter FIND A DENTIST on the right sidebar.

The problem is, that, if I filter on Georgian Language, I got the results on English language and if I filtered on English, I get the result on Georgian.

Please, help me ASAP.
Thanks.

July 16, 2018 at 5:29 pm #2528574

davidG-36

Filter from Georgian page must goes the the result page hidden link

But it goes to the English result page hidden link

And vice versa

July 17, 2018 at 7:04 pm #2530811

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

Thank you for contacting us. Please, my sincere apologies for the delay in answering.

By the URL, this looks like the form's action is using the language code incorrectly. Are you using any filters on this form to change the URL? I'll attach an image for you to see.

You may see that while the language code is being added in the primary language incorrectly, this is not being displayed in the secondary language, which would be expected. This seems to have some custom code changing it.

If you do not know, I'll need to request temporary access (wp-admin and FTP) to your site - preferably to a test site where the problem has been replicated if possible - in order to be of better help.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Note:

*** Please, can I install the Duplicator or All in One Migration plugin to make a copy of your site and install it on my test environment? This will help me debug the problem.

*** Note: Please make a full backup of your site.

Privacy and Security when Providing Debug Information for Support: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Thank you.

July 18, 2018 at 2:05 am #2531172

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

Thank you. As you have changed the default language, you must also edit the widgets so that they work with the new settings.

On the Appearance > Widgets, note the "Secondary Sidebar". These are the two widgets you are using on your site to display the search form. The return URL was incorrect. Please see the pictures that I will attach.

I've already edited both widgets with the correct URLs. Please, could you check if this is working properly?

Thank you.

July 18, 2018 at 5:24 am #2531698

davidG-36

Omg, of course!!! I completely forgot about these URLs. Thank you so much for your help. I'm even a little ashamed that I disturbed you for such a trifle 🙂

But, there is another little(I hope so) problem and may be you can to help me with this too. As you can see on Georgian page hidden link there is some column titles on English, which I can't translate: 'Specialty', 'Region', Clinics and 'Results for', Results for &'.

First three I created myself as a Taxonomies (in Team/Settings/Taxonomies) and last two you can see on filter result page.

The problem is, that WPML string translation search can find all of them as the strings and of course I entered Georgian names/words for these strings but they aren't translated anyway, as you can see.

July 18, 2018 at 1:32 pm #2532475

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Glad to hear that it now works. To fix the second problem, I followed the steps below:

- Click on the WPML > Settings > Custom XML Configuration
- Insert these lines:

<wpml-config>
    <admin-texts>
        <key name="tshowcase-settings">
            <key name="tshowcase_name_category" />
            <key name="tshowcase_name_tax3" />
            <key name="tshowcase_name_tax4" /></key>
    </admin-texts>
</wpml-config>

- Click on the "Save" button
- On the WPML > String Translation, translate the strings

Please, let me know if I can help with any other questions you may have. I'll be happy to help.

Thank you.

July 18, 2018 at 3:20 pm #2532694

davidG-36

Hello,

Thanks! It works for column titles, but what about the 'Results for'?
You will see it on Georgian result page.
check attached file please.

July 18, 2018 at 5:05 pm #2532855

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

Glad to hear that it now works. I've seen what you're reporting this will need to be debugged to find out why you're not translating.

As the original issue is resolved may I kindly ask you please to open a new ticket for your new question? This will also help other users with similar problems find solutions when searching the forum.

Thank you.

July 20, 2018 at 4:44 am #2536262

davidG-36

Yes, Sure. Thanks for your great support.