This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by Xavier 1 year, 4 months ago.

Assigned support staff: Bruno.

Author Posts
May 25, 2018 at 6:25 am #2227047

Xavier

Hello,

after updating WooCommerce and WPML to their last version, the Telephone string at checkout is mnot translated.

Thanks.

May 26, 2018 at 12:28 am #2231938

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello,

Thank you for contacting us. Please, my sincere apologies for the delay in answering.

Is this happening in the default WooCommerce strings? Have you tried to verify that the problem persists with the default theme?

Also, have you searched within String Translation if the string is still translated?

If the problem persists, please as a test, could you disable all non-WPML plugins and see if the problem persists?

Thank you.

May 27, 2018 at 3:34 pm #2235141

Xavier

Hi,

it persiss with parent Storefront theme.

Yes, I searched before writing this ticket.

The problem persists with all non-WPML plugins disabled.

Thanks.

May 28, 2018 at 11:11 pm #2242246

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

I've tried installing the Storefront theme in my testing environment, but this is working correctly.

Please, could you create a package from your site using Duplicator plugin and send me to test it in my testing environment? You can host the Duplicator backup file on some service such as Google Drive or Dropbox, for example.

Thank you.

May 30, 2018 at 12:06 am #2248677

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

Thank you. I'm not sure if I could replicate the problem. After activating WPML and its add-ons, the string was displayed as "Telephone" in the same way as it is translated. I'll add a picture for you to see.

I basically activated WPML (and its add-ons) and cleared the cache.

Is the string still displaying incorrectly? Please, could you check?

Thank you.

May 30, 2018 at 5:45 am #2248965

Xavier

Hi, looking at your screenshot I see that I was looking for "Telephone" at String Translation, while the string to be translated is "Phone". I don't why this new version deleted or changed my settings. Anyway, now I have translated "Phone" and it works.

Thank you.