This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by Diego Pereira 2 months, 1 week ago.

Assigned support staff: Diego Pereira.

Author Posts
August 14, 2019 at 7:16 pm #4397175

margaritaL-3

Hi,

My template for Arabic translation broke on the home page:
hidden link

It should look like English version.

hidden link

I change it on Elementor editor, it changes perfectly, save and nothing happens.

Can you please help?

August 15, 2019 at 2:14 pm #4401515

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello @margarital-3, welcome to the WPML support Forum!

Could you please temporarily switch to a default theme (like twenty-seventeen) and check if it works? I suspect that this is a compatibility issue with the theme.

If so, please let me know and we will proceed with the compatibility tests.

All the best,
Diego

August 15, 2019 at 2:40 pm #4401763

margaritaL-3

Hi,
Thank you for your prompt reply. I switched to twenty seventeen and it works. You can check now. But some elements of the design broke with twenty seventeen. Is there a way I can keep my Astra theme ? Or would you please advise any other popular free theme which works with WPML?

August 15, 2019 at 4:01 pm #4402299

margaritaL-3

My issue is resolved now. Thank you!

August 15, 2019 at 4:01 pm #4402305

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

This seems to be a new compatibility issue. In these cases, these are the procedures:
- Install the theme in a clean installation and reproduce the problem in this new installation. So we can isolate it and do some testing without the interference of server settings or other plugins
- After this, I will check the problem in this new installation and look for a quick solution
- If I can not find a solution, I will forward the problem to our compatibility team
- The compatibility team will do some more testing and will contact the product author to fix the issue

I created a test website with a clean WordPress install. You can access it through this link:
hidden link - Through this link you will be automatically logged in.

Please upload the theme to this test install, setup it the same way as in your website (using the same options) and create some dummy content to reproduce the issue. Please note that we only need the theme and the related functionality, you don't need to setup a entire website or clone your existing site.

After that, please send us clear steps on how to see/reproduce the issue on this test install. We will run some tests.

Kind regards,
Diego

August 15, 2019 at 4:02 pm #4402309

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there, I'm glad to hear that the issue is solved 🙂

Please contact us if you need our help in the future with WPML. We will be more than happy to help.

Cheers,
Diego