This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: L'utilisateur rencontrait des lenteurs sur une page catégorie d'une catégorie parente Solution: Il s'agit d'un conflit avec les mu-plugins de l'utiliateur, dés qu'on désactive les mu-plugins le problème ne se présente plus.

Author Posts
April 3, 2019 at 6:07 pm

anaelleC

I am trying to: diminuer le temps de chargement d'une page de mon site

Link to a page where the issue can be seen:hidden link

I expected to see:un temps de chargement correcte

Instead, I got:un temps de chargement de 57secondes lorsque les plugins WPML sont activés (et 13 secondes lorsqu'ils sont désactivés)

April 5, 2019 at 8:34 am #3542163

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+02:00)

Bonjour,

Bienvenue à l'assistance technique de WPML.

Je m'excuse pour le long temps d'attente mais votre ticket a été assigné au support en anglais par erreur.

Je viens de visiter votre page et, en effet, je vois le long temps pour ouvrir cette page. Si biens 13 seconds sans WPML n'est pas très optimisé, 60s est trop.

J'ai augmenté votre WP Memory Limit vers 512M et j'ai aussi désactivé la option Réglez les identifiants pour la fonctionnalité multilingue dans WPML > Langues mais le problème persiste.

Pouvez-vous faire les tests suivants toujours sur le même page:

1.1 Avec et sans WPML (+ Votre thème et plugins).
1.2. WPML + votre thème, mais tous les autres extensions désactivés.
1.3 Avec un thème par défaut WP et tous vos plugins différents à WPML désactivés.

Un format similaire au suivante nous ferait la lecture plus simple:
************************************************
1. Thème +- WPML +- All plugins
************************************************
Page generation time: xxx
Peak memory usage: xxx
Database query time: xxx
Number of queries:

S'il vous plaît :
- Essayer de faire les tests sur le mêmes pages, sur le fronted et le backend.
- Faites attention aux informations que WP QUERY MONITOR offre:
-number of queries
-the caller
-the load time of single queries.
*Une querie de 0.05s ne se considère pas "longue".

En dépendant de la différence des temps qu'on obtient, on pourrait voir l'apport de temps généré pour votre thème, plugins et WPML et évaluer l’étape suivant.

Cordialement,
Andrés

April 5, 2019 at 9:59 am #3542829

anaelleC

Bonjour Andrés, merci de votre retour.

Voici les informations souhaitées, j'espère qu'elles pourront nous aiguiller :

1. Mon thème + WPML + All plugins
************************************************
BACK-END

Page generation time: 4,0975
Peak memory usage: 45 692 kB
Database query time: 1,1759
Number of queries: 405

FRONT-END

Page generation time: 67,2058
Peak memory usage: 35 870 kB
Database query time: 60,1708
Number of queries: 383

2. Mon thème - WPML + All plugins
************************************************
BACK-END

Page generation time: 0.8058
Peak memory usage: 14,169 kB
Database query time: 0.0736
Number of queries: 127

FRONT-END

Page generation time: 13.8182
Peak memory usage: 14,019 kB
Database query time: 12.8019
Number of queries: 193

3. Mon thème + WPML - All plugins
************************************************
BACK-END

Page generation time: 1,4397
Peak memory usage: 31 667 kB
Database query time: 0,1939
Number of queries: 290

FRONT-END

Page generation time: 59,5708
Peak memory usage: 23 130 kB
Database query time: 58,4432
Number of queries: 312

4. Thème par défaut + WPML - All plugins
************************************************
BACK-END

Page generation time: 2,5843
Peak memory usage: 29 650 kB
Database query time: 0,3109
Number of queries: 249

FRONT-END

Page generation time: 46,7353
Peak memory usage: 28 186 kB
Database query time: 44,9186
Number of queries: 330

Je reste dans l'attente de votre analyse,
Anaëlle

April 5, 2019 at 11:10 am
April 5, 2019 at 11:11 am #3543605

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+02:00)

Merci de votre analyse, Anaëlle.

Je voudrais isoler si votre problème est lié au serveur, pour cette raison je viens de créer un site de test dans notre serveur Cloudways.

Je vous ai envoyé des instructions dans le message privé antérieur pour faire la migration.
J'attends votre retour.

Cordialement

April 5, 2019 at 1:31 pm #3544529

anaelleC

Andrés, la migration vient de se terminer. Je viens de tester, mais le chargement de la page semble être toujours aussi long...

April 8, 2019 at 9:26 am #3555987

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+02:00)

Bonjour,

Merci de votre aide.

Or, je viens de visiter notre site de test et la page problème télécharge très rapidement lorsque tous les autres extensions ne sont pas activés - 0,6228s.

************************************************
Twenty Fifteen + WPML + WooCommerce - All plugins
************************************************
Page Generation Time: 0,6228s
Peak Memory Usage: 37 356 kB
Database Query Time: 0,1091
Database Queries: 161

1. Votre page problème est une page de catégorie de produit WooCommerce et sa URL devrait être
hidden link
à la place de :
hidden link

2. Vous avez une image avec la même URL aussi :
hidden link

3. Vous avez installé l'extension Premmerce WooCommerce Permalink Manager Pro
pour enlever le /categorie-course/ de votre catégorie.

Tout cela fait que WordPress n'arrive pas à télécharger la bonne URL/contenu et cela prends plus de temps du nécessaire.

Dans notre site de teste j'ai :
- Modifié le nom de l'image par :
hidden link.
- Desactivé votre extension Premmerce WooCommerce Permalink Manager Pro.
Désormais, la page télécharge rapidement.

Cordialement

April 8, 2019 at 12:34 pm #3557667

anaelleC

Bonjour Andrés,
Merci de votre analyse qui m'aide à régler ce problème.
1/ J'ai en effet renommé l'image mentionnée et je gagne environ 20 secondes de chargement.
2/ En revanche, j'ai beau désactiver le plugin "Premmerce", je ne vois aucun effet additionnel, et la page reste bloquée à un chargement de 46 secondes tout de même.

Voyez-vous d'où cela pourrait venir ? J'ai pourtant supprimé le cache de mon navigateur.

Anaëlle

April 8, 2019 at 3:28 pm #3559793

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+02:00)

Merci Anaëlle. Comme vous voyez dans notre site de test, ce page télécharge rapidement :

1. Pouvez-vous effacer votre cache correctement ? Vous avez aussi des fichiers de cache installés dans le dossier /wp-content/ et deux extensions de cache.

2. Dans votre site de test, est- ce que vous pouvez vérifier si cette situation arrive quand:
- Seulement le paquet WPML et WooCommerce sont activés. Cela va nous dire s’il y a un problème d’interaction avec une autre extension.
- Vous changez votre thème pour un thème par défaut de WordPress. Cela va nous dire s’il y a un problème d’interaction avec votre thème.
- Si le problème disparait, est-ce que vous pouvez commencer à les activer, un par un jusqu'au problème revient ?

Cordialement

April 12, 2019 at 9:54 am #3597347

anaelleC

Bonjour,
J'ai effectué les tests dont vous parlez, mais rien ne change, le temps de chargement de la catégorie Course à pied est toujours très longue. Je pense que cela n'a pas de lien avec les extensions (j'en ai que très peu) ni avec le thème.

Je constate en revanche qu'il y a beaucoup moins de problème pour charger chaque sous catégorie de la catégorie course à pied. Chargement d'une sous catégorie = 8 à 10 sec, chargement de la catégorie parent = 40 sec.

Aussi, j'ai remarqué que plus il y avait de produits dans la catégorie, plus le temps de chargement était long. J'ai par exemple créé une nouvelle catégorie parent avec un produit uniquement et le chargement est très fluide. Plus j'ajoute des sous catégories, avec des produits rattachés à cette nouvelle catégorie plus elle devient lourde et le temps de chargement atteint à nouveau les 40 secondes.

La seule différence que je vois entre votre site test et le mien, est qu'aucune des images ne s'affichent sur le votre.

Serait-ce l'origine de mon problème ? Il s'agit pourtant d'un site e-commerce qui n'est que très peu rempli pour l'instant et dont j'optimise le poids des images.

Anaëlle

April 12, 2019 at 2:54 pm #3600069

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+02:00)

Bonjour Anaëlle,

Comme vous voyez tout fonctionne correctement dans notre site de test et nous devons donc travailler dans votre site.

Pouvez-vous nous confirmer d'avoir effectué une sauvegarde et nous confirmer de pouvoir intervenir ?

Cordialement

April 15, 2019 at 8:25 am #3611021

anaelleC

Bonjour, oui vous pouvez intervenir, j'ai effectué une sauvegarde.
Merci tout de même de ne pas toucher au thème car beaucoup de réglages doivent être remis en place lorsqu'on le désactive.

Merci d'avance pour votre aide,
Anaëlle
PS : vous verrez qu'en attendant de trouver le problème, j'ai remplacé dans le menu le lien de la catégorie parent "Course à pied" par le lien de la boutique qui charge beaucoup plus vite.

April 15, 2019 at 2:00 pm #3613907

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Bonjour,

Andrés ne travaille pas aujourd'hui. Avec votre permission, je vais continuer le traitement de ce ticket avec vous.

Pour mieux comprendre la situation, j'ai fais un peu le tour de votre serveur et du serveur migré sur notre infrastructure. Sur notre site, la page est chargé en moyenne en moins de 3s. Alors qu'elle prend pratiquement 1minutes sur votre serveur.

J'ai effectué les actions suivantes, mais cela ne corrige pas la situation :
- Executer les actions de dépannage sur WPML->Assistance Technique->Dépannage.
- Executer les deux dernières actions de WooCommerce Mutlilingual(WCML)->Support->Troubleshooting.
- Supprimer la catégorie Young, puisqu'elle a été créé en anglais, et qu'elle ne contient pas de produit. La bonne pratique avec WCML est de créer le contenu de la boutique(produits, catégories, tiquets, etc.) dans la langue primaire puis de la traduire via les fenêtres WCML.
- Désactiver l'option mutli-monnaie puiqu'il n'y a pas d'autres monnaies configurées.

Hélas, Tout cela ne corrige pas l'erreur. Alors j'ai désactivé toutes les extensions non WPML/WooCommerce sauf l'extension Dokan, par ce que le thème dépend d'une fonction dokan_is_store_page. Mais le résultat est toujours insatisfaisant. Je suis arriver à 13secondes, qui est selon moi encore très grand.
Mais cela explique que les autres extensions prennent pratiquement 40secondes. C'est très bizarre, puisque d'autres pages catégories se chargent plus rapidement.

La seule chose qui m'intrigue est le fait que les urls de la boutique sont renseignés en anglais alors que le site utilise le français par défaut, la base des catégories par contre est renseigné en français.
Je vais discuter ce point en interne avec nos experts WCML et je reviens vers vous dés que possible.

Cordialement,
Jamal

April 15, 2019 at 2:25 pm #3613979

anaelleC

Bonjour Jamal, merci de votre aide précieuse. Je prends bonne note des bonnes pratiques que vous avez mentionnées pour la traduction et reste donc dans l'attente de votre retour.
Anaëlle

April 16, 2019 at 3:34 pm #3623565

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Bonjour Anaëlle,

J'ai escaladé le ticket à notre équipe 2nd Tier. Je reviens vers vous dés que possible.

Cordialement,
Jamal