This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 1 reply, has 1 voice.

Last updated by vladimirB-14 1 month, 1 week ago.

Author Posts
September 11, 2019 at 9:30 pm #4556515

vladimirB-14

I am trying to: have a snappy page load for my e-commerce website

Link to a page where the issue can be seen: hidden link;

I expected to see: load time around 1-2 sec

Instead, I got: load time around 5-7 sec

How i reached the conclusion that the issue is WPML related:
1) disabled all plugins - quick load time
2) enabled all plugins back - slow load time
3) disabled only WPML plugin - quick load time

What i tried to resolve the issue:
1) increased memory limit to 256M
2) removed from the DB all non-translated strings

The issue still persists. Please help.

September 11, 2019 at 9:32 pm #4556517

vladimirB-14

My issue is resolved now. Thank you!
Appears to be a combination of bloated Strings table and cache.
After clearing the table and disabling/enabling the plugin seems to have gone.