This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by richardA-22 1 year, 7 months ago.

Assigned support staff: Bruno.

Author Posts
September 23, 2018 at 2:02 am #2758057


Please take a look at hidden link ... scroll down to testimonials. The company (and logo) and author are shown.

I have managed to do the arabic translation but the company (and logo) and author are not showing on the arabic page here: hidden link

Have tried to find the answer in past tickets and forum but no luck ...can you tell me what I need to do to make them show on the arabic page?


September 25, 2018 at 1:47 am #2762049


Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you for contacting us.

It depends on how this is created. When you translate this content, are these fields displayed for translation? As it seems to me, you're using Visual Composer, correct? If so, is this some native Visual Composer module or is it some custom module of your theme?

To be able to verify this, I'll need to request temporary access (wp-admin and FTP) to your site - preferably to a test site where the problem has been replicated if possible - in order to be of better help.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.


*** Please, can I install the Duplicator or All in One Migration plugin to make a copy of your site and install it on my test environment? This will help me debug the problem.

*** Note: Please make a full backup of your site.

Privacy and Security when Providing Debug Information for Support:

Thank you.

October 2, 2018 at 8:02 pm #2782641


Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)


Thank you. In Testimonials > Testimonials, I noticed that you are not syncing images with the secondary language. To fix the problem I followed the steps below:

- Click on the Testimonials > Testimonials
- Click to edit some testimonial on the original language
- On the "Language" metabox, check both the options
[X] Duplicate uploaded media to translations
[X] Duplicate featured image to translations
- Click on the Update button
- Click to edit the translation
- Finish the translation and click on the "Save & Close" button

Following the steps, the images are displayed correctly in the testimonials.

Please, let me know if I can help with any other questions you may have. I'll be happy to help.

Thank you.

October 6, 2018 at 4:44 am #2792465


My issue is resolved now. Thank you!