This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 18 replies, has 2 voices.

Last updated by Bobby 3 months, 4 weeks ago.

Assigned support staff: Bobby.

Author Posts
June 11, 2019 at 2:57 pm #3996435

vivianK-2

I am trying to: Translate the Key Ingredients Page, For some reason I can't find the text fields inside the Translation Page.
Link to a page where the issue can be seen: hidden link and translation page hidden link

I expected to see:

Instead, I got: no textfields for my contents only media text fields

June 11, 2019 at 5:14 pm #3997599

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

how are you adding the text fields ? are you using the beaver builder ?

please review the following documentation on how to use beaver builder with wpml as well as the current Modules that are translatable with WPML as not all modules have been added

if your module is not added within the list you can either try to add them using XML files
=> https://wpml.org/documentation/support/language-configuration-files/

or translate the page using the classic WP editor with the page builder
to do this , edit the default language page -> click on the button to turn off "Use WPML's Translation Editor" and just pick for "this page only"

this will allow you to edit the page using the page builder.

NOTE : i recommend first "duplicating " the page and then just filling in the translations

let me know your results please

June 12, 2019 at 10:21 am #4002933

vivianK-2

yes I'm using Beaver Builder. I can see the fields before but I don't know why it's gone. I already deactivate the plugins and changed the theme but the issue still occur. Hope you can help me this issue as soon as possible.
I can give you my Dev site login and FTP details for you to take a better look at the issue.

June 12, 2019 at 11:05 am #4003349

vivianK-2

[removed ]

June 12, 2019 at 9:41 pm #4007753

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Thank you for the access details !

i took a closer look and was able to reproduce the issue on your site but i was not able to reproduce it on my local enviroment using a clean enviroment.

i do notice that this is a staging environment that you provided me with , i have tried creating a duplicator to test locally but i was not able to.

would it be possible for me to test with a minimal environment within the staging site you provided me? (meaning deactivate all 3rd party plugins and test with only beaver builder and WPML )

June 13, 2019 at 1:16 am #4008183

vivianK-2

Yes you can

June 14, 2019 at 2:57 am #4017925

vivianK-2

Yes, the issue is also present on the Live site. I'm using WPengine for hosting, any idea what setting it could be that I could request them to adjust?

June 14, 2019 at 3:10 am #4017977

vivianK-2

Something I just noticed - the custom fields actually are there, until I re-save the main post. Then the custom fields for the translations disappear. I'm trying to see if this also happens on your test site but when I try to access the WPML translation editor the pages don't load.

June 14, 2019 at 5:35 pm #4023267

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hi ,

if you get an error 504 or blank page please just refresh the page , it seems that the server might be a bit loaded and the site was heavier due to all the plugins but i have removed some other applications so it should work now.

Regarding the custom fields you can control them from Default Page-> Edit -> scroll to the bottom and edit them to be at "translate".

at your site they were set to "do not translate"

it could be a possible caching issue on your server ? i am not 100% positive though .. i have checked the database tables for WPML as well and they seemed OK

June 15, 2019 at 10:26 am #4026481

vivianK-2

thanks for the reply,

can you check this page?
hidden link
It seems your method is not working in this page. As you can see, It's a lot of fields which is not necessary to be there. see screenshot.

Also, I checked at the bottom to be "translate" and we removed some of plugins, so hopefully it will help to load faster.
You can used this page for testing hidden link

For some reason it detects all sorts of fields and attributes. Can you fix that? so The Content fields will just remain?
I think the slowdown Staging is due to the pages processing all those custom fields

here are the WPengine error logs:

Sat Jun 15 09:39:07.844623 2019] [php7:notice] [pid 11250] [client 101.99.34.40:50922] WordPress database error Unknown column 'wrap_tag' in 'field list' for query UPDATE `wp_icl_strings` SET `wrap_tag` = '' WHERE `id` = '41576' / From [soulstory.co/wp-admin/post.php] in [/nas/content/live/soulstory/wp-content/plugins/wpml-string-translation/classes/class-wpml-st-string.php:273] / made by shutdown_action_hook, do_action('shutdown'), WP_Hook->do_action, WP_Hook->apply_filters, call_user_func_array, WPML_PB_Integration->do_shutdown_action, WPML_PB_Integration->register_all_strings_for_translation, WPML_PB_API_Hooks_Strategy->register_strings, do_action('wpml_page_builder_register_strings'), WP_Hook->do_action, WP_Hook->apply_filters, call_user_func_array, WPML_Page_Builders_Integration->register_pb_strings, WPML_Page_Builders_Register_Strings->register_strings, WPML_Beaver_Builder_Register_Strings->register_strings_for_modules, WPML_Beaver_Builder_Register_Strings->register_strings_for_modules, WPML_Page_Builders_Register_Strings->register_strings_for_node, WPML_PB_String_Registration->register_string, WPML_PB_String_Registration->update_string_data, WPML_ST_String->set_wrap_tag, WPML_ST_String->set_property, referer: hidden link

June 16, 2019 at 4:50 pm #4030969

vivianK-2

can you tell me how did you removed some other applications? and what applications are they?
I reverted the site from live site so I can try to fix it on my own. Now I encountered the issue again, when I re-save the main post the custom fields for the translations disappear. How did you fix that before? also, when I tried to set to "translate" it goes me to 502 error.

June 17, 2019 at 7:15 am #4032641

vivianK-2

I made a video to show you the secondary issue - hundreds of attributes from the page, or from Beaver Builder, are getting picked up by WPML and added as custom fields:

hidden link

Really need help with this as my live site is having serious translation issues so I need to apply my fix asap. Thanks.

June 17, 2019 at 4:40 pm #4037217

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hi There,

in regards to the issue in your screencast these fields are coming from the custom field "_fl_builder_data". setting that field to "do not translate" or simply "copy" removes them from loading in the Translation Editor.

The issue should be fixed now on your staging site.

it seems that the field "wrap_tag" was missing from wp_icl_strings DB table, you can see it added now within my screenshot .

please verify with me

June 18, 2019 at 3:32 am #4039929

vivianK-2

Yes, this seems to be working on Staging now. So when you say "it seems that the field "wrap_tag" was missing from wp_icl_strings DB table, you can see it added now within my screenshot." Is that what was causing the custom fields from not appearing? And how was that added back? From setting "_fl_builder_data" to "do not translate"?

Thanks.

June 18, 2019 at 3:46 am #4040015

vivianK-2

Is this then the solution that I would need to apply to my Live site?

https://wpml.org/forums/topic/text-fields-not-showing-in-the-advanced-editor-only-titles-show/#post-4034789