Please make sure to update to WPML 4.3.4 before reporting any issue

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 11 replies, has 2 voices.

Last updated by patrickL-55 4 months ago.

Assigned support staff: Noman.

Author Posts
July 20, 2019 at 6:03 pm #4250375

patrickL-55

I try to put a language switcher to a custom place on all my posts.
The best solution would be if I could just put a link to the other language on some text, but then there is the problem with sticky links.

I like the solution with "Links to translation of posts " that looks clean, but it always appears at the end of the post, (in the screenshot I used before and after post).

Third solution would be the custom widget, but then it does not align with the text and appears on a new row (see screenshots)

July 21, 2019 at 7:18 am #4251529

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support. If third solution is fine for you then we can set alignment using small CSS code. Could you please send me page link where you want to display that switcher as widget so that I can provide you CSS to fix this issue.

Thank you

July 21, 2019 at 7:56 am #4251549

patrickL-55

it should work everywhere in the end but try hidden link

July 21, 2019 at 10:47 am #4252105

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

I can’t see language switcher in the link that you have provided. Have you added language switcher as widget?

Thank you

July 21, 2019 at 12:01 pm #4252141
patrickL-55

hidden link

I added it here. I need it in the same font and style as the text. Is it not possible to add html or a link to text?!

July 21, 2019 at 5:13 pm #4252863

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

To take a closer look on this issue, please provide temporary access (WP-Admin and FTP Login info) to your site (preferably staging site), so that I can look into your setup and debug the issue.

Your next answer will be private which means only you and I have access to it.

=== Please backup your database and website ===

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

Thank you

July 22, 2019 at 1:58 pm #4258169

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

I have logged in to your site and followed below steps in order to fix alignment issue:

1. I have added ‘inline-lang-switcher’ class in VC element to apply CSS to only this particular element.
hidden link

2. Added below code in WPML >> Languages > Additional CSS section:

.inline-lang-switcher p,
.inline-lang-switcher .wpml-ls-legacy-list-horizontal {
    display: inline-block;
}

.inline-lang-switcher ul,
.inline-lang-switcher a,
.inline-lang-switcher span {
    margin: 0 !important;
    padding: 0 !important;
	color:#000 !important;
}

And now language switcher looks as in the attached screenshot. Could you please check and confirm?

3. To handle new questions/issues, I have created new tickets since these are separate issues. Here are the links to the new tickets:
https://wpml.org/forums/topic/issue-in-categories/
https://wpml.org/forums/topic/author-profile-is-not-showing-in-german/

Thank you for your cooperation and patience.

July 22, 2019 at 7:33 pm #4261035

patrickL-55

Thank you that's already cool but the switcher is not on the same height than the other text, what parameter do I need to change?

July 23, 2019 at 8:11 am #4263611

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

You can fix this issue by adding below CSS in WPML >> Languages > Additional CSS section:

.inline-lang-switcher span {
   position: relative;
   top: -1px;
}

And it will look as in the attached screenshot. You can change -1 to any number according to your needs.

Please let me know if this resolves your issue or you need further assistance with this issue.

Thank you

July 24, 2019 at 4:31 am #4270195

patrickL-55

ok that works, still wondering why it is not changing on the german page but I'll figure out. Thanks

July 24, 2019 at 7:25 am #4270989

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Okay sure, if you find any issue please feel free to contact us and we would be happy to help you.

Thank you

July 25, 2019 at 4:32 pm #4285179

patrickL-55

My issue is resolved now. Thank you!