This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: I am trying to translate some new content on an existing page.

Solution: I would like to ask you to edit the page in the original language -> Make a small change in the text of the 'Clarity' element -> Save the changes -> Update the translation.

Relevant Documentation:

This topic contains 6 replies, has 2 voices.

Last updated by Carlos Rojas 9 months ago.

Assigned support staff: Carlos Rojas.

Author Posts
January 18, 2019 at 12:11 pm #3105913

simonE-15

I am trying to:
Translate some new content on an existing page.

Link to a page where the issue can be seen:
hidden link

I expected to see:
The text box containing "Clarity of purpose, thought and communication." to appear in the translation section for the page, or under string translation.

Instead, I got:
The Respect and Spirit text boxes are visible and available to translate but the Clarity text box cannot be found.

January 18, 2019 at 1:19 pm #3106050

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

I would like to ask you to edit the page in the original language -> Make a small change in the text of the 'Clarity' element -> Save the changes -> Update the translation.

Could you tell me if the issue persists?

Kind regards,
Carlos

January 18, 2019 at 1:40 pm #3106141

simonE-15

That's fixed the issue. It would be interesting to know why it happened though.

January 18, 2019 at 2:23 pm #3106339

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
I'm glad to hear that the issue is solved 🙂

I suspect that, for some reason, the entry in the database for that element was affected or wasn't recognized by WPML. Following the steps in my previous message just refreshed the entry in the database.

Please don't hesitate to contact us if you need our help in the future with WPML. We will be more than happy to help.
Best regards,
Carlos

January 18, 2019 at 2:32 pm #3106356

simonE-15

I spoke too soon. The translation section became available, but the translation doesn't appear on the live site. Please could you take another look?

January 18, 2019 at 2:36 pm #3106383

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,

I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Regards,
Carlos

January 18, 2019 at 4:12 pm #3106763

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,

It seems that the cause of the issue was the cache memory. Please translate the 'Clarity' texts - Save the translations 100% -> Flush the cache memory.

The steps above should solve the issue.

Regards,
Carlos