This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 17 replies, has 2 voices.

Last updated by stefanA-12 1 week, 6 days ago.

Assigned support staff: Bigul.

Author Posts
September 23, 2019 at 11:20 am

stefanA-12

Hello! 🙂

I am trying to translate 2 texts: with a sign-up fee of, now then
This texts are from the subscriptio plugin and translated yet by me in the WPML string translation. So the strings are available, but it not shows the second languages (German, Spanish) on the website.

Link to a page where the issue can be seen: flat.tips/shop and in the cart.

Append a screenshot to see the issue in detail.

Please, have a look to that.

Many thanks in advance for your help,

Stefan

September 23, 2019 at 6:04 pm #4626053

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Stefan,

Welcome to the WPML support forum. I will do my best to help you to resolve the issue.

Have you translated the *day with a sign-up fee* string from WPML String Translation? Because it is not showing for me in String Translation panel. Please check the attached images.

For your kind information, *Subscriptio* plugin is not listed on the WPML compatibility list for the Plugins - https://wpml.org/documentation/plugins-compatibility. It does not mean that this plugin is not compatible with WPML, but our compatibility team has not tested it yet.

--
Thanks!

Bigul

September 24, 2019 at 7:05 am #4628435

stefanA-12

Hello Bigul,

thank you for your informations! 🙂

The both texts are translated in the WPML string translation yet.

Please, have a look to the both screenshots append.

But in the second languages it not shows the translation.

Kind regards,

Stefan

September 24, 2019 at 5:18 pm #4633211

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Stefan,

Thank you for the updates. This may be a cache or compatibility issue. Please try the following troubleshooting steps after a full site backup and make sure the issue is existing or not.

1) Upgrade to WPML 4.2.9. We have released a new version few hours ago.

2) Go to WPML>>Support page

3) Click on Troubleshooting link (blue link in the middle of the page)

4) In Troubleshooting page, please click on the following options of the *Clean up* section. Wait for confirmation of processing after each one.

- Clear the cache in WPML
- Remove ghost entries from the translation tables
- Fix element_type collation
- Set language information
- Fix WPML tables collation
- Assign translation status to duplicated content
- Recreate ST DB cache tables

5) Clear all types of caches(including the server cache)

--
Thanks!

Bigul

September 26, 2019 at 8:17 am #4644319

stefanA-12

Hi Bigul,

I have done the WPML update to 4.2.9, also all the other steps are done, I have deleted all caches. Also, now I have created a new Test Product to look if there is changing something. Append a screenshot to that.

Sadly in the second language the translation text is missing still.

How it is possible to fix the issue?

Kind regards,

Stefan

September 26, 2019 at 1:12 pm #4647113

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Stefan,

Thank you for the feedback. This may be a compatibility issue. So to debug the issue further without affecting your live site, I have created a test site in our Sandbox server. Please visit the following URL. It is a fresh installation.

hidden link

Please install and activate your theme and *Subscriptio* plugin in the test site. Then check the issue is existing or not.

It will help us a lot in debugging. Especially our developers.

--
Thanks!

Bigul

September 27, 2019 at 9:01 am #4652465

stefanA-12

Hi Bigul,

I have installed my theme and the plugin subscriptio on your test website. Now the both texts are available in the second languages. 🙂 So this are good news! 🙂 Append 2 screenshots for that.

Now the next step, to bring a solution to my website! 😉

How can be fixed that issue on my website?

Many thanks for your help,

Stefan

September 27, 2019 at 3:26 pm #4655463

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Stefan,

Thank you for the feedback. Maybe you are facing this issue because of the compatibility conflicts with other plugins. Therefore to make sure if possible, please do the following steps.

a) Backup your site first
b) Deactivate all the plugins that are not related to WPML
c) If the issue is gone, activate the plugin one by one to see with which one there is an interaction issue

Or please allow me to make a duplicator copy of your site using the Duplicator plugin(https://wordpress.org/plugins/duplicator/) for debugging the issue on my local server.

--
Thanks!

Bigul

September 28, 2019 at 7:44 am #4658067

stefanA-12

Hi Bigul,

I´am doing every day a backup! 😉 You can do a copy of my website with the duplicator plugin to check the issue.

Hopefully you can find the problem! 🙂

Kind regards,

Stefan

September 30, 2019 at 12:34 pm #4664579

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Stefan,

Thank you for the updates. I made a Duplicator copy of the site and debugging the issue now. Will get back to you as soon as possible. Please wait.

The Duplicator free version was not working on the site. So I have tried with the Pro version of it. Please check the attached images.

--
Thanks!

Bigul

September 30, 2019 at 12:50 pm #4664665

stefanA-12

Hi Bigul,

this message error 524 is from my CDN, it is a timeout info. But every task will be normal executed and to come back to a live site it is always possible in this screen of the message. Or you have only to wait and the task will be normal finished.

Finally you have now your duplicate or not?

Reg., Stefan

September 30, 2019 at 5:42 pm #4666955

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Stefan,

Thank you for the updates. The error 524 is only happening while making Duplicator package using WPML. But it works fine with Duplicator pro. So we have the duplicator copy and working on it now. Please wait. We will get back to you as soon as possible.

--
Thanks!

Bigul

October 2, 2019 at 7:48 am #4677567

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Stefan,

The issue is existing on my local copy after the initial debugging steps. Therefore I have shared the details with our second-tier team and waiting for the expert opinion now. We will get back to you as soon as possible. Please wait.

--
Thanks!

Bigul

October 4, 2019 at 1:30 pm #4696081

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Stefan,

I am escalating the ticket to our second-tier team for further debugging because the bug is existing after our primary debugging procedures. We will get back to you as early as possible. Please wait.

--
Thanks!

Bigul

October 4, 2019 at 1:38 pm #4696151

stefanA-12

Thank you Bigul,

great info that you are working for it! 🙂

Have a nice weekend,

Stefan