This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 19 replies, has 2 voices.

Last updated by hlaingM 5 months, 2 weeks ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
April 26, 2019 at 5:45 pm #3692671

hlaingM

I am trying to: translate contents on page

Link to a page where the issue can be seen: hidden link

I expected to see: the texts on the page in the language I set

Instead, I got: the texts on the page displayed in the other/opposite language

April 29, 2019 at 4:10 am #3699931

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Welcome to WPML support. I'd be assisting you further on this issue.

Are you using the latest versions of WPML plugins? Which version of PHP/MYSQL are you using? You can easily send this information using Debug information settings from WPML.

Could you please go to WPML > Support > Debug Information and give me the information in the next reply. You can read the detailed instructions here: http://wpml.org/faq/provide-debug-information-faster-support/

Could you please make a slight change on the text in the default language as well as translation and see if that helps?

Further, If you disable all non-related WPML plugins, switch to one of the default themes, the problem persists or not?
NOTE:
+ Make a backup (both files and database) for your site before updating/proceeding anything (Always a good practice!).

Look forward to your reply.

Thanks

April 29, 2019 at 6:01 am #3700117

hlaingM

Hi,

Thank you for your response. I am using PHP 7.2.14 and wordpres 5.1.1

I tried what you suggested. It seems to me that there are 2 different set of files as you can see in the 2 images.

Previously, I opened an ticket to make a language switch appear in the home page. The technical representative suggested me to create duplicates here (all pages>edit>duplicate) and there (translation management>translation dashboard>choose duplicate). Anyway, I was NOT able to create the duplicates on all the files. I did not even understand what I was creating those duplicates.

For a different reason, the language switch suddenly appeared. The customer representative told me to close the ticket since the issue (described in the title) was resolved and to open a new ticket, leaving me with a mess like this.

Thank you for your time.

April 29, 2019 at 6:26 am #3700221

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

It looks like there are two pages created (one on each language) and it's creating the confusion, could you please just use the language switcher on the page and see if the translation is showing correctly.

Further, which ticket are you referring to?

If the problem still exists, to debug it further, I would need to check your site settings once, for this I would need temporary access (wp-admin and ftp) to your site.

So could you please provide me those details, you will find the needed fields for this below the comment area when you log in to leave your next reply.
hidden link

This info is private and available to you and WPML supporters only.
Read more about this: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Note:
Backup your sites before providing the credentials or if possible provide credentials for the test site

Look forward to your reply.

Thanks

April 29, 2019 at 8:21 am #3701047

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Firstly, I followed the below steps
- Go to Dashboard->Pages
- Change the language to Burmese
- Edited the help and QA page and changed the slug of it to "help-and-qa-burmese"

Since the pages are there with the same slug, to make it easy to understand I changed the slug.

Then I debugged why the help and qa page is not showing it's translation and noticed that it's translation was trashed, then I followed the below steps to fix the issue:
- Go to Dashboard->Pages
- Change the language to Burmese
- Clicked on "Trash" and restored the help and qa translation, after this the language switcher is working perfectly.

Further, regarding the homepage link, I followed the below steps:
- Went to Appereance->Menus
- The homepage was created using the custom link
- Changed the language and can see the link is same, changed it to the language home URL and it's working properly.

You can know more about menu translation here: https://wpml.org/documentation/getting-started-guide/translating-menus/

translation of "Ad Categories" [Not take you to the right ad categories list, you can compare the different effects when you click "Ad Categories" with English is on and with the secondary language switch is on.

I don't see any differences here, the number of categories shown is less, but this must be happening as those categories are not translated, could you please check if those categories are translated.

Also, we have a feature where you can display content as translate without duplicating it to the secondary language, you can know more about the feature here: https://wpml.org/documentation/translating-your-contents/displaying-untranslated-content-on-pages-in-secondary-languages/

Let me know if this helps.

Thanks

April 29, 2019 at 10:46 am #3702253

hlaingM

Thank you for your help.

Right now, I see 3 files (2 translations of "Help & FAQ" and 1 English version) [attached]. Which one do I have to delete? why? What is one supposed to see normally (I assume it is not going to be 3 pages, but it is 2 pages or 1 page) for default English and a secondary language?

Regarding the "Ad Categories", The option "Translatable - use translation if available or fallback to default language" was selected for "Categories" under WPML -> Settings -> Multilingual Content Setup. However, if you see the attached image, when I put the pointer on the translation of the "Ad categories" on the header menus, no drop-down list appears.

April 29, 2019 at 10:56 am #3702371

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

You can check the slug of the page and delete it, I added 1 to the title so it's easy for you to delete the page.

NOTE:

+ Make a backup (both files and database) for your site before updating/proceeding anything (Always a good practice!). You can use a plugin for this if you like. I often use the Duplicator plugin for this purpose. See: http://wordpress.org/plugins/duplicator/

I can see the issue, could you please let me know how the dropdown has been created? I can't see those links in the sections of the menu? Could you please let me know which theme/plugin settings are used to create the function?

Look forward to your reply.

Thanks

April 29, 2019 at 11:26 am #3702619

hlaingM

Hi, when I deleted the translation marked with "1" which has a slightly different slug name from the default English page, the translation was gone from the menu. On the other hand, if I delete the other translation, it looks fine.

Based on that, does it mean that I need to have 2 pages (one for English and one for a secondary language?) and the 2 pages must have a different slug name?

For the appearance of "Ad Categories" on header menus, the function is at Classipress > Settings> Categories tab> Categories Menu. Apparently, it must have been a built-in feature of the classipress theme. Since I chose "0" for categories depth and the number of categories, the sub-categories are not displayed on the menu.

April 29, 2019 at 11:31 am #3702697

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Based on that, does it mean that I need to have 2 pages (one for English and one for a secondary language?) and the 2 pages must have a different slug name?

WPML will auto create the pages for translation, yes if you view the pages from Dasboard->Pages you will see a page each for every language.

I can see those categories even I select category depth as 0, so there must be different settings for this, could you please contact the theme author and ask how to disable/enable it?

Look forward to your reply.

Thanks

April 29, 2019 at 11:43 am #3702903

hlaingM

Hi,

"WPML will auto create the pages for translation, yes if you view the pages from Dasboard->Pages you will see a page each for every language."

-So you meant I do not need to duplicate them manually? if the pages are auto-created, why was the other technical representative telling me to duplicate the pages in 2 places (one at Pages>Edit and the other at Translation Management)?

With regard to "Ad-Categories", what you see in the classipress> settings>.... is the "(parent) categories". The settings/number that can be adjusted are for the display of "SUB-categories". Apparently, that function is the built-in feature of the theme. I can ask the theme developer the exact file where it is coded? But, it can take several days for me to get a reply.

April 29, 2019 at 11:48 am #3702913

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

WPML will auto create the pages for translation,

I am sorry if I didn't explain the context properly here, what I was trying to mention was that you will not need to go to Dashboard->Pages to create a separate page after creating a translation using translation editor.

Apparently, that function is the built-in feature of the theme. I can ask the theme developer the exact file where it is coded?

It's very important to know how it's created to fix this, so I request you to contact them once regarding this.

Look forward to your reply.

Thanks

April 29, 2019 at 11:57 am #3702973

hlaingM

Hi, thank you for your explanation

"you will not need to go to Dashboard->Pages......after creating a translation using translation editor."

-Could you please elaborate on how I can create a translation using translation editor?

Yes, I will contact the theme developer, but, as I mentioned, you will have to wait for several days before they will get back to me (and thus, me to you), accordingly, with the file name/codes.

Thank you,

April 29, 2019 at 12:15 pm #3703083

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Please refer to the following documentation to know about how to create translations:

https://wpml.org/documentation/translating-your-contents/
https://wpml.org/documentation/translating-your-contents/using-the-translation-editor/

Let me know if this helps.

Thanks

April 29, 2019 at 12:51 pm #3703309

hlaingM

Hi, I already read the 2 links you sent before. But, I do not see the overview picture by looking into the 2 links.

In the link below (which you sent), translation management > 2. Select translation options, where the link shows the selection of "Translate" put in the rectangle boundary labelled as "3".

But, why did the previous translator tell me to choose "Duplicate" when the link tells otherwise? What is the difference between choosing "Translate" versus "Duplicate"?

https://wpml.org/documentation/translating-your-contents/

April 30, 2019 at 7:47 am #3708841

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

What is the difference between choosing "Translate" versus "Duplicate"?

As the term itself suggest, translate means to translate content to a different language and duplicate means a copy of the original language.

For example, if you have a page with the content "hello" and you have two languages enabled English and French, the content will be shown as below:

While Translating:
English Language ==> hello
French Language ==> the translation you will add manually.

While Duplicating:
English Langauge ==> hello
French Language ==> hello [it will be the same as the English Langauge, just as copy]

Let me know if this helps.

Thanks