Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 11 replies, has 2 voices.

Last updated by Carlos Rojas 1 year, 11 months ago.

Assisted by: Carlos Rojas.

Author Posts
March 30, 2022 at 9:59 am #10909773

poonyalidP Site owner

Hi,

I use WPML and now Thai language is my default Permalink language.

I use Windows Server 2016 with IIS with Plesk control panel. My website hidden link using WordPress with WooCommerce. I use Thai and English version. Thai is primary language for my website.

My server caused many slow problem, 500 internal server error, 503 Server error.

Plesk support team investigate and inform there is problem with Thai permalink caused by WPML.

I use Nitropack CDN and still very slow. Nitropack development team investigate and also said problem caused from Thai permalink problem.

I have no problem to change default Permalink from Thai to Eng, if it will make the website faster and better.

Please tell me the steps how to change default Permalink from Thai to English and what to do after that.
Example, after change default permalink from Thai to Eng, I need to correct all the link in all webpages manually. Or does it have any tools to help change them?

Thanks.

Below are comment from Plesk and Nitropack team.
===========
Jorge Rosa (Plesk Support)
Mar 29, 2022, 0:24 GMT+7
Hi Poonyalid,

Thank you for your time. I've reached out to the developers for further investigation. I couldn't find any additional errors besides of what I've found. But, I've found out that the English version works well, so it might be a rewrites issue.

In the meantime, please expect my next update within the next 48 hours.
Best Regards,
Jorge Rosa
Technical Support Engineer
Plesk
================
Vasil (NitroPack)
Mar 29, 2022, 10:11 GMT+3
Hello Poonyalid,

Thank you for the update!

I can see that due to the encoding being used for representing the special symbols at the URL some pages are not properly detected and get their URL changed from one to another.

This might be caused by a misconfiguration of WPML. In order to further test the matter can I ask of you to make your WPML configuration to:
> different languages in directories

Or additional approach will be to temporarily disable your parameter for English, so we can further test the encoding.

Looking forward to hearing from you!
Best Regards,
Vasil
Tech Support at Nitropack

March 30, 2022 at 11:14 am #10910607

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hello,
Thank you for contacting us.

1.- Could you tell me if the issue persists if you install a fresh new WordPress site with Thai as default language?

2.- You can encode the URLs by going to WPML -> Languages -> Languages -> Edit languages

In this link you will find the description of the option: https://wpml.org/documentation/support/editing-wpmls-languages-table/#language-configuration-fields-defined

3.- Please provide the debug information of the site. In this link, you will find the steps to follow: https://wpml.org/faq/provide-debug-information-faster-support/

Regards,
Carlos

March 31, 2022 at 12:53 pm #10920501

poonyalidP Site owner

I want to change all the permalink from Thai to English. What to do?

March 31, 2022 at 1:02 pm #10920629

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hi there,
Thank you for sharing the debug information

Before we continue, could you answer the questions (points 1 and 2) of my previous message?

Regards,
Carlos

March 31, 2022 at 1:36 pm #10920903

poonyalidP Site owner

Hi,

For No. 1, Do you want me to install WordPress in Thai version? Please explain.
No 2, I don't understand. Please see attachment.

As from Plesk support and Nitropack support mentioned to change all Permalink language from Thai to English, how can I do that?

Thanks.

Thanks.

5.JPG
March 31, 2022 at 1:42 pm #10921091

poonyalidP Site owner

Example, When I put this URL in web browser "hidden link" , then I automatically change to Thai language "hidden link"

How to stop permalink automate convert from Eng to Thai?

I mean from "products" to "สินค้า".

Thanks.

March 31, 2022 at 1:45 pm #10921209

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hi there,

1.- Yes, it is important that you check if the issue persists in a new WordPress installation in Thai. You can ask your hosting providers to help you run this test.

2.- If you see the attachment you shared and read the documentation (https://wpml.org/documentation/support/editing-wpmls-languages-table/#language-configuration-fields-defined) you will see there is a column called 'Encode URLs'. Please activate this option for the Thai language -> Save the changes -> And double-check if the issue persists.

3.- I don't quite understand what this request is about, but I think it is referred to the slugs of the posts/pages that are the ones that appear in the URLs. If this is the case, then you just need to edit each post/page on the site and change the slugs for English ones.

Regards,
Carlos

March 31, 2022 at 2:02 pm #10921387

poonyalidP Site owner

Hi,

I enable Encode URL for the Thai language already. Please see attachment.

Refer to my parent company website hidden link , the website are all in Japanese language and all the permalink, slug are in English.

So I want my website hidden link to be all permalink, slug in English too.

I tried to enter hidden link , but the url changed to hidden link everytime.

How to fix it?

Thanks.

5.JPG
April 1, 2022 at 12:29 am #10925357

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hi there,

To change the slug of the post types have to go to WPML -> Settings -> Post Types translation -> Change the slugs -> Save the changes.

Please visit this link where you will find a guide with the steps to follow in order to translate the post types slugs: https://wpml.org/documentation/getting-started-guide/translating-page-slugs/

Regards,
Carlos

April 1, 2022 at 3:18 pm #10930573

poonyalidP Site owner

Hi,

I'm not sure I setup correctly or not.

I change the "Post Types Translation>Products (product)> change from Translatable to Not Translatable" and click save.

But after try go to hidden link ,it still translated to Thai again. hidden link

Please help.
Thanks.

5.JPG
April 1, 2022 at 3:43 pm #10931027

poonyalidP Site owner

Hi,

More question, now I use Thai slug for thai language and use English slug with /?lang=en for English

Example for this Player page.

Thai:
hidden link

English:
hidden link.

If I want to stop using Thai in permalink and slug, and use only English in permalink and slub, how can I separate the use for Thai and Eng?

For the English is /?lang=en , how for Thai? /?lang=th ? or only English permalink and slug without /?lang=

Thanks for your help.

April 2, 2022 at 7:03 am #10934479

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hi there,

1.- Could you tell me which part of the documentation I shared you didn't understand?

2.- Please read this documentation so you will learn how to set up the Language URL Format: https://wpml.org/documentation/getting-started-guide/language-setup/language-url-options/

Regards,
Carlos

This ticket is now closed. If you're a WPML client and need related help, please open a new support ticket.