This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 1 reply, has 2 voices.

Last updated by Raja Mohammed 7 months, 1 week ago.

Assigned support staff: Raja Mohammed.

Author Posts
March 13, 2019 at 10:15 am

mathildaW

I am trying to: Synchronize cart content when switching languages - but it's not working I am still getting a message with the prompt saying that everything in my cart will disappear if I switch languages.

Link to a page where the issue can be seen: hidden link -> Change Language from English to Swedish

I expected to see: No prompt message at all.

Instead, I got: The default prompt message saying in Swedish (DU HAR VALT ATT BYTA SPRÅK
Om du byter språk till svenska så kommer din varukorg att tömmas.

BYT TILL SVENSKA
BEHÅLL ENGELSKA)

March 14, 2019 at 5:27 am #3340591

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

Welcome to our forum,

Please Goto > WoooCommerce >WooCommerce Multilingual > Settings
- In the Cart section under the title Switching languages when there are items in the cart
select the option
[x] Synchronize cart content when switching languages.

This will solve your issue. please check the attached screenshot.

Kind regards
Raja