This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 1 reply, has 2 voices.

Last updated by Diego Pereira 8 months ago.

Assigned support staff: Diego Pereira.

Author Posts
February 18, 2019 at 11:10 am #3211608

monaP-2

I am trying to:

Link to a page where the issue can be seen: hidden link

I expected to see: only the English articles on the English blog and the French ones on the French blog etc.

Instead, I got: all the articles, no matter the language, all in the English and Spanish blog while on the French blog I cannot see any article

February 19, 2019 at 11:57 am #3216442

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello @monap-2, welcome to the WPML support Forum!

Please go to WPML > Settings > Post Types Translation and check if the posts are set as "Translatable - use translation if available or fallback to default language". If so, please change it to "Translatable - only show translated items".

For more details:
https://wpml.org/documentation/translating-your-contents/displaying-untranslated-content-on-pages-in-secondary-languages/#displaying-original-content-for-whole-post-types

If the issue persist, please temporarily switch to a defualt theme (like twenty-seventeen). Does the issue still occurs with the default theme?

All the best,
Diego