This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 30 replies, has 3 voices.

Last updated by Itamar 5 months, 2 weeks ago.

Assigned support staff: Itamar.

Author Posts
April 17, 2019 at 2:10 pm

juneW

I am trying to: understand why two pages have become disconnected in the translation.

Link to a page where the issue can be seen:

Eng: hidden link - notice only EN toggle appears.

Fre: hidden link - notice no Toggle for EN FR exists at all on this page.

I expected to see: Here is a staging site I created just a few days ago where you can see how the toggle on these pages should be appearing and the two pages should be connected:

hidden link

hidden link

Instead, I got: The Eng and Fre pages on UNDE were somehow disconnected. I am trying to troubleshoot why this is happening on the site. It's happening elsewhere as well.

I notice on both the Live website and the staging that if I click on Modifier la page, I end up on the English version of Edit page.

April 17, 2019 at 2:20 pm #3631917

juneW

Note that I am also seeing this issue on a number of other pages on the live website.

1. Live: hidden link - missing language toggle

Staging: hidden link - shows toggle and goes to the correct language 'Edit Page'. However, I'm unsure if the System Fields are correct.

2. hidden link - missing language toggle

hidden link - shows toggle but if I attempt to update the page, I get taken to the eng. version of the page.

April 17, 2019 at 8:19 pm #3634687

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

I've checked things on your site, and I can see that 'Pages (page)' post type is set to 'Not translatable'. Please see the attached screenshot. This must be the reason for the problems that you have on your site. You can compare it to what you have on the staging site which I think is 'Translatable - use translation if available or fallback to default language'. You can read more about this last option on our documentation here.
https://wpml.org/documentation/translating-your-contents/displaying-untranslated-content-on-pages-in-secondary-languages/

Please let me know if this information is helpful to you.

Regards,
Itamar.

April 18, 2019 at 12:21 pm #3639069

juneW

Hi,

Yes I saw this discrepency between the two. However, as you can see via the video link below, if I try and change the radio button to either 'Make 'Pages' translatable ' or 'Make 'Pages' appear as translated', it reverts back to 'Do not make 'Pages' translatable'.

hidden link

Any ideas as to why this might be happening?

Thx.

April 18, 2019 at 12:27 pm #3639099

juneW

Note that I just checked plugins on the staging site and made sure that status of plugins between staging and the live site were consistent. Plugin conflict doesn't appear to be the issue.

Thx!

April 18, 2019 at 12:38 pm #3639173

juneW

I can also provide login details to the staging site so you can look at both via wp-admin. Please provide best method for providing the staging login credentials.

April 18, 2019 at 12:40 pm #3639179

juneW

Apologies for all the messages. I'm not sure that droplr.com link is working to the video. Here is another option for viewing: hidden link

April 18, 2019 at 4:07 pm #3640615

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi and thanks for the video.

I suspect that there is a collision with the theme or another plugin that might cause this problem. If possible get your site into a minimum environment. Minimum environment means switching to a default WordPress theme like Twentyseventeen and no plugins activated except WPML.
Is it possible for you to try it?
You will need first to check if the problem persists when just the theme is switched to Twentyseventeen (for example). If it persists then deactivate all plugins except the WPML and its add-ons and WooCommerce itself. Then please check if the problem persists. If it does not persist so start by activating the plugins one by one and check when the problem comes back, then report to me which was the culprit plugin.

**** Important! Please make a full site backup (files and DB) before you proceed with those steps****


*** If your site is a live site you might want first to try those procedures in a staging environment or a snapshot of your site on your local server or another server. ***

If the minimum environment procedure did not point to the problematic plugin or theme, please do the following:
Please provide me with the WordPress debug.log
Please check this page for instructions.
https://wpml.org/documentation/support/debugging-wpml/
Look under the headline "Enabling the built-in debugging feature in WordPress".
To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);.
Change it to:

define('WP_DEBUG', true);
// Enable Debug logging to the /wp-content/debug.log file
define('WP_DEBUG_LOG', true);
// Disable display of errors and warnings which is recommened on a live site.
define('WP_DEBUG_DISPLAY', false);
@ini_set('display_errors',0);

Then repeat the action that causes the issue (try to switch pages to translatable). In this case, the errors will be saved to a debug.log log file inside the /wp-content/directory.
If you can paste your debug.log to pastebin.com and provide me that link, it would be great! (This is the cleanest way because sometimes the logs are long and create a complete mess in discussion).

Please, could you provide me the additional Info?

Thanks,
Itamar.

April 18, 2019 at 6:50 pm #3641525

juneW

Hi, I am in the process of setting up a 2nd staging to carry out your recommendations on.

However, I did just try to turn on the WPML debug in the wp-config of the live website and there is no reference to WPML in the wp-config file.

Please advise.

April 21, 2019 at 6:51 pm #3652873

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

I'm sorry if I was not clear enough, but when I asked you turn on the debug option in the wp-config.php file, you shouldn't look for any reference for WPML. You should enable the WordPress debug option. You can read more about it in the WordPress documentation here.
https://codex.wordpress.org/Debugging_in_WordPress
All the detailed explanations are in my previous reply.
Please let me know if you need help with enabling the WordPress debug log.

Regards,
Itamar.

April 24, 2019 at 12:07 pm #3672461

juneW

Thanks Itamar - Note that I am still working on this. I should have some feedback later today.

Tanya

April 25, 2019 at 2:20 pm #3683383

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Itamar is having couple of days holidays. Sure you can take your time to check it and let us know when you have some news.

Thank you

April 25, 2019 at 6:42 pm #3685117

juneW

Thanks Noman,

Ok, so here is an example that may help us troubleshoot our issues above.

I have created this new page on the live website: hidden link

What I want to do is duplicate the English page to French where all the ACF content blocks and content is copied over to French just once after which I will edit the individual content blocks with french text .

However, on the Edit Page of the duplicated french page, I do not see any of the english content blocks that were copied over.

Here's what I did:

1. Created the page in English. Added all the ACF content blocks in English.

2. In the Multilingual Content Setup box:

a. I changed the radio button from 'Do not make 'Pages' translatable' to 'Make 'Pages' translatable'.

b. Under System fields, I updated all radio buttons from 'Don't translate' to 'Copy Once'.

c. I Clicked Apply button

3. In the Language box in right sidebar, I checked the 'Duplicate' checkbox and then selected 'Duplicate' button.

4. Next I clicked on the pencil icon to edit the French version of the page.

Here is where saw there doesn't appear to be any content to edit on the French side.

So what am I doing incorrectly here? I am expecting to see the same ACF content blocks on the French version of the page.

Thanks!

April 25, 2019 at 6:43 pm #3685127

juneW

And to clarify on my response above, we now want the French and English pages to be translated independently. Changes made on French should not affect English and vice versa.

Thx!!

April 28, 2019 at 4:47 pm #3698637

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

When I check now the French translation here hidden link I can see that custom fields there. Please see the attached screenshot. Also, they are showing on the front-end here hidden link

Things look OK.
Have you managed to solve this problem?

Regards,
Itamar.

The topic ‘[Closed] The associated translation of a page is disappearing.’ is closed to new replies.