Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Sun Mon Tue Wed Thu Fri Sat
- 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 9:00 – 13:00 -
- 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 14:00 – 18:00 -

Supporter timezone: America/Los_Angeles (GMT-08:00)

Tagged: ,

This topic contains 43 replies, has 2 voices.

Last updated by Bobby 1 week, 4 days ago.

Assisted by: Bobby.

Author Posts
April 3, 2023 at 12:01 am #13385771


The automatic translation has been stuck for a long time. I started two weeks ago. Before I have another license. I also contact you for the same reason one week ago (read the mail attached to understand). Today I bought again the license to receive support. I follow the guide in the forum to apply the new license, I stop an restart the consumer credits. The only changes is that the translation service is not anymore in error, but still in the same screen without translate anything.
After the installation of the new license, the plugin give me other error, so I was "forced" to translate all my product taxonomy as my brand (that's not necessary for me).
In the other screenshot there are some of the last error and the message that the plugin show me. I would like to precise that the error you see it wasn't before the license change, but in the meanwhile I also upgrade to php 8.1 from 7.4 to be sure that the issue wasn't provide from php.
I was redirect to the troubleshooting page by the plugin and I run the task as in the screenshot.
I can provide an account to access to the site if needed.

Screenshot 2023-04-03 alle 01.58.42.png
Screenshot 2023-04-03 alle 01.51.03.png
Screenshot 2023-04-03 alle 01.46.26.png
April 4, 2023 at 2:31 am #13395391


Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Hi there,

There are a few things that I see going on here.

1. the product_type taxonomy -> Go to Taxonomies Translation -> Product_Type and set to "Not translatable"

2. Could you share with me what the other error is saying as it's not in English

3. Go to WPML->Translation Management->Automatic Translation -> are you using pay-as-you-go or pre-paid credits?

It looks like you might have run out of credits thus the translations are pending until more credits are purchased.

April 4, 2023 at 7:42 am #13396973


1) I solve it, thanks
2) This is the translation about the second error. I test to disable some plugins (not all because something is necessary to the site to work.

Some taxonomies on your site are being forced as untranslatable. This will cause an issue when trying to run a multilingual WooCommerce site.
This is most likely caused by a plugin or theme.
What you can do:
Temporarily disable plugins to see if this message disappears.
Temporarily change the theme to see if this message disappears.
We recommend that you contact WPML support, report that you are receiving this message, and make yourself available to send a duplicate copy of the site. We will work with the theme/plugin author to best resolve the issue. In the meantime, we will offer you a temporary solution so that you won't be stuck.

3) I have the pay-as-you-go subscription, as in the screenshot.

Is it possible to translate again all the products? Because some I translated some of products with api rest before activate the subscription, but I would like to have all translated in the same mode because probably I didn't translate something and also in that product there ins't advance wpml translation. I know that I'll consume more credits, but it's ok

April 4, 2023 at 7:47 am #13397239


I would like also to share this screenshot, the products, that I highlighted, are in loading since days...

Screenshot 2023-04-04 alle 09.45.08.png
April 4, 2023 at 6:25 pm #13403335


Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Thank you for updating me!

For #2 we will most likely need to split it into it's own ticket and debug further, let's first focus on the automatic translation issue and afterward we can review it.

You should be able to go to WPML->Translation management->select specific pages you want to translate again and send them for translation, do this also, for the ones loading.

Let me know your results, please.

April 5, 2023 at 9:46 pm #13414391


If I select some products and trigger manually the automatic translation it works, I see that I use more credits and the page or product I selected seems to be translate. After the plugin translate what I selected manually it return to a freezing status and sometimes give me an error. It seems as it has in cache something that it isn't able to translate...
It's a little bit difficult to trigger all manually because the site has lot of products....
In addiction I notice some other issues. When the automatic translation start my site low down. My site is hosted in bitnami, The machine has a lot of ram and cpu. I attach the chart. I need to reboot the machine several times today. I go further, in the apache folder of the server I found the fatal wpml log several times, like this:

 [Sun Apr 02 17:50:21.694915 2023] [proxy_fcgi:error] [pid 2010:tid 139919607449344] [client] AH01071: Got error 'PHP message: PHP Fatal error:  Uncaught TypeError: array_key_exists(): Argument #2 ($array) must be of type array, bool given in /bitnami/wordpress/wp-content/plugins/wpml-sticky-links/classes/custom-fields.php:169\nStack trace:\n#0 /bitnami/wordpress/wp-content/plugins/wpml-sticky-links/classes/custom-fields.php(169): array_key_exists()\n#1 /bitnami/wordpress/wp-content/plugins/wpml-sticky-links/classes/custom-fields.php(83): WPML\\SL\\CustomFields->getSettings()\n#2 /opt/bitnami/wordpress/wp-includes/class-wp-hook.php(308): WPML\\SL\\CustomFields->convertUrlsInCustomField()\n#3 /opt/bitnami/wordpress/wp-includes/class-wp-hook.php(332): WP_Hook->apply_filters()\n#4 /opt/bitnami/wordpress/wp-includes/plugin.php(517): WP_Hook->do_action()\n#5 /opt/bitnami/wordpress/wp-includes/meta.php(154): do_action()\n#6 /opt/bitnami/wordpress/wp-includes/meta.php(250): add_metadata()\n#7 /opt/bitnami/wordpress/wp-includes/post.php(2524): update_metadata()\n#8 /bitnami/wordpress/wp-content/plugins/woocommerce-order-status-manager/src...', referer: <em><u>hidden link</u></em>
Screenshot 2023-04-05 alle 23.21.35.png
Screenshot 2023-04-05 alle 22.44.50.png
Screenshot 2023-04-05 alle 21.30.30.png
Screenshot 2023-04-05 alle 09.10.08.png
April 6, 2023 at 8:46 pm #13423057


Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Try the following please:

1. Increase the PHP Time Limit from 30 to a higher limit if possible and try again

2. Go to WPML->Settings->Translation Mode->switch to "Translate What You Choose" and save

3. Switch back to "Translate Everything Automatically" this should re start any stuck jobs.

Since we use Translation Memory you will not be charged twice for any content that has already been translated.


Are you currently using the WPML Sticky Links plugin?

I ask this because some users only activate it because they think it is a must-plugin when using WPML. If this is the same case as yours, you can deactivate this plugin and thus avoid the error.

Let me know your results, please.

April 8, 2023 at 6:56 pm #13431953


I follow your suggestions, I increase the time limit (screenshot "Wordpress_settings"), then I follow your instructions to switch the translation mode.
WPML calculated again all the string to translate, then it started to translate, but I have lots of truble.
The site started to slow down a lot , until it give me gateway error. I need to go to the Bitnami user panel and reboot the machine. Again after few minutes the server started to go slowly until I'm not able to do anything. With ssh I use wp-cli to deactivate almost all plugins (but not WPML) because I supposed some incompatibility. I leave some because they are necessary. You can see the last tested configuration in "Plugin" screenshot. Respect to the screenshot, also Codisto Channel Cloud was deactivated only for a while because it synchronize the shop with amazon and eBay and it was necessary for the shop owner.
The site continued to go slow and sometimes give us gateway error so I try to deactivate WPML and all went well. I notice also an incredible speed bump of the site in particular about products and orders. The server is well sized as you can see in the Server_configuration screenshot. In the same screenshot you could see when I started the automatic translation (high peak of the database connections) and the performance error (low peak of the site).
I try to leave a night to translate because I supposed the plugin needed sometime to stabilize or translate, but today in the morning the situation is the same. Now I retest it and I switch off and on the automatic translation. In a day it translate only 600 products from Italian to other 4 language and there's not so many information in the product.
It's a big issue for us because also in the past I have some issue about site performance. I increase the server, clean the database, recreate and modify some tables indexes and leave only the necessary for the site. Now I understand that the WPML plugin consume lot of resources and even if the server is big, no difference. The site have 16000 products and 5 languages. I didn't see in WPML site some limitation about that and I read about WooCommerce that's able to have also 1 million of products, so I was confident that there's no matter.
Is there some solution about that?

April 10, 2023 at 5:55 pm #13439239


Yesterday and today I'll continue to try. I stop and restart automatic translation because I have the error in the screenshot, as I didn't have any credits left, but in reality I had Credits as you go plan. I receive a receipt, then after an hour, I restarted the plan. I test automatic translation again. It block my site multiple times. I also test to change the theme with a default theme, but the situation is worst because wpml plugin block the site multiple times, the theme change starts to recreate image thumbnails and use lot of more resources. I need to recover a backup. These is the production site and I was obbligate to work also in these days of holiday.
Now I recover the site. Stop the automatic translation and I'm triggering the translation by hand each 200 of products. In these moment it seems to work, but that's not a possibile solution for long time and it's a little bit difficult to translate all almost 16000 products in this manner. If you need I can share an admin account to check the site

Screenshot 2023-04-09 103630.png
April 10, 2023 at 8:53 pm #13440269


Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Thank you for updating me on your results!

I would like to request temporary access (wp-admin and FTP) to your site to test the issue.
(preferably to a test site where the problem has been replicated if possible)

**Before we proceed It is necessary to take FULL BACKUP of your database and your website. Providing us with access, you agree that a backup has been taken **

I often use the Duplicator plugin for this purpose:
You will find the needed fields for this below the comment area when you log in to leave your next reply.
The information you enter is private which means only you and I have access to it.

NOTE: If access to the live site is not possible and the staging site does not exist please provide me with a duplicator package created with the duplicator plugin.

Thank you,

April 11, 2023 at 6:14 pm #13449303


Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Thank you for the access details!

Since we are working on resolving the issue with the automatic translation not working and being stuck, if possible go to WPML->Translation Management ->Tools and either activate the pay as you go plan or connect it to the existing one

Then try to translate using the automatic translation and let me know your results.

are you able to reproduce the same behavior on this copy?

April 11, 2023 at 9:23 pm #13450417


I just activate the automatic translation in this copy, the production site become slower and slower after a period of time, generally after some hours...let's see...the problem is that sometimes it's impossible to access to the site until I reboot the bitnami machine

April 12, 2023 at 10:49 am #13454553


I just screenshot the page in the test site after I enable the automatic translation, but is the same as hours ago, it doesn't go on. In the production site if after some page refresh starts to translate, after some hundreds of translation block the site. Now it seems it's not able to start.

April 13, 2023 at 12:35 am #13460327


Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

When I go to WPML->Translation Management->Tools I can see that the pay-as-you-go plan is not activated and also not connected to the main account that the production is using.

I have manually connected the 2 now so we can see the same things as the queue will stop working if the credits are not available.

Now that it's set up correctly I will restart

In the meantime can you please also enable REST API

I will check back once it is done and update with my results

April 13, 2023 at 8:27 am #13462311


Sorry for the configuration, after the duplication didn't check everything of the site, I only discourage indexing and start the translation. I attach the screenshot with test I made to show that WordPress Rest Api was active in both production and test site.
In these days I continue to do some test and work (directly on the production site). I share with you, hoping that will be useful.
I select manually products to translate, few at times (50 or 100 and sometimes 200). Generally it worked but yesterday when I try to translate 200 products in one shot (so I have 800 posts to translate because we have 4 more language in addiction to the default...) I had gateway timeout multiple times (even if I refresh page) but only for the admin page. The site will continue to work for customers. After a quarter the situation were the same. I try the apache server reboot but nothing. I restart my bitnami instance and also the database instance but the situation remain the same.
Then with bitnami ssh I check the ram with the command


that show the active processes. CPU was ok but I had multiple php processes whose sum occupied the most of the RAM (8gb). Maybe you'll find that useful because generally the RAM is lower.
I try with wp-cli to deactivate the sitepress-multiligual-cms, but I have a WordPress error that block the site (maybe if I had disabled the other wpml plugins the situation would have been different). I reactivated it, wp-admin page continued to give me gateway timeout. After a period of time (I went to sleep and check this morning) the site starts to work normally (even if the admin pages are slower as always with the WPML activated).