This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 8 replies, has 2 voices.

Last updated by Jamal 8 months, 2 weeks ago.

Assigned support staff: Jamal.

Author Posts
January 21, 2019 at 9:36 pm #3114165

jean-francoisR-8

I am trying to: Use a Blog Masonry & Grid plugin on my French page.

Link to a page where the issue can be seen: hidden link

I expected to see: A 10px bold font like in Icelandic : hidden link

Instead, I got: It appears for 2 seconds on the French page and then it changes into a big and thin font.

I of course checked many times and the Element has the same settings in the two langages (copy/paste)

Everything leads to think that it's a WPML problem because when I create a French post without an Icelandic parent, it works well.

January 22, 2019 at 10:53 am #3115738

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

Thank you for contacting WPML Support. I will be glad to help with this.

I cannot tell right now what causes this, but i have found in the browser developer tools that the css file hidden link overrides the style.
This file is loaded for both languages. But affects only the french version.

I can suggest creating a css style and scope it to french like

html[lang=fr] .entry-title {
  /* style here */
}

and add it in WPML->Languages->Language switcher options->Additional CSS.

Can you provide an example of a french page that is not showing this issue ?

Best regards,
Jamal
WPML Support

January 22, 2019 at 1:31 pm #3116627

jean-francoisR-8

Thank you very much for your answer.
I'm going to contact our webmaster.

Here is a link to a French page where the text is similar to the Icelandic one: hidden link

January 22, 2019 at 1:34 pm #3116647

jean-francoisR-8

Just for information.

I created a new page with the same code as hidden link

The page is: hidden link

The only difference is that this test page is not linked to an Icelandic translation and it seems to be working fine

January 22, 2019 at 2:04 pm #3116806

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

Thank you for your feedback. I checked the examples you provided and i still see that hidden link file overrides the styles.

Would you try to create a test page in the default language, and then translate it to french?

Best regards,
Jamal
WPML Support

January 24, 2019 at 12:02 pm #3124902

jean-francoisR-8

Dear Jamal,
I've created a test page in Icelandic and translated it.

Here is the result and it seems to be working fine.

hidden link
hidden link

Why is it an isolated case on the official page then?
I want to inform you that before asking for your assistance, I had already deleted the pages and done everything from the ground again.

Thanks in advance.

Florent GAST

January 24, 2019 at 4:05 pm #3126011

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hi Florent,

Thank you for your feedback. Why is this issue only happening to the homepage ? You are using a custom block with the page builder that is adding this piece of style and i just cannot tell why it is only happening in the homepage.

As a workaround you can add the following code to WPML->Language->Language switcher options->Additional CSS. See attached image

html[lang=fr-FR] .blog-shortcode .entry-title {
    font-size: 10px;
    font-weight: bold;
    line-height: 15px;
    cursor: pointer;
    display:inline-block;
    font-family:"Open Sans", Helvetica, Arial, Verdana, sans-serif;
    font-size:10px;
    font-stretch:100%;
    font-style:normal;
    font-variant-caps:normal;
    font-variant-east-asian:normal;
    font-variant-ligatures:normal;
    font-variant-numeric:normal;
    font-weight:700;
    height:30px;
    line-height:15px;
    margin-bottom:0px;
    margin-left:0px;
    margin-right:0px;
    margin-top:0px;
    padding-bottom:0px;
    padding-left:0px;
    padding-right:0px;
    padding-top:0px;
    text-align:center;
    text-decoration-color:rgb(60, 62, 69);
    text-decoration-line:none;
    text-decoration-style:solid;
    text-size-adjust:100%;
    text-transform:uppercase;
    transition-delay:0s;
    transition-duration:0.35s;
    transition-property:color;
    transition-timing-function:ease;
    width:146px;
    word-spacing:0px;
}

It will bring the same style to french pages that presents this issue.

If you want to debug this issue further, check what blocks you are using in the homepage, if any block is added by another plugin, it may add its own style. Check by elimination until you find where this is coming from.

Let me know what do you think about it.

Best regards,
Jamal
WPML Support

January 28, 2019 at 10:52 am #3135033

jean-francoisR-8

Thank you very much for your help. I'm gonna ask our webmaster to have a look. I will let you know when it's fixed.

Best regards.

January 28, 2019 at 11:22 am #3135113

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hi Florent,

Thank you for your feedback. I look forward to know his findings.

Best regards,
Jamal
WPML Support

The topic ‘[Closed] The Blog Masonry & Grid plugin doesn't show the correct font once translated’ is closed to new replies.