This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by Yvette 1 year, 1 month ago.

Assigned support staff: Yvette.

Author Posts
October 3, 2018 at 3:45 pm #2785112

mandarina-diseno-grafico-y-webS

I am trying to:
How to save independently and unsynch all translations for all existing pages, and custom post types

Instead, I got:
When I change any field from any page from the default language, that field is synched to all languages.
I have to go to the translation manager and mark as "translation finished" for that field (untill 100% translation is completed) and then I see it in that language again.
And cannot see the button of "Translate independently" and it's very frustrating.

Is there any bulk way to do it for all already created potst/pages?
- Save as all posts in they own language ( they are translated but still synched )
- Mark as independent translation

October 5, 2018 at 9:21 am #2790087

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hello

I am not quite understanding your workflow or objectives but I will answer your questions one-by-one .

You wrote: "I have to go to the translation manager and mark as "translation finished" for that field (untill 100% translation is completed) and then I see it in that language again."

Response: You can always mark the option to notify the system that it is a minor change and no updates are needed. You can also change the translation options on the field to be "translate" and not "copy". This will stop the synchronisation of the fields.

You wrote: "...cannot see the button of "Translate independently" and it's very frustrating...."
Response: This is only availalbe for Duplicates. If you have a Translation, then it will not appear.

You wrote: "..Is there any bulk way to do it for all already created potst/pages?.."
Response: You would have to execute an SQL query on the field "_icl_lang_duplicate_of" to replace or remove it. I should test it first. You also might try using the Translation management to "Bulk" translate the duplicated posts. Again, would need to test.

If you could explain what you are trying to achieve and a concrete example, I could perhaps improve these answers though

Kind regards

October 8, 2018 at 10:33 am #2795535

mandarina-diseno-grafico-y-webS

Hello, thank you very much for you response

As I might not explained the problem clearly. lets focus in the first issue, I'll include some screenshots:
1) As you can see in wpml-field-status.PNG the hero_text is marked as translate and not copy
2) If I update the value in the primary language (french) like in wpml-field-change.PNG and save
3) the icon changed from edit tu update in secondary language (english) as you can see in icon-changed-to-update.PNG
4) when i click on it, the "trasnlation finished" gets unmarked for that field in english, so I see the primary language value for that field (it was marked before i updated the primary language's value).

This doesn't not make any sense for me, if I could fix this behavior i would do it manually (so lets forget about the bulk action for now)

Thank you very much

October 8, 2018 at 10:52 am #2795663

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hello

Thank you for the fuller explanation.

You wrote: "... when i click on it, the "trasnlation finished" gets unmarked for that field, in english, so I see the primary language value for that field (it was marked before i updated the primary language's value). "

My response:
The system has detected that you have changed the value of the field in the primary language and therefore notifies you that the translation needs to be re-checked in the 2nd language. This is why the field that was previously fully translated is now "unchecked".

This seems logical to me since changing the text in the original language would imply that your translation is not longer valid.

The only way I can see to "deactivate" this behaviour is for this field to be set as "Do not translate". In this way, the field is not monitored for changes/synchronisation and also will not be avialable to the Translation Edtior. It would imply, however, that to change the value of the translated text, you would either need to:
- edit this field WITHOUT the translation editor (e.g. manual edit of target post with native WordPress editor)
- OR -
- change the tranlsation option of this field back to "Translate" when you want to edit the values using the Translation Editor.

I wait for your feedback.

October 9, 2018 at 1:12 pm #2800098

mandarina-diseno-grafico-y-webS

Hello,

thaks again,

but "The only way I can see to "deactivate" this behaviour is for this field to be set as "Do not translate"." won't fix the problem. this produces the exact same behavior.

We setted one field to "not translate", then we went to the original language, made some changes and this value was unmarked from "translation finished" in other languages.

Is there any way to disable the translation manager and treat each translation as different posts ( like WPML used to work no long a go? when you copied the content to the other languages and then clicked in "Translata independently" )

thank you

October 9, 2018 at 2:45 pm #2800531

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Of course.

You can set the following configuration to not use Translation Editor:

WPML -> Settings -> How to translate posts and pages -> Create translations manually

October 9, 2018 at 3:44 pm #2800884

mandarina-diseno-grafico-y-webS

thank you,

The thing is that i cannot see that page ( i copied from another environment that works the url: wp-admin/admin.php?page=wpml-translation-management%2Fmenu%2Fsettings )

Any idea what might be causing this? ( attached screenshot )

PS: the user i'm logged in with is role Adminstrator

October 9, 2018 at 4:58 pm #2801304

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

This seems to be a not-so-uncommon WordPress error.

I found a thread where the role capabilities for WPML were reset as follows:

- Switch to a defaul theme like Twenty Seventeen
- Open the functions.php file of the theme and insert these lines:

// reset the roles
if ( !function_exists( 'populate_roles' ) ) {
  require_once( ABSPATH . 'wp-admin/includes/schema.php' );
}
populate_roles();
 
// reset the WPML capabilites
icl_enable_capabilities();

- Upload the file and refresh the front-end
- Click on the WPML > Languages, and the configuration page should be displayed.
- Remove the lines above
- Switch back to your normal theme

Please let me know if this resolves your issue.

The topic ‘[Closed] The button of "Translate independently" is missing’ is closed to new replies.