This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 60 replies, has 2 voices.

Last updated by Lauren 2 months, 4 weeks ago.

Assigned support staff: Lauren.

Author Posts
April 5, 2019 at 8:00 pm #3546683

angelaG-5

The page I translated using WPML plugin does not show up in the live site after I see the handoff is received successfully.

April 5, 2019 at 8:09 pm #3546719

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thank you for contacting WPML support. I'll be happy to help you with this.

I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

April 5, 2019 at 9:01 pm #3546985

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Please me the access to your site so that I can further troubleshoot. If that is not an option, you can send me a duplicator snapshot so that I can test locally. The next reply is marked as private. Thanks!

April 5, 2019 at 9:20 pm #3547091

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

The Data Science page that we have been referencing is showing as Waiting for Translator, and it shows as available for translation in WPML -> Translations. If you are using memoQ, it should be sent to the professional translation services and then once they have completed the transfer, you should receive an update. Then, you can go to WPML -> Translation Management and click Check Status and get Translations.

Please let me know once that is done if the content is still not showing as translated in the secondary language.

April 5, 2019 at 9:34 pm #3547107

angelaG-5

I didn't create the job (I thought you did.) and that is not the issue what I am referring to. You don't seem to remember we discuss this about two hours ago through the chat program. You had suggested something and asked me to come back if it didn't work. For the reminder, here is the original entry.

https://wpml.org/forums/topic/translated-contents-delivered-back-does-not-appear-on-the-web-site/

I couldn't create a duplicate entry (this system claimed I can't make a duplicate entry.) so I couldn't paste the same info.

Anyway, the issue is that I sent work by going as below:
1. On WP, Go to WPML -> Translation Management
2. Select one of the page (Ex. "Video Library") and submit for translation
3. I get translated contents back by doing "Get Translations". The status shows the job is complete.
4. Go to the live web site and there is no translated text. I checked the deliverable is translated so it looks like the contents is not properly pulled in.

We are using the WPML plugin to send work to memoQ which doesn't have WPML plugin setting and workflow.

The other problem is that I cann't export in XLIFF format. (Please see the original entry which has the screenshot.)

There is another issue also which is related to having the "French" in the menu. See more info about this also in the original entry.

Please advise.

April 5, 2019 at 9:51 pm #3547113

angelaG-5

I forgot to mention that I chose "memoQ(First Available)" in "Translation Bascket" not Shoichi Takasaki, and then click "Send all items for translation. I don't think choosing "Shoichi Takasaki" works because it is not associated with memoQ so I can't translate it with it.

April 6, 2019 at 12:17 am #3547395

angelaG-5

I found a few interesting facts.

1) The translated contents is found in XLIFF but it still doesn't show in the web site.
Using the process I explained earlier, "Data Science" page was translated (using "memoQ") but the translated contents did not show in the live web site. However, when I re-assign the page to translate it to myself "Shoichi Takasaki", then export the contents into an XLIFF. I do see the translation is there. This means the translation is done corrected and received by WP or WPML plugin but it is not correctly shown in the live web site. That should be where the problem is. (See the attached image file showing the XLIFF file and the translation in it.)

2) Importing worked for one page for some reason after updating WPML plugins
hidden link

This page shows French successfully after translation and importing. But after I tried the same process (translation and importing), it didn't work for this page below:

hidden link

Please advise.

April 8, 2019 at 1:57 pm #3558367

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I have sent you a private reply. Please let me know once the site migration is completed and I will continue troubleshooting there. Thanks!

April 8, 2019 at 7:53 pm #3561115

angelaG-5

Thank you for your support. The migration is done and ready. Could you prepare a secure page so that I can share some private info (ex credential)?

April 8, 2019 at 8:23 pm #3561175

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thanks so much. The next reply is marked as private so that you can securely share information.

April 8, 2019 at 9:14 pm #3561415

angelaG-5

It looks like this comment field is visible to others in public so I am deleting it just in case. Could you reprepare a secure response or confirm this reply field is secure?

April 9, 2019 at 12:14 pm #3566639

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

This reply is marked as private. YOu may need to refresh the screen to see the private fields. Thanks!

April 9, 2019 at 6:40 pm #3570077

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

It looks like the Cloudways migration was not completed. Do you prefer me to use the staging site you sent to me for testing? If so, is it okay to disable plugins/themes and make changes on this test site? Just want to confirm before I make any changes. Thanks!

April 9, 2019 at 11:16 pm #3571157

angelaG-5

Yes, it is fine to disable items on the staging site that we sent over.

April 10, 2019 at 2:36 pm #3577475

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Great thanks. I set your site to minimal settings (only WPML activated and default theme Twenty Nineteen) and you can see that the translated content correctly shows on the front end: hidden link

So it seems likely there is a conflict with the Black Studio TinyMCE Widget plugin. When you activate Site Origin and then this plugin, you will see that the translated content no longer displays. Can you please confirm this on your live site as well? If this is the case, I will try and reproduce on a clean install and if I am able to, we can escalate this to our compatibility team.

The topic ‘[Closed] The closed issue about translated page did not get resolved.’ is closed to new replies.