This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 60 replies, has 2 voices.

Last updated by Lauren 5 months ago.

Assigned support staff: Lauren.

Author Posts
April 10, 2019 at 4:18 pm #3578447

angelaG-5

Yes, I do see "Black Studio TinyMCE" Widget listed in the Plugins page.

However, in the page you said you see French at the link below, it looks only the title translated but not the body contents. Which we translated so it is not still showing the body contents in French.

hidden link

Look at the screenshot attached. This is showing the XLIFF exported of the same page but from the live page. As you can see at the marked location, the corresponding French body text is found in the XLIFF file but not showing.

Plus, one another strange thing is that the corresponding English page has "resources" in the URL but the localized one doesn't.

Source URL
hidden link

In summary, the French title is showing but not the French body contents. Plus, the URL may be wrong as well.

April 10, 2019 at 5:36 pm #3579607

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

The body content was still not showing the translation because the Black Studio TinyMice Widget plugin was still activate it. If you deactivate just this plugin, no content shows, because Site Origin shows no existing widget. So you have to also disable Site Origin and then you see the translated content.

The difference in the URL is because the English page has a parent page set (Resources) and the French page does not have a parent page set. You can change this in the page edit screen when you use manual translation. It is in the Page Attributes section.

April 10, 2019 at 5:40 pm #3579707

angelaG-5

Ok. Got it. Thank you for sharing the screenshot. I take you are going to your compatibility team and will let me know once the issue is resolved?

April 10, 2019 at 7:12 pm #3580687

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Unfortunately, I was not able to reproduce the issue on a clean install. Feel free to visit the test site I created and mess around. Here are the steps I took:

1. Create a page using the Site Origin page builder. Add one SiteOrigin visual editor and one Black Studio TinyMCE visual editor widget.
2. Go to WPML -> Translation Management and send the page to translation basket.
3. Go to WPML -> Translation Management -> Translation Basket and send the content to myself (local translator)
4. Go to WPML -> Translations and download the XLIFF
5. Edit the XLIFF file and create the translations using an online editor. Download the new XLIFF.
6. In WPML -> Translations, upload the new XLIFF.

After these steps, the translated content displays on the front end of the site. Please feel free to test this here:
Login: hidden link
Username: demo
Password: gTM6gGa769Ch

I followed these same steps on your site, but the content does display on the frontend. So, I'm going to need to make a copy of your site locally since the cloudways migration did not work.

To best troubleshoot the issue, please make a snapshot of your site using the Duplicator plugin: https://wordpress.org/plugins/duplicator/. This will allow me to try and duplicate the error so that I can run further tests without interrupting your live site.

Once the snapshot is complete, either upload the snapshot ZIP file and the installer.php file to a file sharing service such as Dropbox (and share the link in your reply) or right click the Duplicator links in your wp-admin and paste in your reply.

Please note: It is important to reduce the size of the package so please exclude some paths like /cache or /uploads and also exclude archives and media files.

I will also need the username and password of an account that was created BEFORE creating the duplicator package.

I will enable the next reply to be private so only you and I have access to it!

April 10, 2019 at 7:47 pm #3580995

angelaG-5

Thank you for looking into it. At first, to be clear, the language that we are having this issue is French but the language you used for this test seems to be Spanish. Secondly, I don't really see any text in Spanish in below:

hidden link

Secondly, I could try to connect this test site to my memoQ server to see if it can send a content to it and return translation to duplicate the environment. Can you create a FR in this test environment?

In the meantime, I will ask the admin of ParkAssist site to create a duplicate and see if they can provide what you are asking.

April 11, 2019 at 4:39 pm #3590717

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

The content in Spanish as "ES" in the beginning, it's not actually translated. Just the language code added to differentiate the content.

I have added French as a language. Feel free to test anything in this environment that you need.

April 11, 2019 at 4:51 pm #3590811

angelaG-5

I tested Spanish with the memoQ connection on the site and it works. (I sent a page to memoQ through the plugin and return the contents after translation through the plugin connection back.) See the translated page in the link below.

hidden link

I will follow up with the WP admin to see where they are with the site duplication task and keep you posted.

April 11, 2019 at 10:14 pm #3593133

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Great, that's a good sign. I would suggest if at all possible, disabling all plugins other than WPML and SiteOrigin on your live site and see if that makes any difference.

April 14, 2019 at 9:12 pm #3608695

angelaG-5

Yes, I still need assistance on this issue.

April 15, 2019 at 6:07 pm #3615629

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Were you able to test the site with all non WPML plugins deactivated to see if that makes any difference?

April 15, 2019 at 7:00 pm #3615895

angelaG-5

I am asking the WP admin to do what you asked which is below. I will provide the zip ASAP.

To best troubleshoot the issue, please make a snapshot of your site using the Duplicator plugin: https://wordpress.org/plugins/duplicator/. This will allow me to try and duplicate the error so that I can run further tests without interrupting your live site.

Once the snapshot is complete, either upload the snapshot ZIP file and the installer.php file to a file sharing service such as Dropbox (and share the link in your reply) or right click the Duplicator links in your wp-admin and paste in your reply.

April 15, 2019 at 7:28 pm #3616115

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Great thank you, I will await the Duplicator snapshot.

April 17, 2019 at 11:57 pm #3635073

angelaG-5

Hi Lauren,

The WP admin (Phil) wrote:

Disabling the Black Studio TinyMCE Widget effectively removes most of the website content, as that is the main content editor widget that is used throughout the site. I'm not sure what happened along the way, as previously this widget was not providing any issues during translation.

I've tried to create another copy of the site using Duplicator, but it's not compatible with the WPEngine hosting service and it is unable to complete. I don't know what else to suggest right now. It feels like maybe a good solution for long-term efforts would be to move the page content out of the Black Studio widget and into another page builder like Elementor. This would obviously be a large effort though, so maybe a manual import of translations like Shoichi offered is the best solution for right now?

---

Could you help Phil by guiding him how to export data? I would really appreciate it.

April 18, 2019 at 12:59 pm #3639273

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I'm not sure that would be the best solution, since the Black Studio plugin seems to be working okay in the test site. I will be happy to manually set up a copy of your site if you would like so that I can further test. You can send me a database dump and the site files (you can exclude archives, backups and uploads folders) and I can set it up locally to test.

If you prefer to change text editors, then I would suggest using an export tool such as WP All Export. However, I'm not sure how it will work to export the content from one page builder and import into another, so you may need to run some tests first to make sure they are compatible.

If you would like to send me the files, you can upload them to DropBox or Google Drive and share the links where I can download everything. I have marked the next reply as private.

April 18, 2019 at 8:15 pm #3641783

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thanks, I got the files uploaded but I still need a database dump. I don't have Backup Buddy so the import does not work for me. I have marked the next reply as private. Thanks!

The topic ‘[Closed] The closed issue about translated page did not get resolved.’ is closed to new replies.