This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by Mihai Apetrei 3 months, 1 week ago.

Assigned support staff: Mihai Apetrei.

Author Posts
July 9, 2019 at 1:49 pm

Walton Kruger

I am trying to:

Have the conditional menu work on English on this page: hidden link but as soon as I change it doesn't work here: hidden link

Please help

July 9, 2019 at 4:10 pm #4172943

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

Can you please elaborate a bit more on the issue that you are experiencing and what exactly is that you are trying to accomplish?

I am not sure that I fully understand the issue that is taking place and what is the menu that you are referring to.

Also, when you say this "but as soon as I change it doesn't", can you please let me know what is exactly the action that you are taking? What do you "change" and what is not working?

I will be waiting for your response.

Kind regards,
Mihai Apetrei

July 10, 2019 at 7:33 am #4176615

Walton Kruger

So we have conditional Menus on this website: hidden link
Thus there is a different menu on these 2 pages
- hidden link
-hidden link

BUT as soon as I choose English on this page: hidden link, the conditional menu does not work and hidden link this page's menu shows up.

July 10, 2019 at 3:47 pm #4182307

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for the extra information.

I will spend some time on this and I will get back to you as soon as I have more feedback.

I will currently leave the ticket assigned to myself, too.

Kind regards,
Mihai

July 11, 2019 at 4:59 am #4186061

Walton Kruger

Thank you so much, would you be able to give me a time as I really need to fix this asap.

July 11, 2019 at 4:35 pm #4191943

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for your patience.

From what I was able to see here (hidden link), there are a good amount of plugin and theme updates available.

Can you please create a full backup of the current site, then update everything to the latest version and then check to see if the issue is still happening?

Please let me know how that goes and what are you able to find out.

I will be waiting for your response.

Kind regards,
Mihai