This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 11 replies, has 2 voices.

Last updated by Raja Mohammed 2 weeks, 5 days ago.

Assigned support staff: Raja Mohammed.

Author Posts
September 11, 2019 at 6:52 am #4550935

peterM-72

Hi,

The problem is that even though everything looks alright in the front-end, the customers pay in different currencys (SEK, NOK, EUR, DKK), the WooCommerce Order Management only shows SEK in the back-end.

Example:

Someone orders Product 1 in Sweden with value "250 kr". WooCommerce shows "250 kr"
Someone orders Product 1 in Finland with value "€25". WooCommerce shows "25 kr" instead of "€25"

WPML WooCommerce Multilingual and Multi-Currency are activated. All products are assigned with a price and this has been fully functional until recently.

September 11, 2019 at 7:58 am #4551221

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello Peter,

Please let me know here, Once the migration is complete,

Kind regards
Raja

September 11, 2019 at 12:01 pm #4553259

peterM-72

Hello,

The migration is now complete.

Please advice how to proceed.

September 12, 2019 at 4:56 am #4558353

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Checking your request

September 12, 2019 at 11:09 am #4560381

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Here is my observation so far :

The checkout and payment are successful with the selected currency even the order emails are correctly delivered with a proper currency symbol. Only in the orders page, the currency symbol defaults to Kr which is the site default currency.

I'm not sure if this is expected behavior or any of the plugin is conflicting with WPML, checking further.

September 12, 2019 at 11:35 am #4560589

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Seems like a compatibility issue with Klarna, The payment displays 25 Euro, However the order status displays 25 kr. Screenshot attached.

To isolate the issue please install klarna plugin to the sandbox site and complete the setup. WPML is already installed in the site please complete the setup similar to your site WPML configuration, let me know once done.

One Click Login: hidden link

September 12, 2019 at 9:16 pm #4564363

peterM-72

I've setup Klarna now, but it requires SSL to function.

I sure hope you don't want me to setup WPML a second time and that you instead reused the previous sandbox environment.

Let me know how to proceed.

September 13, 2019 at 12:56 pm #4568721

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Thanks, I am able to reproduce this issue, it seems like the issue is happening with payment gateways. I will escalate this to the second tier for a detailed investigation.

Kind regards
Raja

September 16, 2019 at 6:04 pm #4583083

peterM-72

Hello,

What's the status on this issue?

September 17, 2019 at 5:20 am #4585625

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

I'm afraid I don't have any update on this yet this is something worked on by our second tier supporters, I will let you once I hear from them.

September 24, 2019 at 7:20 am #4628541

peterM-72

What is going on? I need this resolved as all statistics is wrong.

September 24, 2019 at 1:27 pm #4631939

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Thanks for the followup, I just checked the escalated queue this issue is further escalated to the developers with a quick workaround fix that can help for the time being.

Open the file wp-content/plugins/woocommerce-multilingual/inc/class-wcml-orders.php

Search for the code

 add_action('updated_post_meta', array($this,'update_order_currency'), 100,4);

Replace it with

 //add_action('updated_post_meta', array($this,'update_order_currency'), 100,4);

Let me know if you can handle this, In case if you need assitance please share WordPress and FTP access to your site. I have enabled the private fields for you.

Kind regards
Raja

The topic ‘[Closed] The currency of orders in WooCommerce back-end only shows in one language’ is closed to new replies.