This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by Diego Pereira 5 months, 3 weeks ago.

Assigned support staff: Diego Pereira.

Author Posts
April 25, 2019 at 12:07 pm #3682143

telmoS

Tell us what you are trying to do?
Trying to add a language "pt" not pt-BR or pt-PT but similar to English that is country neutral.

Is there any documentation that you are following?
Yes another forum support ticket to add a custom language. However I receive "The default locale already exists." when following same instructions

Is there a similar example that we can see?
hidden link want similar for /pt/

What is the link to your site?
hidden link

April 25, 2019 at 7:08 pm #3685343

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello @telmos, welcome to the WPML support Forum!

I did some tests on a clean install and it worked if i used these options (see screenshot).

Could you please check if "pt" is being used as the default locale for another language?

Please let me know if it worked for you.

All the best,
Diego

April 26, 2019 at 7:20 am #3688287

telmoS

Hi Diego,

As far as I can tell no, it is not being used by any other language. I attach a screenshot of the language settings panel.

I attempted to add it again and this time I get an href already exists (screenshot attached). I wonder if I needed to wait until the previous attempt I did was fully removed?

Anyway, I am able to add pt locale but now how to fix the href already exists error?

Thank you for your support.

April 26, 2019 at 7:22 am #3688341

telmoS

Related to this, I also have this warning in the languages settings. I made sure there is no media or pages from my previous attempts of getting the pt language added but I still have this. Any idea where I can remove them ?

April 26, 2019 at 7:42 pm #3693115

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

I sent some instructions to replicate the website through a private message (previous answer).

Please let me know if it worked for you.

Kind regards,
Diego

April 27, 2019 at 4:55 pm #3695869

telmoS

Hi Diego,

Thank you for the assistance. I have started the migration. In your private message a database password was supplied however the password was not requested by the form.

Once I clicked migrate, a new page appears and spins for a while. After 4-5 minutes a new more extensive form appeared stating that there was some PHP error.

Please see attached images.

April 29, 2019 at 7:20 pm #3706295

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

Thanks, it seems that there is a setting on your hosting preventing the migration.

In this case, please send us temporary access to your WordPress dashboard (website URL, login and password) I'll check and do some tests. - Please use the private field to send the sensitive data - do not post if you do not see it.

It would be better if you give me a test site rather than the live site.

IMPORTANT Please backup a working copy of site files and database before.

Please also install these plugins, they will allow me to create a copy of your website:
Duplicator: https://wordpress.org/plugins/duplicator/
File Manager: https://wordpress.org/plugins/wp-file-manager/
All-in-one WP Migration hidden link

PS: To ensure the quickest and most accurate support, please provide your debug information so that I can get a look at some of your configurations. We have an excellent article on how to located here: https://wpml.org/faq/provide-debug-information-faster-support/.
NOTE: Please be sure to check the box to indicate you can provide debug info and paste your debug info in the debug field provided, and NOT in the general response field.

Kind regards,
Diego

The topic ‘[Closed] The default locale already exists when adding country neutral language pt.’ is closed to new replies.