This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by laylaV 2 weeks, 1 day ago.

Assigned support staff: Bruno.

Author Posts
September 27, 2019 at 5:27 pm #4656139

laylaV

I am trying to:
I've translated the homepage, 100%. Though, the translation is not showing, neither the English flag.

Link to a page where the issue can be seen:
hidden link

I expected to see:
An English flag on the Dutch homepage. It does show when I am logged in and look on the front. But it doesn't show when I am logged out of the website. The other English pages show up (also the flag on the other pages), and when I go to hidden link I get a 404

Instead, I got:

September 27, 2019 at 9:23 pm #4656787

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you for contacting us. Please make sure the language is marked as hidden by following the steps: click on the WPML > Languages > Hide Languages

Is the English language marked as hidden? If so, it is necessary to make it visible so that the page works correctly when access is unlogged.

If the problem persists, I'll need to request temporary access (wp-admin and FTP) to your site - preferably to a test site where the problem has been replicated if possible - in order to be of better help.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Note:

*** Please, can I install the Duplicator plugin (or All in One Migration) to make a copy of your site and install it on my test environment? This will help me debug the problem.

*** Note: Please make a full backup of your site.

Privacy and Security when Providing Debug Information for Support: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Thank you.

September 30, 2019 at 3:28 pm #4666033

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

Thank you. When I access your site it appears that the home page is not translated. I will attach a picture for you to see.

In your first post, you said that the home page had already been translated. Are you sure this page was previously translated or was it another page?

>>> I tried to solve it myself by using a backup, but somehow I can't make translations anymore now, so I've made it worse.

What is happening? Are you following any steps so that the translation does not happen? Are you getting any error messages?

Thank you.

September 30, 2019 at 4:00 pm #4666239

laylaV

Hi Bruno,

Thanks for having a look. If you login and go to pages (in the dashboard), it seems that the pages are not translated (there's the + sign, instead of a pencil) but if you open them you'll see that there's a translation; also for the homepage. I attached some screenshots so you see what I see.

The flags show on all the other pages on the front end, just not on the homepage.

September 30, 2019 at 6:25 pm #4667141

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

Thank you. By following the steps you posted I was able to see the page you were reporting. After marking the fields as "Translation is complete" the pencil icon was displayed, as well as the English home page.

Note that some fields were not translated, so for testing, I just copied them from the default language. You can go to the page and translate the remaining fields.

By following these steps, can you translate the other pages? If the problem persists with the other pages, please let me know. Be sure before you translate and mark the options as "Translate is complete".

Thank you.

September 30, 2019 at 10:25 pm #4667683

laylaV

Seriously, this is driving me nuts! So, you are right, I can translate them. But seriously, before I contacted you I tried this several times and couldn't save the translations. So the + button kept showing like nothing was translated. I also marked all the checkboxes till 100% so I am not sure what was going on there. Thanks for your time, appreciated! 🙂

September 30, 2019 at 10:47 pm #4667689

laylaV

So, I was able to update all the pages. Though.. now when I am on the English version of the homepage, the menu is not showing anymore :s Synchronising the menus doesn't help..

September 30, 2019 at 10:52 pm #4667717

laylaV

Solved that menu thing myself, thanks Bruno!