This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 17 replies, has 2 voices.

Last updated by Mihai Apetrei 6 months, 3 weeks ago.

Assigned support staff: Mihai Apetrei.

Author Posts
March 1, 2019 at 10:21 am #3259608

ireneF-9

I translate the site, but the english menu doesn't show in the home page, but in the others pages appears

March 1, 2019 at 10:28 pm #3263303

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

1. I have noticed that your website’s WP Memory Limit is 40MB. The WP memory limit needs to be increased as the minimum requirement for WPML is 128Mb WP Memory Limit: https://wpml.org/home/minimum-requirements/

❌ Very important: please make a backup of your site (files & database) before following any of the upcoming steps ❌

Please add this to your wp-config.php file to increase WP memory:

/* WP Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

Paste it just before:

/* That's all, stop editing! Happy blogging. */

These settings can be limited directly by your hosting provider, so, if that’s the case, I recommend you to contact and ask them to modify them directly. If you can get even higher values It would be great.

Please make sure you have updated the values successfully, You can verify them from WPML >> Support page.

2. Make sure that the theme you are using and all the plugins are using the latest versions. If not, please update them to the last version, only after you create a full website backup.

3. Can you please let me know if the homepage is translated?

4. Also, I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of the site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box.

The private box looks like this: hidden link

Just a note that I won't be working on the weekend so I will be able to get back to you at the beginning of next week.

I will be waiting for your response.

Kind regards,
Mihai Apetrei

March 7, 2019 at 9:31 am #3283179

ireneF-9

Hi, could help me. I write to you I haven't have an answer...

March 7, 2019 at 6:32 pm #3286405

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

I don't see any replies on this ticket! Can you please let me know where else you wrote to us?

Also, can you please let me know if you were able to follow the recommendations above?

I am looking forward to your response.

Kind regards,
Mihai Apetrei

March 8, 2019 at 9:18 am #3290438

ireneF-9

Hi,

I answer here and send you the info to enter to the website.... The memory limit has been update to 256m.

The home page is translated (of course).

Now doesn't appear the box to send you again the admin o ftp access. How can I send you the credentials?

March 11, 2019 at 9:44 am #3309317

ireneF-9

Hi, I write to you a few days ago, and I hanven't have an answer. I have the issue in the website for days, and my client is angry because the website is online... Can you give me a solution?

March 11, 2019 at 10:39 am #3309813

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

Thank you very much for your patience and I am very sorry for the delay in response but our ticket queue has been really full and I also don't work on the weekends.

It is really weird that you were not able to find the credentials private fields but I will enable them once again below.

If you still can't see them, can you please use an incognito browser window or try using a new browser as this might happen either due to caching or a browser extension.

Please let me know if you see the fields now.

I will be waiting for your response.

Kind regards,
Mihai

March 12, 2019 at 5:42 pm #3327159

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

I totally understand the place you are in at this moment and now, that I have access to the site, we can move faster.

From what I can see, that header with the language selector in the top right was created with Elementor (it's called: header principal).

Also, from what I can see, there was a redirect set for when someone was trying to go to the English version of the site (hidden link) - this link was always redirecting people to the Spanish homepage.

After I disabled the 404 to 301 plugin, that links work now.

Can you please let me know if that fixed the issue?

March 12, 2019 at 5:50 pm #3327173

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

If that didn't fix the issue, can you please explain to me a little bit more what are the exacts steps that you are taking and what you would expect to happen? That will help me better understand what you mean.

I will be waiting for your response.

Kind regards,
Mihai

March 19, 2019 at 12:44 pm #3379061

ireneF-9

Hi, The problem went solved when you deactivate that plugin, but now it doesn't work again... What could be the problem?

March 20, 2019 at 3:45 pm #3390055

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

Yes, that plugin was the issue in the beginning.

Now, I don't know why it happens again.

Can you please let me know if you made any changes/edits on the site? Did you modify anything to the Elementor header element, to the homepage, or to WPML's settings, theme options or did you installed any plugins?

1. Also, can you please first create a full backup of the site and then update all the plugins here to the latest version:
hidden link

Please let me know if that helps somehow.

2. If not, please try this:

❌ Before proceeding please make a full website backup! ❌

Go to WPML -> Support -> Troubleshooting

Press the following buttons:
• "Clear the cache in WPML"
• "Remove ghost entries from the translation tables"
• "Fix element_type collation"
• "Set language information"
• "Fix terms count"
• "Fix post type assignment for translations"

3. If nothing changes, I would need to see the detail of the error log. You can see how to enable debug logging here:
https://wpml.org/documentation/support/debugging-wpml/

Go in your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:
define('WP_DEBUG', true);

Edit your wp-config.php file and add these lines, just before it says 'stop editing here':

ini_set('log_errors',TRUE);
ini_set('error_reporting', E_ALL);
ini_set('error_log', dirname(__FILE__) . '/error_log.txt');

This will create an error_log.txt file in your site's root directory. Please send me its contents through a link - using a service like pastebin.com.

I will be waiting for your response.

Kind regards,
Mihai

March 21, 2019 at 7:30 pm #3419379

ireneF-9

Hi,

I tried the 1st and 2nd steps without results. For the 3rd step I tried to find the expression:
define('WP_DEBUG', false)

But i couldn't find it within the wp-config.php file. Anyway i set it to true and try to follow the rest of the instruction, but no error_log.txt was generated.

The issue persist, I have notice a couple of interesting points that may help you in the troubleshooting:
- The language selector is only missing in the home page, the rest of pages seems to be unaffected by the issue.
- It seems that the english version of the page is missing in the production site.
- If you try to load the page in editor mode then, all work just fine, the language selector appears at the home page and it switch perfectly between languages. I will attach an images to illustrate my point.

March 22, 2019 at 2:58 pm #3441569

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

Thank you for the valuable information and for going through the steps.

I would like to duplicate your current site on a testing environment so that I can debug more on this but I will need your written approval.

Would that be ok with you?

I will be waiting for your confirmation.

Just a note that I won't be working on the weekend so I will be able to get back to you at the beginning of next week.

Kind regards,
Mihai

March 25, 2019 at 10:43 am #3452235

ireneF-9

Yes, you can!

March 25, 2019 at 3:07 pm #3455251

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

Thank you for the confirmation.

I will start the duplication process and I will let you know as soon as I have more feedback.

Kind regards,
Mihai