Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:

The Events Calendar Additional Fields are not showing for translation.

Solution:

1. On WPML -> Settings -> Custom fields translation.

Or at the Multilingual Content Setup section on each event editing screen, I set the fields that start with _ecp_custom_ to 'Translate'.

2. Then I update / re-saved the draft of the page.

3. And then I could get the fields for translation in the ATE.

This topic contains 12 replies, has 2 voices.

Last updated by Itamar 2 months, 3 weeks ago.

Assigned support staff: Itamar.

Author Posts
September 2, 2019 at 9:08 am #4495581

olafM-4

We use the Events Calendar pro and translate Events from English to German and Chinese. We have defined Custom fields for Events like Short_Title or Price_Tear_1 etc. The WPML settings are marked to translate these custom fields. The field content appears in the ATE, but when the new, translated page is created these custom fields remain empty.

Link to a page where the issue can be seen: hidden link

Edit the Event page and you see the Custome Fields propagated in English. Switch to another language and they are empty until we manually enter the data. With hundreds of events in the system that isn't fun.

It looks like we have found another bug in WPML.

Can you give us a patch, please?

September 2, 2019 at 10:08 am #4496063

olafM-4

I got the access details for you. Please open the private message field.

September 2, 2019 at 10:08 am #4496065

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Can you please let me have access to your site and explain to me in details where and how I can see this issue on your site?

If you need further help with this, please share the access details to your site with me.
I'm enabling a private message for the next reply.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- - Please make a backup of site files and database before providing us access. --

Thanks,
Itamar.

September 3, 2019 at 2:34 pm #4505371

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Hi and thanks for the access details.

I've checked things on your site, and I'm still trying to understand the issue. Thanks in advance on helping me with this. I've checked the event at the following link that you gave me as an example.
hidden link
Here is what I checked.

1. When I go to edit this event and check the ADDITIONAL EVENT FIELDS section, I see that you have filled the following fields.
A. Typ -> Opera
B. Title_kurz -> La Gioconda
C. Komponist -> Amilcare Ponchielli
D. Reisedauer -> 3 Days
Please see the attached screenshot additional-fields.jpg

2. Then I checked the Multilingual Content Setup section at the bottom of the editing screen of the event. And I could see the following settings.
A. -typ -> Translate
B. -titel_kurz -> Translate
C. -komponist -> Copy
D. -reisedauer -> Translate
Please see the attached screenshot additional-fields-settings.jpg

3. Then I pressed the button to edit the German translation of this event and I was transferred to the ATE screen. On the ATE screen, I could see the following.
A. The 'La Gioconda' string is showing for translation but is not translated.
B. The 'Opera' string is showing for translation and is translated.
C. The '3 Days' string is showing for translation and is translated.
D. The 'Amilcare Ponchielli' is not showing for translation.
Please see the attached screenshot fields-on-ate.jpg
So far everything as expected. The fields that are set to 'Translate' do show for translation and the fields that are set for 'Copy' do not show for translation (because they will be copied).
Please note that the translation is not 100% complete. And therefore none of the translation will show on the event when you view it on the site. The translation needs to be 100% complete for the translations to show.

4. Now when I check the event on the site (front-end), I do not completely understand where those fields (ADDITIONAL EVENT FIELDS) are showing. The only field value that I could find is the '3 Days' value. Please see the attached screenshot event-on-front-end.jpg. And please note that I'm checking the English event which is the default language of the site.

Can you please take it from here and explain to me where exactly the issue is?
Please attache more screenshots if needed. And remember that translations will not show on the front-end if the translation is not 100% complete.

Thanks,
Itamar.

September 4, 2019 at 12:20 pm #4510797

olafM-4

Hi Itamar,
thank you for your thorough analysis. I just created a new event to illustrate the issue. The error is still there. You can also create a test event yourself if this helps.
Here is mine. It is still in draft version, but you can publish it as well if you want. hidden link
I created the event in English. You can see the English version first. I filled all Additional Fields with some nonsense. Then I translated the event to Chinese. All Additional Fields appear empty in the translated Event.
You can create the German version of the event and will see that the Additional Fields do not appear after the Event is created in German. That is the problem.
The Custom fields were our own patch. We copy the content of the Additional Fields to the Custom Fields. These are visible in the ATE and can be used to display in the Front End. But this patch also kills us because it copies the Additional fields to the Custom fields every time you edit and preview the page. We always check the translated page before we publish it.
The bottom line, we need to know how to convince ATE to include the additional fields in the translation and then fill the Additional fields with the translated content. Then we can remove our "patch" that is not helping much.

September 4, 2019 at 8:04 pm #4513905

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Hi.

If I understand correctly, then it looks like you are mixing translation methods. If you chose to translate your pages with WPML's Translation Editor (classic or ATE), then you shouldn't edit the translation in the other languages with the WordPress editor. According to the screenshot that you have attached, it looks like this is what you are doing.

I'm not sure which patch do you mean when you write: "We copy the content of the Additional Fields to the Custom Fields." When I try to create a new event and insert values in the Additional Fields, they then show on the ATE. Please see the attached screenshot. Please note that they do not need to show in German or Chinese on the WordPress editing screen of the event. It can cause issues if you try to edit the translations there. Please read more about it on our documentation here.
https://wpml.org/documentation/translating-your-contents/using-different-translation-editors-for-different-pages/
Does this information help you with this issue?

Also please note that the are systems fields that are related to the Additional fields. If you click the 'Show system fields' link in the Multilingual Content Setup section, you will see them. Please see the attached screenshot. I'm not yet sure if their setting need to change, but we'll check it once you reply on the above.

Thanks,
Itamar.

September 5, 2019 at 3:26 pm #4520529

olafM-4

Hi Itamar,
The "Translate this Document" switch is always set to "Use WPML's Translation Editor". To simplify matters. Forget everything and please look at the new test Event I created for you. It is called "WPML Test 2" and is in the dev3 copy of our website. The Event is created in English. The Additional Event Fields are all field with placeholder text data. Then the translation is created with ATE by clicking on the "+" sign of the WPML Language tile. The ATE does not get the Additional Fields for translation. Period. Additonal Fields are missed.

If we also propagate the Custom FIelds, then these do show in the ATE. But the Additional Fields do NOT. Please see the Event here hidden link
Stay in the backend. Because, as soon as you select Preview or Publish a script runs that copies the content of the Additional Fields and creates corresponding Custom Fields with the same content. It is a failed fix of the problem. Just ignore it. It was our way of getting the information translated. ATE sees the custom fields, translates them and manages them correctly.
The two attached images should make it clear. The first image shows the event with Additional fields all propagated and no Custom fields exist. Then create the translation and as you can see only the Title of the event appears and no Additional Fields.

September 8, 2019 at 5:11 pm #4532091

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Hi.

I've created a test site with a fresh WordPress installation, and there I could replicate the issue. You can access it through the following link if you want to check things yourself.
hidden link
Through this link, you will be automatically logged in. (If nobody logs in the test site will be available for one week from today.)

I was able to find a workaround for this issue. Here is what I did.

1. On WPML -> Settings -> Custom fields translation.
Or at the Multilingual Content Setup section on each event editing screen, I set the fields that start with _ecp_custom_ to 'Translate'.
Please see the attached screenshot _ecp_custom_.jpg

2. Then I update / re-saved the draft of the page.

3. And then I could get the fields for translation in the ATE.
Please see the attached screenshot _ecp_custom_in-ate.jpg

I checked it on your site here and it works.
hidden link

Can you please confirm that now you can translate the Additional Fields?

I'll then consult our compatibility team whether this is the correct way to translate the additional fields.

Regards,
Itamar.

September 10, 2019 at 10:15 am #4543861

olafM-4

Itamar, that is great news. First, we went to see the test site you created and we found that the translation editor there is different from ours. It looks like you have a newer version that isn't yet released to us. Looks good. It shows Custome Fields and offers the content for translation. But the headline is confusing. In the Event page, these fields are called Additional Fields. Anyway, moving on to our own site we checked the settings of _ecp_custom ... fields. And we changed these to "translate". Then we actually got the field content showing up in the ATE also in our version. The test was successful. Additional event fields are now translatable. This solves the issue.
The question remains, how did you find out? How can one know that these "_ecp_custom_..." are the fields? The field count is different from the Additional event fields and the numbering of the fields is not in sequence and unrelated to the field name. Please help us to understand the remedy. We marked 21 fields but have only 14 in use.
Thank you.

September 10, 2019 at 4:19 pm #4547315

olafM-4

Itamar, this afternoon I updated a translation on our site and I got to see the new translation editor which you also have on your test site. It looked good and better than the old one. But the joy was short lived. We are back to the old version. What happened? Did you "play" and test it? The effect is that almost all translation jobs are now disappeared. They are no longer in the Job list. Not a problem, easy to recreate. Just wondering what is happening.

September 10, 2019 at 8:09 pm #4548775

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Hi.

I'm glad that my suggested workaround helped you to solve the issue.
I'll report this to our compatibility team, and they will try to see if a fix for this issue can be found. I think that it will hard to determine the field's exact name (number at the end) and therefore hard to get those fields automatically show on the Translation Editor.

I've found what is the name of the field by inspecting the field with the browser's developers tool. Please see the attached screenshot _ecp_custom.jpg. And then I've found those fields in the Multilingual Content Setup section after clicking the 'Show system fields' link.

It is OK to mark all the 21 fields that you have as 'Translate' and only use 14 of them. If you know that some of them only need to be copied, so you can set them to 'Copy'.

Regards,
Itamar.

September 11, 2019 at 3:59 pm #4555153
olafM-4

The translation of additional fields is resolved. Thank you very much. However, since that workaround is now implemented we are getting an error message from WordPress saying the WPML Media plugin is now failing.

---- automatic email from WordPress:
Since WordPress 5.2 there is a built-in feature that detects when a plugin or theme causes a fatal error on your site, and notifies you with this automated email.

In this case, WordPress caught an error with one of your plugins, WPML Media.

First, visit your website (hidden link) and check for any visible issues. Next, visit the page where the error was caught (hidden link) and check for any visible issues.
----
There are no visible issues, just this message when I edit a page and click "update":

The site is experiencing technical difficulties. Please check your site admin email inbox for instructions.

Could that be related?
Since you have access to the site, can you advise if the WPML Media feature can be turned off? We are only interested in translating image names and captions. We are not interested in using different images in other languages. We don't understand the feature.
If you think it is unrelated then this ticket can be closed.

New threads created by Itamar and linked to this one are listed below:

https://wpml.org/forums/topic/split-wordpress-caught-an-error-with-one-of-your-plugins-wpml-media/

September 12, 2019 at 11:19 am #4560437

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Great, I'm glad that it is solved now!

Good luck with your web projects 🙂
Itamar.