Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem: Trying to filter the events, added with Events Calendar, using the List /Month / Today filter in the secondary language result in a 404 page. Solution: Use these steps to fix the issue with 404 errors:

- Go to WPML -> String Translation - Enable the "Exact match" option - Search for the string 'month' - Select the all lower case string with "the-events-calendar" as Domain - Press the "Translations" link to the right - leave the string untranslated (same as original string) - Check the "Translation is complete" checkbox for all languages - Press the "Save" button - Repeat the above sequence for the "today" and the "list" strings

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 2 replies, has 2 voices.

Last updated by roxanneS 4 years, 1 month ago.

Assigned support staff: Vincenzo.

Author Posts
June 6, 2017 at 9:24 pm #1292631

roxanneS

I am trying to: Filter the events using the List /Month / Today filter
This is the same problem as thread https://wpml.org/forums/topic/the-events-calendar-incorrect-urls-404-errors/

URL of (my) website where problem appears: hidden link

I expected to see:
hidden link
hidden link
hidden link

Instead, I got: 404 page
hidden link
hidden link
hidden link

Steps to duplicate the issue:
Go to hidden link
Use the filter on the "Options d'affichage' on the right to filter by month, list or today.

By the way, on the referenced thread, your last suggestion was to change the default language to English, Uninstall and reinstall The Events Calendar.
This does not work.

June 8, 2017 at 2:27 pm #1294138

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/London (GMT+01:00)

Hello, thank you for contacting WPML Support!
I will take care of your ticket.

I was able to reproduce the issue in my test install.

Try these steps to fix the issue with 404 errors:

- Go to WPML -> String Translation
- Enable the "Exact match" option
- Search for the string 'month'
- Select the all lower case string with "the-events-calendar" as Domain
- Press the "Translations" link to the right
- leave the string untranslated (same as original string)
- Check the "Translation is complete" checkbox for all languages
- Press the "Save" button
- Repeat the above sequence for the "today" and the "list" strings

See the attached screenshot.

Please let me know if this solves the issue or if you need further details.

Thank you

events-calendar-slugs.png
June 8, 2017 at 3:20 pm #1294208

roxanneS

That’s it! Oddly enough, I could see month/list/today in the French translation, but I had to check the "Translation complete" box for everything to work.

Tnak you.