This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:

Make the flags beside each other.

Solution:

Copy this CSS code snippet to WPML > Languages > Language switcher options > Additional CSS

.wpml-language-switcher > a {
display: inline-block !important
}

This topic contains 6 replies, has 2 voices.

Last updated by annikaN-2 5 months ago.

Assigned support staff: Dennis.

Author Posts
May 10, 2019 at 6:05 am #3781521

annikaN-2

I am trying to: Get the flags beside each other

Link to a page where the issue can be seen:hidden link

I expected to see: The flags beside each other

Instead, I got: Get the flags one over the other after the latest update of wordpress

May 10, 2019 at 7:46 am #3782047

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

Welcome to WPML Support forum.

May I know how the language switcher was added to your menu? Did you add it from WPML > Languages > Menu language switcher?

Anyway, I would like to request temporary access (/wp-admin and FTP) to your site to take a better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. Your next reply will be set to private.

Maybe I'll need to replicate your site locally to continue debugging and escalate if necessary. For this I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Please confirm if this okay with you.

Our Debugging Procedures
I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to BACKUP the site before providing us access.

Privacy and Security Policy
We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Kind regards,
Dennis

May 10, 2019 at 7:53 am #3782065

annikaN-2

Thank you for your fast answer, I have put the code in function.php because I don't want it in the menu for then on mobile devices you need to open the menu to see it.
I have no field under the comment field to put the ftp and wp-admin?

May 10, 2019 at 7:56 am #3782077

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

Thank you for your reply.

I have now enabled the access information box.

Kind regards,
Dennis

May 10, 2019 at 8:54 am #3782397

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

I can see that you're using a custom code for your language switcher which would also require custom coding to fix the issue.

However, custom work is currently not supported in the support forum but I can give you a hint.

Could you please try to copy this CSS code snippet to WPML > Languages > Language switcher options > Additional CSS

.wpml-language-switcher > a {
display: inline-block !important
}

I am not sure if it will work on your end and may require custom work to make it work seamlessly with your theme. For custom programming work for your site, we recommend contacting one of our certified partners .

https://wpml.org/documentation/support/wpml-contractors/

Kind regards,
Dennis

May 10, 2019 at 9:25 am #3782753

annikaN-2

Thank you work perfect

May 10, 2019 at 9:25 am #3782755

annikaN-2

My issue is resolved now. Thank you!