This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 9 replies, has 2 voices.

Last updated by Bruno 1 year ago.

Assigned support staff: Bruno.

Author Posts
September 7, 2018 at 8:07 pm #2715841

massimo lorenzini

Hello my client tell me that site having problems whe he go to a specific page
in the admin panel.
The page display all the properties (wordpress configured for a real estate agency).

i have read something in your forum like "delete" the old version of plugins:
sitepress-multilingual-cms
wpml-string-translation
but after the reainstallation where all goes fine, the plugins says:
WPML ha bisogno di impostare le lingue per i contenuti multimediali del tuo sito.
doing that a get parse error ...and the prolem still present.

here the full line of error:
<b>Fatal error</b>: Call to undefined method wpdb::get_active_languages() in <b>/web/htdocs/www.immobiliareseveso.it/home/wp-content/plugins/sitepress-multilingual-cms/classes/menu-elements/class-wpml-custom-columns.php</b> on line <b>107</b><br />

removing the plugin the page works ....

may you help ?

thx in advance

September 10, 2018 at 11:59 am #2719830

massimo lorenzini

NO one can help me ?

September 10, 2018 at 6:58 pm #2721239

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you for contacting us. Please, my sincere apologies for the delay in answering.

Apparently, you're using the "Real Homes" theme, correct? If so, please could you update your theme to the latest version and check if the problem persists?

If the problem persists, I'll need to request temporary access (wp-admin and FTP) to your site - preferably to a test site where the problem has been replicated if possible - in order to be of better help.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Note:

*** Please let me know exactly what steps should I follow to see the problem.

*** Please, can I install the Duplicator or All in One Migration plugin to make a copy of your site and install it on my test environment? This will help me debug the problem.

*** Note: Please make a full backup of your site.

Privacy and Security when Providing Debug Information for Support: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Thank you.

September 10, 2018 at 9:45 pm #2721525

massimo lorenzini

Hello Bruno! thx for your answer, but, after the update of the theme and WP i still have same problem.
I'll grant you the access to see what happen, but first i have to disable the filter of ip address for FTP.
I'll reply you asap.

Thank you!

September 11, 2018 at 3:03 pm #2724335

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

Thank you. Sure. Your next response will be private so you can add the credentials privately, where only our team and I can see the credentials. Please, let me know when you're ready.

Thank you.

September 12, 2018 at 9:41 pm #2729139

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you. I saw the problem you're reporting. This seems to be happening because of some compatibility problem.

Please, can I install the Duplicator or All in One Migration plugin to make a copy of your site and install it on my test environment? This will help me debug the problem.

Thank you.

September 14, 2018 at 12:12 pm #2735298

massimo lorenzini

yes pls! do all u need 🙂

Thank You!

September 14, 2018 at 4:58 pm #2736222

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you. I noticed that you are using a very old version of your theme. You are currently using version 2.7.0. On your theme page, however, I see that the latest version is version 3.6.0, which was recently released.

Could you please update your theme to the latest version to see if the problem persists? As the message to update your theme does not appear, you may need to update it manually by downloading the latest version directly from the theme author's site and then updating the theme files.

After following these steps and updating your theme, please let me know if the problem persists.

Thank you.

September 22, 2018 at 2:40 pm #2757616

massimo lorenzini

thx Bruno for your support.
Now i can use again the properties page , but when i modify a property or i create a new one i can't mange media. i think now the problem is theme related.

agree ?

September 25, 2018 at 4:17 am #2762470

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thanks for updating the theme. Glad to hear that it now works.

Ideally, to see the problem with the images, I should suggest for you to disable all the plugins for you to test if the images are going to be uploaded properly.

If the issue is resolved, enable the plugins one by one to see if any of them are causing problems.

If the problem persists, may I kindly ask you please to open a new ticket for your new question? This will also help other users with similar problems find solutions when searching the forum.

Thank you.