This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 1 reply, has 2 voices.

Last updated by Itamar 1 month, 3 weeks ago.

Assigned support staff: Itamar.

Author Posts
August 22, 2019 at 10:23 am #4438345

bertyL

I am trying to:
The German language from my page turned off for the second time in a week. I don't know what the problem is. It happend automatically. I was adding some products this time.

Link to a page where the issue can be seen:
hidden link it's all over the website
I expected to see:

Instead, I got:

August 22, 2019 at 10:38 am #4438379

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

This chat has been inactive for quite a while so I'm transforming this chat into a support ticket because I believe you're still encountering the problem. You'll still be troubleshooting the problem with me and this way we will not lose any progress made so far.

I can see the issue on your site. Please see the attached screenshot.
Have you translated all your site's pages?
Is some of your site content set to 'display as translated'?

Please fix the following and see if it helps to solve the issue.

By looking at the debug info that you have attached I can see that your server WP Memory Limit is set to 40M.
Our recommendations are to have the following as minimal requirements:
- PHP 5.6 and above (this OK with your installation) with a WP Memory Limit of at least 128MB and more if possible.
- MySQL 5.6 and above (this OK with your installation).
Please follow this link for detailed documentation:
https://wpml.org/home/minimum-requirements/
Is it possible for you to change those to the minimum requirement?
You may need to contact your hosting provider for that.
Meeting those baseline requirements is most critical before starting to debug and sometimes solves issues like you experiencing.
Most important is to raise the WP Memory Limit.
Please try to raise it before you contact your hosting company.
You can try and do it from the wp-config.php file in your WordPress installation.
Insert this code in that file.

/** Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

Add it before this line:
/* That's all, stop editing! Happy blogging. */

Could you please perform that procedure and see if it help?

Thanks,
Itamar.

The topic ‘[Closed] The German language from my page turned off for the second time.’ is closed to new replies.