This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 11 replies, has 2 voices.

Last updated by Katriel Reichman 2 months, 2 weeks ago.

Assigned support staff: Noman.

Author Posts
July 21, 2019 at 4:39 pm #4252823

Katriel Reichman

On the Hebrew site, the whole page becomes very wide and the content is not visible unless you slide the whole site over.

We changed the theme on the site, activated and deactivated plugins, but it didn't help.

July 22, 2019 at 9:21 am #4255413

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support. To take a closer look on this issue, please provide temporary access (WP-Admin and FTP Login info) to your site (preferably staging site), so that I can look into your setup and debug the issue.

Your next answer will be private which means only you and I have access to it.

=== Please backup your database and website ===

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

✙ Please provide me page URL where I can see this issue.

Thank you

July 24, 2019 at 8:38 am #4271573

Katriel Reichman

I give you permission. Can you please send me the email you would like to use for your admin access? Thank you!

July 24, 2019 at 9:19 am #4272305

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

My email: [removed]

July 25, 2019 at 9:02 am #4281143

Katriel Reichman

Thank you. I made you an admin of our staging site. You can log in with your email to hidden link

I am sending you the FTP credentials via email.

July 26, 2019 at 9:30 pm #4291935

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Sorry for some delay. I was able to login to your staging site successfully. I am OFF on Fridays and Saturdays (my weekend), I am going to work on this issue on Sunday and will get back to you asap.

Thank you for your cooperation and patience.

July 29, 2019 at 5:20 am #4297027

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

I have visited your site in latest Chrome and Firefox browsers but I can not see site wide issue as you can see in the attached screenshot. Could you please clear your browser cache and take another look on it.

If still issue persists, please show us where the issue is with highlighting in screenshots so we can help

Thank you

August 1, 2019 at 11:16 am #4321015

Katriel Reichman

The support forum seems to be working again.

Here is a screenshot of the issue on mobile devices. I literally just see a purple page.

August 4, 2019 at 1:00 pm #4336395

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Sorry for the delay, we ran into the weekend. There are some CSS properties written in your theme that causing this issue. I have fixed this issue by adding the following CSS in Additional CSS section of your theme:


body {
	overflow:visible;
}

.rtl iframe#st_gdpr_iframe {
    left: 0 !important;
}

And now it looks as in the attached screenshot in mobile devices. Could you please check and confirm?

Thank you for your cooperation and patience

August 5, 2019 at 10:49 am #4339935

Katriel Reichman

Thank you! The site looks great mobile devices (you fixed the issue for mobile), but the Hebrew site (internal pages) still does not look good on desktop. When I go to the bottom of the page, and scroll to the left, the screen turns purple. I am attaching a screenshot. Thanks!

August 5, 2019 at 4:26 pm #4342009

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

I have updated the CSS as follows:

@media(max-width:992px) {
body {
	overflow:visible;
}

.rtl iframe#st_gdpr_iframe {
    left: 0 !important;
}
}

Could you please take another look on it.

Thank you

August 7, 2019 at 10:36 am #4353879

Katriel Reichman

My issue is resolved now. Thank you!