This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 18 replies, has 3 voices.

Last updated by Alejandro 1 month, 1 week ago.

Assigned support staff: Alejandro.

Author Posts
August 15, 2019 at 9:32 am #4399921

stefanP-20

I am trying to: make the home page to sync

Link to a page where the issue can be seen:

I expected to see:

Instead, I got: an old page in english

August 15, 2019 at 9:46 am #4399981

stefanP-20

ehe n I write homepage, I meen frontpage!

August 15, 2019 at 10:02 am #4400071

stefanP-20

Now I also translated the page : BILDER/ GALLERY and it does not come on in english....

August 15, 2019 at 1:56 pm #4401323

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thank you for contacting WPML support. I'll be happy to help you with this. It looks like the homepage is now showing for both pages, so it seems you have got that part resolved.

As for the gallery page, how are you creating the content for this page? Are you using a page builder? Have you synced your images to all languages? You can do that at WPML -> Settings -> Media Translation. If you can tell me a little more about how you add the content to this page, I will be better able to help determine how to translate it. Thanks!

August 15, 2019 at 2:36 pm #4401639

stefanP-20

hello,

the frontage problem is not that it is not showing!! the problem is that it is not the same page as the swedish one if you look carefully....

the gallery page: It is created the same way as all the other ones, with text modules and gallery modules. I translated it in your advanced translator this morning to 100 % andd then synced the pages as I have done with all pages so far.

August 15, 2019 at 2:38 pm #4401665

stefanP-20

settings:

Set language information for existing media
x Translate existing media in all languages
x Duplicate existing media for translated content
x Duplicate the featured images for translated content
Media Translation Documentation

August 15, 2019 at 4:07 pm #4402311

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Please send me a screenshot of what missing content you are seeing on the homepage. I am not noticing any content sections missing or different in either language.

Also, in order to look deeper into the gallery page, I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

August 16, 2019 at 1:44 pm #4406629

stefanP-20

hi again,

now I updated the swedish pages with some new images/ photos since we rebuilt. But the english pages do not change even after updating the translations.... You do have to explain what to do with media / images translations since their is no easy way to find it in the tutorials, sorry!! Why do not the images change on the already translated pages???

August 16, 2019 at 2:41 pm #4407015

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

In regards to the homepage, the only difference I see is the content in the last section of the page. I see there is an hr tag in the English version, and not in the default language. I can see the different content when I view the page in manual translation, and also I can see the string in WPML -> String Translation. You can update the content in either place and it should show on the front page. Please see attached screenshots.

For the Media page, I recommend deleting the English translation. Remove it from the trash as well. Then, duplicate the original page to English. After this, you can click "Translate Independently" to change the English content. Please let me know if the content shows after that.

As for the issue with Media not updating, please open a new ticket for this separate issue so that it can be addressed specifically.

August 17, 2019 at 6:49 am #4409435

stefanP-20

hello,
1. frontpage: there is a lot of difference between the two languages, look at the blurbs!!!! And I do not understand te things you are writing about.... hr code? string translation? not even my web lady knows what string is.......
2. Tried to delete the photo gallery page but can not......

August 19, 2019 at 1:26 pm #4416461

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

1. You can find string translation in WPML -> String Translation. In the drop down menu, select pagebuilder_shortcode_strings_3025 and you will see the content from the original page. Here, you can update the translated content and then let me know if it displays correctly on the frontend of your site.

2. To delete the page, please click on Pages. Then, use the admin language switcher at the top of your dashboard and switch to your secondary language. From here, you can check the box next to the page and then send the page to trash. Once you have done that, be sure to go to the trash and make sure the page is permanently deleted. Then, try duplicating the page and let's see if the content displays.

Please let me know the results.

August 20, 2019 at 8:38 am #4421645

stefanP-20

1. front page almost works now, the two blurbs on the right are still in swedish and I can not find out how to translate them!!!
2. Deleted the page. Then I don't know what you mean by "duplicate the page"??
But I guess you mean translate so I sent it to the translation , synced the menus again but it still does not show

August 21, 2019 at 12:41 am #4426863

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

If you are creating these as Divi Blurbs, make sure you have gone to Divi -> Library and translated the blurb there. Does that resolve the issue?

As for duplication, once you delete the translated page, when you view the original page in the page edit screen, there should be a checkbox to tick to "Duplicate" the page. This is the way I would like you to try and translate. Please let me know if that makes any difference.

August 21, 2019 at 2:06 pm #4432077

stefanP-20

hello,
blurbs: Of course they are Divi blurbs, what else could they be? all blurbs are DIVI, but these 2 does not translate......
I will try the duplicate thing.....

August 21, 2019 at 6:12 pm #4434521

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I should have asked are the two blurbs that are not showing the translation set as Global blurbs? If you go to Divi -> Libraries, I can see that most of the content there has not been translated, Are these blurbs found there? And if so, please translate there and let's see if that resolves the issue on the homepage.

Let me know how it goes with the Duplicate feature. Thanks!