This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 2 voices.

Last updated by dimitraP-5 4 months, 2 weeks ago.

Assigned support staff: Yvette.

Author Posts
May 22, 2019 at 10:15 am #3864151

dimitraP-5

I am trying to import WooCommerce products in two languages. I have two separate csv files. I am importing the csv with the primary language at first and set the unique identifier as sku. Then I import the second csv of the second language and set the same unique identifier. When the products are imported, their translations aren't linked.

Link to a page where the issue can be seen:
Original product: hidden link
Translated product: hidden link

When I tap on the English flag of the original product, I expected to see the english translation.

Instead, I got: hidden link

May 22, 2019 at 11:47 am #3864893

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

1. Could you please confirm what type of product you are importing? Are they "simple" or "variable"?

2. The import of a product not connected with the 1st language was an existing issue that was resolved with v3.0 of the Woocommerce addon. You installation information lists an older version of this add-on being used.

Please confirm that you are using the latest available version of the plugin.

May 23, 2019 at 10:24 am #3873611

dimitraP-5

Hi Yvette,

1. I am importing only simple products.
2. I am using WooCommerce v.3.6.3, WP All Import v.3.5.0, WPML All Import v.2.1.1. All of my plugins are updated.

May 24, 2019 at 8:43 am #3882493

dimitraP-5

I deleted all the products in my store and imported them from scratch, but I still face the same issue.

May 24, 2019 at 9:12 am #3882799

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hmm - I think the best way to handle this is for you to try to import your products into a clean sandbox site that I have prepared for your with WPML and WooCommerce.

hidden link

Please upload the WP All Import and WPML All Import Multilingual plugins and then create a small sample with one or two of you simple products so we can look at it. If you can include a screencast of how you are defining the linking between products - this woudl be most helpful.

Thanks

May 24, 2019 at 11:02 am #3883769

dimitraP-5

Thank you for setting up a debugging environment!
I have added screenshots of all the steps that I took. As you can see, the products are still not connected to their translations.

May 27, 2019 at 9:05 am #3895013

dimitraP-5

Hello, are there any updates regarding my issue?
Thank you in advance.

May 27, 2019 at 5:39 pm #3900071

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

I connected to the site and reviewed the jobs that you ran. I could not see that you included a unique identifier in the "Automatic Record Matching to Translate" part of the import (see image).

You need to include the information there so that the import links the two products.

Can you please try your import again and make sure you enter this information as per the documentation here:
https://wpml.org/documentation/related-projects/wpml-all-import-plugin-website-import-with-wpml/#how-to-import-woocommerce-products

May 28, 2019 at 8:14 am #3903899

dimitraP-5

My issue is resolved now. I believed that the connection between the translations was only made through the final step of the importing process. Thank you so much!