This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 2 voices.

Last updated by Shekhar Bhandari 3 weeks ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
October 2, 2019 at 5:44 am

desmondN

I have places the custom language switcher into my theme.

However, the translation is not working properly. The translations in the theme strings are ok, but for the title and description, it is not changing to the translated text. Kindly refer the short clip below

Also, if I have switched to Malay, I try using the search box to find another listing, the new page will load in English instead of Malay. How do I make the language change persistent until I change the language again? Here's a screenshot: hidden link

Also, how do I define my website structure so that the malay pages will load for hidden link and for future, the chinese version will load for hidden link?

October 2, 2019 at 6:13 am
October 2, 2019 at 6:19 am #4677269

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Can you please let me know where you have translated this?

Also, are you aware which plugin is creating this timetable?

Look forward to your reply.

Thanks

October 2, 2019 at 7:44 am #4677513

desmondN

Hi, I use the translator on the right side of my WordPress Backend : hidden link

Is it because I need to make sure the translations are 100% before they will show?

The timetable is not a plugin, it's together with the theme

October 2, 2019 at 8:12 am #4677685

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Is it because I need to make sure the translations are 100% before they will show?

Yes, you will need to make the translations 100% before they will show at the front-end.

The timetable is not a plugin, it's together with the theme

Can you confirm with your theme author if this is translation-ready? Or is there any settings from where we can rename/edit those strings?

Look forward to your reply.

Thanks

October 2, 2019 at 9:18 am #4678147

desmondN

Hi Shekhar, I will check with my author.

Moving on to point 2 and 3,

Also, if I have switched to Malay, I try using the search box to find another listing, the new page will load in English instead of Malay. How do I make the language change persistent until I change the language again? Here's a screenshot: hidden link

Also, how do I define my website structure so that the malay pages will load for hidden link and for future, the chinese version will load for hidden link?

I just realized most of my images are not loading in the other language

October 3, 2019 at 1:38 am #4683715

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Also, how do I define my website structure so that the malay pages will load for <em><u>hidden link</u></em> and for future, the chinese version will load for <em><u>hidden link</u></em>?

Use the language format as directories, https://wpml.org/documentation/getting-started-guide/language-setup/#language-url-format

Also, if I have switched to Malay, I try using the search box to find another listing, the new page will load in English instead of Malay. How do I make the language change persistent until I change the language again? Here's a screenshot: <em><u>hidden link</u></em>

I can see the issue, can you try to use language URL format as directories /ms/ instead of ?lang=ms and see if this helps?

For other issues, I request you to open a new ticket. So it will be easy to debug and provide help on those issues.

Thanks

October 3, 2019 at 2:03 am #4683749

desmondN

Ok, I just used my url and it seems to have worked.

The current URL is displayed as url/ms/page, how can i change the displayed name to url/bm/page? Locals here prefer "bm" over "ms"

October 3, 2019 at 2:11 am #4683807

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

You can just use "Use directory for default language" and leave other settings.

For using root file or page you will need to create it yourself, so if you aren't sure please use the above settings.

Let me know if this helps.

Thanks

October 3, 2019 at 2:17 am #4683835

desmondN

I just used the home url and it worked.

The current URL is displayed as url/ms/page, how can i change the displayed name to url/bm/page? Locals here prefer "bm" over "ms"

October 3, 2019 at 2:20 am #4683871

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Please use the solution as provided here and let me know if this helps:
https://wpml.org/faq/how-can-i-assign-or-change-language-code-to-existing-content/

Look forward to your reply.

Thanks